Troubleshoot MMOS to Simucube (MMOS Firmware retained)


#1

I have an issue with #2 Bootloader fails to upload to SimuCube and MMOS Firmware is retained

My hardware configuration:
-drive type
-motor type/model: mige 130 ST

Problems arise when:
-I wanted upgrade MMOS to Simucube, i followed a tutorial and MMOS still open when i tried to upgrade the .dfu

How it behaves:
-When i try to launch for the first time Simucube configurationn the wizard does’nt appear.
In my devices windows appears Simucube in Firmware Mode but nothing happen.

To pass in DFU mod i need to change the position of dip switch and i put the Simucube Boot.loader 0.11.2 extract directly on my desktop.

I already tried everything on wiki on this step #2 Bootloader fails to upload to SimuCube and MMOS Firmware is retained with success

I dunno really how to know my devices inside the Augury box. I can only tell you i bought 2 years ago

Thanks in advance to help me


#2

Hi @6DYoOz!

It looks like you have successfully uploaded the the DFU file using DfuSeDemo as the Simucube in Firmware Upgrade Mode is indeed visible in the Devices.

Which motherboard are you using at the moment? There is a known issue in that some AsMedia and VIA chipsets are unable to communicate properly with the firmware.


#3

Yes. I think the upload is good.

My motherboard is [Gigabyte GA-H97-HD3.


#4

Interesting, that motherboard should have only compatible chipsets if its the Revision 1 of the motherboard.

We are investigating.


#5

Thanks for investigating and take my issue seriously.

I have a race sunday. Do you think you could find the problem easily?

Could i easily backup with MMos 2014, if needed?
I don’t have the mmos.hex anymore.


#6

https://files.fm/u/u9x38ntc here you are


#7

If you are using .11.2 then use the boot loader file that says reset all settings or something to that effect… The standard bootloader has an issue and will fail to install.


#8

Hi

I’ve just tried this bootloader, unfortunely without sucessfull.

I also seen that i don’t have any devices as Simucube in firmware mode in windows device manager.
It appears only in USB Deview


#9

You connect straight to the usb or maybe through hub? Have you tried both usb 3.0 and the usb 2.0 ports?


#10

I connect straight to the USB 2.0.
I already tried the bot configuration yesterday.


#11

You reverted to mmos and it works as it did?


#12

Yes, it has worked great.
I am working on device setup on it.
Anyone have a device setup configuration for an Augury with 10000 points encoder?


#13

I think this will work Follow the problems Small MiGE 10k test2.drc . Have you updated your ioni firmware?


#14

No didn’t update IONI firmware because i believed your .dfu have the both.


#15

Wouldn’t hurt to check just to be sure.

Don’t forget to also setup mmos with settings , pwm & dir , 3.4Khz and 40000cpr


#16

How could i know the firmware of my ioni?

I tried with this setting but my motor doesn’t have any rotation lock, and seems like strange comportement like some vibrations.


#17

How did you load the drc? with the same program granity you can check the version of your ioni

It could be your mmos settings but you could also try another drc given here by mica


#18

What do you mean by drc?

I cannot acces to Simucube Sotfware to check my configuration because everything is grey and disabled.

Should i download the granity software to check something?


#19

You have to use latest granity (also you have to connect the 2nd usb to your computer) connect to see what ioni firmware you are currently using and also load the drc file if your motor settings are lost. You could either load mine or the one from mika to check.

If the motor parameters aren’t lost take pictures of all the tabs or save them as drc for reference.


#20

I send you a screenshot of my configuration