Project Cars 2 and Simucube 2

Again, thanks for all. Still no luck. Just to reply to several comments since I last replied:

I don’t currently have anything but my pedals and SC2 installed. My pedals work fine.

I deleted all Fanatec stuff, included the Fanatec-branded desktop folder which had calibration and test software in it. But I did find and use the Windows 10 calibration screens in Device Manager before starting True Drive or PC2. Those seem to be set up for a hand controller, even for the Simucube ‘device’. So I just used the X and Y calibration in the first step, then just hit enter for the remaining screens without entry.

It seems SC2 is set up from scratch with 900deg. rotation, but I did use that, and also set up some hard ‘bump stops’ at +/_135 deg. I set True Drive up so that these were very hard stops that couldn’t be exceeded. I bumped the wheel off of those stops, but still no luck. I think I had less than 900deg. settings with the hard bump stops, so I’ll try that again with 900deg, but doubt it will change anything.

So no luck with anything. Just another comment; Although my right steering did assign, I’ve still been unable to get left steering to assign. Although my wheel registers in Windows 10 calibration steps, my wheel does nothing in the PC2 calibration routine. I’m assuming that’s because left steering is still not assigned, but neither right, nor left steering works in the PC2 calibration screen.

That’s status as of now. Thanks for all the help posts. I will definitely post when/if I get the SC2 set up with PC2.

Edit- PS, I have tried multiple USB connections on my PC. I did build this PC, but I’m not completely sure if all my USBs are 3+… some are definitely 2+. I did buy a separate USB 3.1 multi-connection expansion board that I have not installed. I may install that to use with all my controllers just to be sure. Hard to believe, though, that USB 2.0 or above would be restricting in any way a simple steering input. I do also have a USB aftermarket keyboard and MS USB mouse installed.

Sorry to hear your still having problems mate. Sounds very strange.

I’m wondering if a Steam file integrity check might be worth a try, just in case some PC2 files are missing or somehow corrupted?

I don’t remember if its left or right but one of them is assigned to a pedal also. Just change it to anything but what it is before trying to set up the wheel and it should work.

Thanks Paul… that is a good suggestion. I was planning to give that a try when I finally managed to get it working. See my post below…

Thanks morpwr. I decided to disconnect my pedals, and just try to calibrate my SC2 in PC2 without them connected. I FINALLY managed to get both left and right steering assigned in PC2, and now everything seems to work Ok. See my post below…

Well, I FINALLY managed to get my SC2 left and right steering assigned in PC2. Here’s what I did, although I can’t say it’s necessariy a true ‘solution’. But everything works now.

morpwr mentioned pedal assignments, and I decided to try to get the SC2 left and right assigned after disconnecting pedals completely. Didn’t seem to help at first. But then I also took the step of deleting the normal Rx, Ry, and Rz assignments in the pedals (I assigned buttons). I then also assigned buttons to both left and right steering, as an effort to try to start from scratch.

One thing I hadn’t mentioned was that PC2 assigned X- to my right steering initially. Since I had luck assigning right steering Ok, I did try to reassign right steering several times, and was successful a couple more times. Each time PC2 assigned X-.

I think X- is more typically assigned to left steering and not right. But that’s what PC2 did, and so when I tried to assign left steering, it either failed to assign (no assignment) or I rec’d the ‘multiple assignments’ message. Strange, since for other functions besides steering, it will just ask you if you want to reassign if that is a duplicate. So apparently PC2 was attempting to assign X- to left steering.

So since I reassigned both left and right steering to buttons, I then again tried to assign them, starting with left steering. Sure enough, this time left steering was assigned X-, and then right steering was assigned X+. I then shut down my PC, reconnected my pedals, and successfully assigned each pedal. Seems to all work now!

I can’t blame Sim Creators for allowing automatic assignments, and for buyers wanting to have that. But in this case, automatic assignments caused me MAJOR PROBLEMS AND HOURS OF WORK, which I don’t understand. If it doesn’t work right the first time, PLEASE give me a manual option with a dropdown list of assignment options that allow me to change anything to anything else in an instant!

Also, would be nice at this point, if PC2 would list Fanatec and Simucube 2 DD options in the wheel options. Hardware options are changing every couple months it seems. No excuses for not keeping up!!

Thanks again for all the helpful suggestions and input!


Marking this thread/post RESOLVED.


My part of it is resolved though.

Yeah, extraordinary amount of troubles for you :frowning:

But, PC2 is end-of-life now, they have already moved on. No way to add support for new devices etc.

1 Like

Thanks for Granite’s willingness to allow my posts to continue- since it ended up not being an SC2 issue, I’m sure. I didn’t know what the problem was at first.

I spent hours trying to figure that out. Checked diview couldn’t find anything then finally caught that one of the pedals and one of the steering assignments are the same. Glad it worked for you.

Hello everyone. I’ve been pretty puzzled by SC2 FFB I’m getting in Project Cars 2, and have not been able to resolve the issue. Problem is that I’ve never been able to generate ANY WHERE NEAR the kind of torque/NM that the SC2 is capable of, or that I was able to generate with ACC after I installed it (brief test after rudimentary start up).

I feel no surface nor curb feedback at all. I have both SC2 and PC2 set at 100% gain (Advanced mode, Enable High Torque). And yet I was able to generate more force with my Clubsport 2.5. I did download and tried ‘Hugo Vai’ (spelling?) wristbreaker mode, which is a beast with only TD running, but after starting PC2, FFB almost disappears.

I know that PC2 has a rep. for having poor FFB, but is this normal? How much FFB do other SC2 users get in PC2? As mentioned, I immediately felt surface and large FFB force after inital setup and control assignment in ACC. Any input appreciated.

One other oddity… with only TD running, Simple/read only mode, when pressing ‘Enable High Torque’ FFB all but disappears (no sim running). Disable High Torque in Simple/Read Only and force returns. Extremely weird!!

Appreciate any feedback… would really hate to abandon PC2 now that I have SC2 installed.

The low torque mode has additional damping and friction. It is not FFB. Create a profile, then it will give you control over the feeling.

Thanks for the feedback, Mika. I wasn’t aware that low torque was only damping and friction.

But even in High Torque mode in Simple or Advanced, I receive low or no torque in PC2. Today I ran the following test with the Factory/OEM Project Cars 2 Profile.

Conditions: Running on Steam, TD minimized after settings set, PC2 Gain 100%, Factory PC2 Profile loaded in Simple mode. When TD indicates “Save Settings to Simucube”, I press that button and wait for that notice to dim.

Simple Mode, Low/Safe Torque: I do feel some resistance to steering with factory settings
Simple Mode, Enable Hi Torque: I do feel increased resistance to steering UNTIL PC2 completes starting with my selected car and track. Then all resistance to steering DISAPPEARS. Resistance to steering inputs is ZERO.

When I enter Advanced Mode following loading PC2 factory settings in TD Simple mode, I see what I assume are Granite’s detailed PC2 factory settings. Results I get in either Simple or Advance mode with Granite PC2 settings in TD are the same as in Simple mode… some resistance to steering input in Low Torque mode, but ZERO resistance to steering input in High Torque Mode.

Adjusting Gain/Force to max or min. in either Advanced or Simple mode in High Torque Mode makes NO difference in my results in PC2.

Very puzzling to me, even though I have read PC2 FFB is poor compared to other sims. And as mentioned, I have loaded other enthusiast settings .txt files such as Hugo Vai’s with no change in my results in PC2 once in-game.

As mentioned, I have perhaps 20-30min. brief test time in ACC after installing that recently and FFB seems to work as expected. I can achieve Copious FFB! :slight_smile:

Any input of other PC2 users’ experiences re: SC2 FFB in PC2 much appreciated. Thanks again.

Did you delete your old wheel profile? Because something is definitely wrong.

Thanks… I deleted my Clubsport 2.5 profile 10 days or so ago when I was having huge trouble trying to get my SC2 to assign steering in PC2.

I checked, and I currently don’t have any Project Cars 2 folder under Users\MyName\

So I may have deleted too much. I kind of assumed that PC2 would create what folders it needed when I got the SC2 installed and set up, after I deleted the old Clubsport profiles. Jim-Power posted the following 11days ago:

C:\Users\YourName\Documents\Project CARS 2\savegame\10064461\project cars 2\profiles\default.controllersettings.v1.03.sav

I currently don’t have anything for SC2 listed there and nothing after YourName\Documents. Did I mess up? Suggestions? Thx


Did you carry out a Steam file integrity check?

I suggested trying that out earlier in the thread when you were having the wheel assignment problem.

Give that a try if you didn’t before and if that doesn’t work, I’d just do a complete uninstall/reinstall of PC2 as something really must be off.

1 Like

Here is what I have if you need to compare:

Documents > Project CARS 2

steamapps > common > Project CARS 2

1 Like

I’m just going to ask to make sure, your volume isn’t at 0% right? You control the FFB strength via volume in PC2, and let gain be at 100%

@EXOTICS4LIFE strange, never had any problem at all with pc2.

the right procedure is :

1 - in the first page of the controls menu (where you can choose multiple types of wheels each with his own image displayed), select “custom” as no presets exists for dd wheels;
2 - assign the steer left / steer right inputs in the “assign commands” menu (where you map every command )
3 - go into the “calibration” menu at the bottom of the 1st page of the controls menu and turn left and right the wheel to let the game recognize the inputs you already mapped before in point 2 and then turn the wheel 90° left (or right i don’t remember exactly) to let it recognize the degrees of rotation you have in your wheel sw (true drive in our case)

that’s all, i mean it is a bit clunky as procedure, no doubt about it, but that’s the way it has to be done.
before doing this, i suggest to delete your whole doc/project cars 2 folder. tell me if it works.

Looking the same to Pauls :slight_smile: