New SC2 Pro - Sudden loss of ffb - Estop related?


I’ve recently purchased the Sc2 Pro (about 2 weeks ago). Since the very first day I’ve been getting ocassional loss of ffb in various forms.

  1. short ffb loss (1-2 sec) without beeps, ffb comes back after that
  2. complete ffb loss without ffb coming back, without beeps. Cleared with Estop cycle
  3. complete ffb loss, followed by sc2 startup beeps (turn on sound + 4 beeps). Log attached.
  4. short ffb loss with 4 beeps, ffb comes back after that. Log attached (note I had pressed the Estop before the actual ffb loss due to a bolt coming loose on the pedal)

It’s a bit weird that sometimes there are no beeps. But when there are beeps, it’s always 4 beeps (can’t decide whether it’s increasing in volume or constant :D) similar to releasing the Estop so I’m thinking there might be a problem with the Estop?

Actions already taken:

  • checked other threads regarding sudden loss of ffb
  • disabled no hands feature (also tried it on low)
  • repositioned Estop so it’s clear of any other cables/equipment
  • replugged the Estop and all other cables
  • checked usb throughput rate, Usbview says full speed which is equal to usb 1.1 (is that correct? I was expecting high speed or superspeed)
  • tried every single usb port
  • tried minimal usb port used
  • bought a dedicated startech pcie usb card

simucube_debug_onstraight_sudenlossffb_beeping_like_poweron.txt (11.1 KB) simucube_debug_onstraight_shortsudenlossffb_4_beeps_increasingvolume.txt (22.1 KB)


Your issue is strange for sure. When you have it, does the steering continue to track on-screen and in the game?

Hi Mika,

  • Not sure about the virtual steering wheel, I always have ingame wheel off. I’ll turn it on and check.
  • Wheel does not track anymore (as in the car goes straight instead of reacting to input) with the big ffb loss
  • wheel does seem to track with the small ffb loss. Could be placebo cause it lasts really short, not 100% sure.

Happens in all sims I’ve tried sofar (ACC, Raceroom, AMS2). Also just remembered I had a fault location error once, luckily I googled it so history to the rescue :slight_smile: It was a Fault location 480901

Ps. I’ve added the logs to the original post. Not sure if you already seen them or if your reply was just before I added them.

We are investigating whether or not this is similar to other cases we have had recently. Can you test if downgrading to firmware release 2020.10 fixes this for you?

Sure, I’ll give it a try this weekend.

@Mika, I was able to squeeze a short 20 minute session in this morning and everything was fine with the 2020.10, no ffb loss or weird stuff happening. I’ll do a longer session tomorrow to be sure but sofar so good.

@Mika spent another hour (this time in Raceroom) and had 0 problems with the 2020.10 , so yes that’s the solution for me right now. Thanks!

Let me know if I can assist somehow in testing more recent versions. I’m not technical whatsoever but if you need logs or something, that should be within my capabilities :slight_smile:

Got the same issues with mine. :frowning:
Will also downgrade to 2020.10 to see if it fixed the problem.

Okay not working for me.
True Drive closes itself after downgrading the wheel to 2020.10. What did I do wrong?

I am using the True Drive 2020.10 software but when the base is powered on, it closes itself. When the base is disconnected its working fine.

@donchulio, can’t really help you here since downgrading to 2020.10 did work for me. Did you follow the downgrade steps needed? It should be in this forum somewhere I believe?

Edit: This is the thread I meant Simucube 2 firmware downgrade

Yeah I did that.
But will try it again later when I am at home.

Did that also in the past and it worked. So that was a little bit suprising.