Messed up my IONI..Granity gives error

I have an OSW small mige…it’s old, 5+ years. I thought i’d try going from Mmos to Simucube…but i think this was for later boards, not mine. So now i think i’ve messed it all up, after following some tutorial on youtube. In the tutorial it said to put Mmos in DFU mode, and then I used some software called DfuSedemo…it did something. It turned my device from Mmos into Simucube, in windows device manager. But now i can’t connect to it in granity, and simucube won’t recognise it either.

I was using granity v1.7.0…so i just got the latest version, 1.15.1.
When i try and connect to the drive, it finds ‘Granite devices IONI pro at bus address 1’ - but when i open, it says Device firmware version too old/not supported by this software version.

how do i install the firmware if i can’t connect to it in granity?

EDIT - so i managed to press the ‘install firmware’ button - but only in between error messages.
That allowed me to update the firmware which was successful, but it’s still giving communication error flags.

  • communication (cheksum mismatch)
  • Datalegth (timeout or app error)

So i’ve now using Old granity, to update the latest firmware.
Old granity then said firmware too new - so i jump over to new Granity.
And this is now the error it gives when i connect:

Communication error flags:

  • Communication (cheksum mismatch)
  • DataLegth (timeout or app error)

Disconnected. See troubleshooting at while accessing parameter: name=undefined, addr=6002, GUI value=-1, HW value=-1

Most important question:
Do you have a Simucube board in your control?

If you indeed have a Simucube board you can’t connect directly to Granity after installing Simucube software without clicking the enable USB button.

no i don’t have simucube, that’s why i effed up big time… i didn’t realise the simucube firmware was only for simucube hardware, i thought i could just switch from mmos to simucube.

its a discovery kit board + IONIcube combo.

And you could also update the ioni firmware since you do all these.

i can’t - windows installs it as a ‘simucube’ device. When i use the st software and try and connect, it says “no st device detected”.

Have you tried deleting the device and its driver from the device manager? Did you connect the disco board directly to your pc?

yes, the disco board is connected directly.
Windows recognises it as a game controller, Simucube.
If i remove device from device manager, and replug the USB back in, windows automatically adds the device as simcube.
If i go into device manager>human interface devices>HID-compliant game controller properties, and uninstall the device, and try again - same result.
Do you have the drivers for the st disco board, so i can select it manually and try and change it in windows that way?

When you delete the device from the device manager it gives you the option to also delete the driver. Maybe this will help.

thanks, no it doesn’t unfortunately.
I’m in device manager. I can see the device as a game controller ‘simuCUBE’. I right click, remove device. Windows comes up with “are you sure”. I click yes. Windows removes it. There is no 2nd option to also ‘delete driver’.

The only way to fix this, i think, is to get the driver file manually so i can update it. I don’t know where to get this file from though, unles you can send it?>

I am working atm so i can’t help you.

You need to flash Mmos or whatever by using the other USB port on the Discovery board.

Can you post a photo showing how you connect your disco board to your pc?

the disco board is inserted onto another board (with the 2 big capacitors…power board?) and then you can see in background the IONIcube board/servo drive.

Thank you.
yes…this worked! i did not realise i had to use the mini USB end, not the micro USB.
I’ve just flashed the mmos Hex again… and yes Mmos is back, and it’s green.

But i still have the issue with Granity - it still comes up with Communication error flags.

EDIT…panic over. IT was just my crap network. Copied granity files over to local drive and its fine.
Thank you all.

1 Like

i have fixed all this now, thank you.
I now need to figure out what hardware i need to replace in my current setup, so i can install Simucube! I shall leave that for another thread (If i cannot figure it out myself that is!)

1 Like

That’s why i was telling you to connect the disco board directly. Update the ioni firmware because it has a lot of improvements but be careful not to wipe your granity settings.

You need to buy a Simucube board. :slight_smile:

If you are in the USA send me your contact info and I might be able to help you with your upgrade to Simucube.

Hey guys I’m very interested in converting my DD to Simucube software as Gifford has done but my son races 5 days a week and I am honestly terrified of making a blunder …I have a genuine Simucube 1 board but since I posted a few images in another post I think joe said my board is one of the older versions …is there possibly any of you well informed gents could actually at some stage physically go on voice in discord or somewhere and help me … The other prolly more expensive safer way would be to buy a new Simucube1 board and ioni controller and do it without the risk of making a blunder.
This is my previous post

Hi Robert,

Will voice on whatsapp work in your country?
I have never tried voice on there, but might work ok?

I am willing to try to help you, but I hate discord!
I have tried to use it twice and I get an echo of everything I say.
We switched to cell phone really quick.