Upgraded True Drive, Wireless wheels no longer detected

I’m having problems with my SC2 and Ascher wheels. I played a few minutes of a game early this morning with a very old version of SC2 True Drive. No problem. I then upgraded to TrueDrive 20211.11+hotfix and neither of my Ascher wheels are detected. I have replacement batteries on order, but I really don’t think this is a battery issue. I can pull the shift paddles at any time and get the green light to blink in discovery mode, but it never turns up in the latest True Drive software. What can I do to get the wheels and SC2 to play nicely together again?

Many reports about Ascher wheel’s empty battery problems, but almost none similar problems with other wheels. Maybe Ascher has problems specific to their wheels and need fuller batteries, or SC FW is less tolerant than it could be.

It seems that this is the bug where the wireless wheel receiver module is not detected on device start. Issue affects some units in the latest firmware release. Will be fixed next week.

1 Like

Greetings. I haven’t touched my SC2 since December because of the wheel not detected issue. I was happy to see that a new Truedrive release was available today and downloaded/installed it thinking that this was going to solve the problem. In short, no change. I have two Ascher wheels. Both of them have operating LEDs that behave as normal to indicate when they’re announcing. However my SC2 is not detecting either of them. This is getting very frustrating.

As a reminder, I was playing with my SC2/Ascher fine in the morning of December 21st, upgraded to 2021.11+hotfix, and ever since that upgrade the wheels are no longer detected. I also tried rebooting both the SC2 and Ascher wheel, completely deleting my install and profiles and starting fresh, but nothing is working.

Edit: I just replaced the battery in one of my Ascher wheels with a brand new battery straight out of the package. No change. True Drive 2021.12 still doesn’t detect the wheel.

Edit: I tried downgrading to 2021.9 to test if that would fix things, but the software prohibits downgrading, so I’m stuck.

Software does not prohibit downgrading, it is just like it was always when downgrading to any earlier version than 2021.11 where we changed the downgrade to be automatically forced.

See: Simucube 2 firmware downgrade

We are aware of the issues regarding wireless wheels in the 2021.11 and .12 release but we haven’t been able to repeat them so fixing it has been “a long shot”. A beta will be available as soon as we can…

1 Like

Thanks for the link Mika. I downgraded to 2021.9 and my wheel is now connecting normally. This will at least keep me rolling until a fix is found. Thank you very much.

We have a beta firmware now available to fix this “wireless wheel receiver module not detected” issue. I’m going to send the link to @Pretext but if there is anyone else who would be willing to spend a few moments to try it out and get some data to us, we would appreciate it very much.

Hi Mika, as i am also concerned by the wireless issue, I am ready to try the beta.

There will be a new release this weekend still, so I’ll focus on getting that out for all.

1 Like

I just try the 2022.2 version.
Unfortunately the issue is still there. My wireless wheel doesn’t appear in the list.
So I downgrade to the 2021.9.

Did you restart the device at least once after the firmware update was complete?

Yes several time. And also the computer.

It would have been nice to get a debug event log from an occurrence where it showed “Simucube wireless wheel receiver not detected” on the wireless wheels tab.

Yes I can do that. Is there are something to do to have the debug event log ?

last tab in True Drive, there is a button for it

I have this log: TrueDrive 2022_2.txt (2.8 KB)
During this log I try several time to scan my wheel by hold both shifter paddles.

OK, thanks for the log!

It really seems that the communications with the wireless wheel receiver module do not proceed further. I wish we could somehow repeat the issue, it seems its not yet fully fixed :frowning:

The issue that we did fix for 2022.2 was a timing issue where the real time operating system did not give enough time to the wireless wheel task to do the initializations as the servo drive communications task given higher priority. We changed the timing to be much more lenient…


Keep at it Mika you will figure it out!
The little Gremlins are the hardest to find!