True Drive 2021.1 not starting after boot

I am having this exact issue. Google led me here, so I am glad I am not alone in this.

When it happens, True Drive shows disconnected and Simucube 2 Pro disappears from devices.
Then, the unit beeps, True Drive shows operational, and Simucube 2 Pro reappears in devices.

Any help is greatly appreciated!

Model: Simucube 2 Pro
Software release: 2021.1
Firmware version: 1.0.33
Servo Drive firmware version: 10826
True Drive version: 1.0.33
Simucube 2 Serial NR: 7014
Drive UID: e186c625
HID UID: 290051-4e535010-2030324e

Windows 10
Version 2OH2 Build 190.42.746

Simucube 2 Pro is in devices

Running iRacing

Turn off USB disabled

Using the USB that was included

Power cycle has no effect

Hey guys,

Never had any disconnection while playing, but when trying to activate True Drive in the next day after a session, the wheel is always disconnected. Need to power cycle the motor in order for it to start.

Troubleshooting it, found a warning sign on the USB under the device manager (was not sure what could be it). Once I turned off the motor, the warning went away. 90% sure the warning said “Device was not migrated due to partial or ambiguous match”. Need to confirm it when the issue pops up again.

I am aware that AMD systems have more sensitive USB drivers/issues, so it could help to see if people having this issue are on AMD or Intel platforms.

Model: Simucube 2 Pro
Software release: 2021.1
Firmware version: 1.0.33
Servo Drive firmware version: 10826
True Drive version: 1.0.33
Simucube 2 Serial NR: 8783
Drive UID: ? (not sure on where to find that)
HID UID: ? (not sure on where to find that)

Windows 10
Version 20H2 Build 19042.746

Ryzen 5 5600X
Asus Rog Strix X470-F

Hi Luciano,

Can you try downgrading to 2020.10 firmware package to see if it solves this for you? Follow the instructions in the downgrade topic. Simucube 2 firmware downgrade

I will give it a try, Mika.

Will let you guys know if this solves the issue.

I may try this. But I feel that I might need to clarify a bit.

This is a continuous, repeating issue for me.

In other words, the wheelbase looses connectivity [whether this is a power issue or something else is unclear] then re-connects within 10 +/- seconds.

I have 2 of 3 SC2 Pros installed now and this is the only one that has exhibited this behavior. I may attempt to swap this one with one that is still in the box, but I’m a little reluctant if it’s something with the power supply. I do not want to have something unexpected happen with a good motor.

I have downgraded but the issue still remains.

First video link SC2 Pro issue
4 minutes of your life you wont get back :neutral_face:

Thanks for the video, something strange is happening indeed. The fault you got after the device rebooted itself is due to you turning the steering wheel and thus generating voltage with the motor just when the servo drive was not yet initialized fully. Cycling e-stop will always clear the faults.

Thanks Mika.
So I have swapped in the new motor and get the same issue.
If I set the log to verbose will that give us some clues?
Also this CommFault just showed up as well. 485001 SMV2 application error

I decided to try the SC2 in Assetto Corsa and can confirm the wheel exhibits the same behavior as it does in iRacing.

The exact error in the device manager is Unknown USB Device (Device Descriptor Request Failed).

I’ll try to downgrade to the previous firmware version now - again, in my case, no disconnections during use, I just need to power cycle the unit in order for True Drive do recognize it.


I have a similar issue regarding the detection of the wireless wheel after upgrading to the latest firmware. I now always need to power down and power up the SC2 during the windows session so that it detects my wireless wheel. This never happened with the old firmware, so I think something has changed with new firmware. I am not having the problem that the SC2 disconnects during ACC. It is an AMD-platform I use.
Hope this helps to find a solution.


Downgrading the FW to 2020.10 solved my issue, and the base was detected when starting the PC in the next day.

Hi All,
I was having same issue.
It seems to have been down to my motion rig barely wiggling the USB cable (one with clip). Now I’ve ensured the cable has lots of room to move freely and secured the cable end with some sticky tape to double ensure it isn’t wiggling.

I also downgraded firmware from the beta to the latest public release.

No more problems.

We have managed to reproduce the issue, and are fixing it.

I moved some related posts all to this same thread.


Back again, I have had this happen now twice.
All cables fine. USB interface simply disconnects and disappears from USB devices in Win10.
I have now reverted back to 2020.10 to see if this is a firmware problem.

AMD posted this on Reddit regarding USB disconnections on 500 Series chipsets: An Update on USB connectivity with 500 Series Chipset Motherboards

Hello everyone,

For about a week I’ve been unable to use my SC2 sport, windows notifies me saying “USB device not recognized”. The error in Device Manager reads “Unknown USB Device (Device Descriptor Request Failed)”. I’ve tried every tutorial imaginable regarding this error and have gone as far as to reinstall Windows. Any help or updates regarding this issue will be greatly appreciated.

Thank you

If this happens also when the device is shut down and you start the device, it is not the issue discussed in this thread but something else.

Do you have it connected directly to PC or via a hub?
I was running mine thru a hub and was getting weird USB message like not enough resources etc. I moved it to directly in PC and it seems to have fixed those messages.

I’ve been trying both same issue :frowning: prior to the update to 2021.1 it was working flawlessly :slight_smile: