True Drive 2021.1 not starting after boot


i did update to the latest True Drive 2021.1.

With all other versions i could put True Drive shortcut to autostart and when i started windows, True Drive was always working.

Since i did the update today, True Drive does not work, until i power off the servo motor and power it on again.

When i switch back to the older True Drive software, the problem still remains.

How can i go back to the older fw version?

Attached you can see screenshots. After i power off the servo engine and power on again with the on off switch, it is working. Please help me, thank you very much.

With downgrade to the older firmware version everything is working normal again. So it must be a issue in the fw, maybe someone can explain this to me.

Thank you very much.

Thanks for the report, we must check what is happening here.

I have updated and made the process of starting it minimized … it works perfectly

Hello, 2 days ago I updated my simucube 2 pro (purchased in December 2020,) to the latest version 1.0.33) the same thing that the author of this topic says. If I restart the computer and simucube is turned on, windows does not detect it, I have to turn off and on there is a problem with the new fireware.

I have also noticed that at the time of not using it turns off and true drive does not detect, I have to turn off and turn on, for the latter I have found solcuion putting always active usbs without suspension, it seems that it goes well in this sense.

excuse me if something you don’t understand, I use translator
Thank you very much, and I am glad to be part of this community and osw simucube2

Thanks for the report. We will be investigating this for next release.

Hello, my Simucube 2 pro works by turning it off and on with the latest update, just like it does for the author of this topic.

Same thing for me too, the simucube2 pro updated to the latest version. After about ten minutes it disconnects from Windows with a flashing blue light. if I try to press the stop button and release it, nothing changes. I always have to turn off from behind.

This is really strange, and should not be happening. Its not happening to our development units nor to me at my home using 2021.1

We will investigate the restart of device needed after computer reboot -issue as soon as we can.

Im having the same issue, i have to power off an on at the servo side for it to work, just says USB unrecognized till then. Tried unplugging the kill button and that made no change.

Same here! SC2 Pro purchased in October 2020.
Last update (Jan 31, 2021) made and it doesn’t work anymore:-(

Switched the SC2 Pro manually off and on and it seems to work now.
Definitely a bug in this FW update…

Same here.
Truedrive starts but reports “disconnected”.
Have to do a Power-Cycle on the SC2.
Purchased End of 2019.


I have to say that this happened to my device at home just today. We are investigating.


I had same problem after downgrade of firmware from beta to latest public version.
I unplugged the usb from back (with clip) plugged back in and it cleared everything.

Also noticed that when it’s on and I boot the pc of my uncle… it won’t boot into windows. After I switch it off - windows loads?!

Firmware 2021.1 - SC Sport R2

We are investigating this on high priority.

I have same issue (simucube2 disconnected from USB) even with the solution proposed by Mika.
At this time the problem is not solved. It happens very often . I’m desappointed

We would like to know the following details

  • firmware release / version
  • does this happen always
  • if issue can be fixed, then how?
    • does power cycle of Simucube 2 fix the issue?
  • Is there a Simucube 2 visible in Windows Devices list at all?

Hello Mika,
Here are the details of my settings:

  • Model: Simucube 2 Pro

  • Software release: 2021.1

  • Firmware version: 1.0.33

  • Servo Drive firmware version: 10826

  • True Drive version: 1.0.33

  • Simucube 2 Serial NR: 1788

  • Drive UID: fc6562e2

  • HID UID: 51003a-32385112-31303532

  • the DD is connected on a USB2.0 port by a small cable with gold connector and ferrite.

  • Windows turn off USB devices disabled

It happens yesterday 4 times during one hour of gaming with assetto corsa. It seems more with the latest version but I don’t know if it is related ? The first thing I hear is the typical sound of a windows USB disconnection. the next time the problem happens I will see in the windows device manager if the SIMUCUBE2 is still displayed.

I forgot to say that I need to quit Assetto corsa and power off/on the simucube2 to fix the problem

I have another issue this afternoon and I saw that simucube2 was not in the windows devices list