Simucube wiereless wheel receiver not detected

Hello,

I think I have a problem with my Simucube Pro R1 wireless module.
I started the base and started my wireless wheel, but I realised the wireless wheel did not connect. So I went to de wireless wheel tab in the software and the first thing I noticed was that it said: “Simucube Wireless Wheel receiver not detected”. and the options are all greyed out.

I have 2 wireless wheel, but both aren’t connecting.

Does this mean something is wrong with the connector on the wheel base?

I am on version 2021.11+hotfix (the lasted release)

edit: I also tried reinstalling the software.

Very strange. I think I found a bug in software 2021.11 + hotfix.

When downgrading to the previous version 2021.9 the wireless module is working again. Not sure what is going on.

This is a known issue and will be fixed in a 2021.12 release this week. See:
https://granitedevices.com/wiki/Simucube_2_True_Drive_releases

Workaround with 2021.11 releases is to just shut down and restart Simucube; the detection is being done at device startup, and it seems to fail on some units more often than others. It is a timing issue.

1 Like

Aha, alright. That also explains it working fine before today. Today was probely bad timing haha.
Thank you for the quick answer!
I will stay at 2021.9 for now at the moment. Looking forward to release 2021.12.

Hi,

I had same issues yesterday.
I updated TD from 2021.9 to 2021.12.
And TD can not recognized my Ascher wheel.
I did downgrade it to 2021.11+. but same situation.
I tried to downgrade 2021.9, but it was impossible because firmware was already upgraded.
Help needed. Thanks in advance.

My devices are followings.
Simucube2 Sports
Ascher Racing B16M-SC
I changed a new battery yesterday.

For downgrading earlier than 2021.11 version, you need to run the downgrade procedure.

We are working on a beta firmware to fix the connection issue, and it will be available on Thursday.

Problem solved. Thank you.
I did downgrade it to 2021.9
And it can connect my wheel with wireless.

Downgrade Procedure in Windows10 JPN version

Hello
All of a sudden I lost the connection between the ascher steering wheel and the simucube2 application I changed the battery and I don’t know what I touched in the application that never detected the simucube2 steering wheel again I tried several batteries and the light on the steering wheel blinks that is The steering wheel does work but in the simucube2 application I can’t find that steering wheel, the connection is wireless. I would appreciate help to solve this problem. I already have the latest version installed and it doesn’t work, thanks

Hola buenas
De buenas a primeras me bajo la conexión entre el volante ascher y la aplicación de simucube2 le change la batería y no se que toqué en la aplicación que ya nunca me volvió a detectar el volante simucube2 probé varias baterías y la luz del volante parpadea osea que el volante si que va pero en la aplicacion de simucube2 no me encuentra ese volante la conexion es inalambrico. Agradecería una ayuda para solucionar este problema. ya tengo la ultima version instalada y no va Gracias

And that is the problem, check the post above yours on recommended version and downgrade procedure.

Si también la instalé y tampoco funciona y la verdad no se que hacer más

You do not have the issue where the wireless wheel receiver was not detected, so downgrading is not useful for you.

Is the wheel ON? Does it show up if you turn it off and back on?

Same issue with 2021.12 and 2021.11.
A downgrading to the 2021.9 resolved the problem.

Hi all. I have the same issue where the text in the wireless tab is greyed out, with a brand new SC2 Sport and Tahko wheel, Truedrive release 2022.2. It automatically updated the firmware on first startup with no problems. I restarted the PC, SC2 and wheel but the issue persists.

I see the fix above is to use old firmware; I’d rather not unless I have to - the 2022.2 release log suggests that this issue was fixed in that release.

Any assistance would be appreciated.

Regards,

Jason

Issue is still not fixed in the latest release for some very small number of units. We are still working on it.

Can you try 2021.11 and 2021.12 releases too? Would be great data for us. We still do not have any devices where this is happening.

Yes, sure. I’ve tried 2021.12, I had no success over several tries both starting Truedrive with the sc2 powered up, and powering SC2 after starting Truedrive. I went back to 2022.2 and that’s worked every time for 5 or 6 tries now, regardless what order I start things up.

I’ll try 2021.11 a bit later.

Regards,

Jason