SimuCUBE Open Source Firmware: Beta version 0.5.X BUG Reports

I would like to have some testing reports to hear if the @HappyCamper 's report of 0.5M CPR being the maximum currently also applies to SinCos.

His encoder should have both modes.

Otherwise I will mount mine again tomorrow afternoon, currently testing with 40k quadrature setup

1 Like

Same with 5.1 about red blink led. I clear faul and restart drive in granity --> ok but when i swith enable/disable button, it’s blinking. Also, see picture below, i have firmware version ok, 5.1 but config tool stay 5.0, is it normal with new release ?
I any case i don’t have any trouble in game…

OK, it seems that the new version number information didn’t compile for some reason. Version 0.5.1b fixes this.

With 5.0 got the same heavy wheel spin to the right.
After unch3cking and checking bump stops it worked fine. Unfortunately I won’t be at my wheel the next few days.

With default settings now road feels smoother ( q maybe.)
Could b3 Placebo :smiley:

its placebo, there should’t be any changes that affect the feel, unless there is some unexpected thing happening when we went from 10 kHz to 2.5 kHz for the torque updates. We also know whats inside Ioni firmware, and there shouldn’t be any changes there either by this downmoding.

5.1b installation is ok
try redo granity clear fault 480901, restart drive and same blink…without reel impact…

Found a minor bug myself. When changing steering range, the lock-to-lock indicator is calculated wrongly.

http://granitedevices.com/wiki/Fault_location

480901 means that a SimpleMotion packet CRC error has occurred. This is unexpected, but could happen if one of my hypothesis is correct. We shall see.

Your previous 481201 is completely expected; it is SimpleMotion timeout. The firmware makes the connection watchdog to time out to get Ioni to reset to default baudrate. Default is needed to connect via Granity.

Mika, this was using 0.5.0.

I will test again in 0.5.0 then downgrade to 0.4.1 and then upgrade to 0.5.1. I will test at 2M, 1M, and 500k and report back later.

During one test yesterday in 0.5.0 at 1M CPR the wheel went offset by about 35-40 degrees with a simple 25 foot acceleration burnout coming back on track at Mid-Ohio in DW12. So this is was not the jolting torque that would normally set it off on bumps or smashing curbing.

Hello SV1

I know you mentioned that you have a Davy Watts BiSS encoder the same as mine available but just need to install it.

I would be real helpful if you have the time to get that installed to test out BiSS CPR values beyond 500K.

Which AKM motor are you using?

Tested the AKM53K with BiSS and this afternoon.

2M on 0.5.0 and running the curbing out of Turn 2 Mid-Ohio offset the steering Offline Testing Session

1M on 0.5.0, 0.4.1 , tested for 20+ laps in each and could not get any errors. Offline Testing Session

1M on 0.5.1b - tested 30+ laps and could not replicate the offset steering. Offline Testing Session

Decided to join race and on my first hot lap,in qualifying got a slight power slide out of Turn 2 and steering offset about 45 degrees. Had to close iRacing open Granity and changed BiSS settings to 19 BIT (524K) and was able to just make it in and finish my hot lap Q with 2 seconds to spare.

Ran 42 lap race at 19bit 524K without any issues or errors.

I cannot currently run it above 19 BIT reliably without having steering offset glitch.

Tried setting in to SinCos in Granity as Beeno suggested, but Granity testing was not reporting any numbers in the encoder CPR line and wheel did nothing after drive restart.

1 Like

Quick calculation by Tero says that wheel would have to turn 11.5 degrees in 1/2500 s for 19bit BiSS to lose track. Hmm, I wonder if there is something else happening that would delay a torque update…

Mika, I have NEVER lost steering at 19bit. Only ABOVE that at 20 (1M), 21 (2M), and 22bit (4M)

19bit (524K) has been flawless so far in 100’s of laps of testing and racing.

So it would still be 5.75 in 1/2500 s, almost 40 rev/s.

This happened in 20bit (1M) mode.

In the official race qualifying, when it happened is was just a slight power slide that was in control and I could feel in kind of jumping really quickly as I tried to steer out of it.I did not take note but is was out like around 18 degrees at that point and white in the pits I could not centre the wheel with the quick centre button as I tried it several times and it went through its routine where the dialogue window ask “recenter anyways or something like that” but no changes to the 18 degrees of offset.

Also just to note, I have had it happen in both steering directions.

It seems Davy has not wired the SinCos signal. I use the same encoder/servo setup and have wired mine in.

Also, been runnin 22-bit for about 12 hours total, no issues at all. Funny one this…

Here is the wiring instructions that I was provided for changing from 10K (40000CPR) to the BiSS.

On the DB15 connector, don’t change the 5V and 0V wires (9 and 10 on DB15 connector). Move the remaining wires as such:
** **
6 to 12
5 to 11
8 to 15
7 to 14
** **
The original wires in 15 and 14 are unused.

Phillip, let me know if there is something that I can rewire to allow for SinCos signal if you believe it will help.

Is is there any way i can get one of these encoders for testing as i’m interested. i can use a soldering iron etc.

Hi Mika,
Update ok now.

But having gui open, I had short usb disconnect in iracing around Spa, one occasion. First such issue with fw.

Closed gui, no issues, and I could not replicate. But running 40k inc encoder only. Sounds like what HappyCamper might be experiencing.

Cheers,
Beano