SimuCUBE Open Source Firmware: Beta version 0.5.X BUG Reports

Please report new bugs (and unsuccessfully corrected old ones) here.

some initial comments


when going through the initial configuration after the update, i did the following in the wizard

selected motor and encoder from drop down. then selected the drc file
selected ‘end of phasing’ index mode
centered the wheel and ‘initialized’ - i think the servo made some beeping noises during the time
centered wheel in ‘set wheel center’ and clicked Finish button.

as soon as i clicked the Finish button, the wheel spun rapidly and wound up my usb wire/plug ripping it out of the connector.


GUI does not follow the windows regional settings.
i have my windows regional setting configured to use the decimal/period character (.) as the decimal separator, but the GUI is showing values using the comma (,) instead


my wheel steering range is 900, but the default bumpstop range is 400.
this resulting in a wheel that only moved a little bit side to side, before hitting the bumpstop.
i think a default value of 400 is too large.

Had the same reaction at startup after installing new firmware.

Started wizard and right after the motor phased wheel took off but I was able to stop it by hand and hit emergency stop.

I loaded DRC file settings through Granity and that fixed the wheel taking off during setup wizard…

At this point I could not save any changes in the 0.5.0 UI and tbw and reconstruction boxes were grayed out and after entering iRacing I could feel that the reconstruction filter was not active.

Ended up having to shutdown computer and wheel and after reboot was able to change reconstruction settings and save file.

As SV1 mentioned the 400 degree settings left very little wheel movement, but was easy enough to fix.

AKM53K with BiSS encoder.

Well I had a chance this evening to test out the BiSS.
I dropped it to 21 BITS (2 million CPR) and was overwhelming the IONI with loss of positioning during heavy moments of FFB torque.
Dropped it again to 20 BITS (1 million CPR) and I was still losing positioning.

Looks like I ended up at 19 BITS (524000+ CPR) and so far after a dozen laps it has stayed solid. I will test more tomorrow.

I Also have the Reconstruction filter and Torque Bandwidth Filters greyed out and not active.

Big Mige 40k encoder

Restart Simucube and gui

Yep Done that and restarted PC still Greyed out

it worked for me in the last Beta and I’m running Ioni firmware 1192

After first config wheel turn right and no possibility to save paramètres.
I use granity and ok.
Aldo, Need some minutes to understand what was wrong with default value of endstop range…now it’s working. Nice

I shall investigate the default bumpstop setting! It really shouldn’t do that.

I just see that i have a red blinky led on ioniboard - 1long 3short - with all working normally…normal?

Connect with Granity and see what is in the testing tab.

this is

Clear it in granity and ok, strange thing…

speak too quick… when i switch “disable usb” blink led come back . i check is same default rigt now

not same fault location

I have a suspicion that the drive just tells that during this session, it has had a SimpleMotion bus fault. This is actually by design to get the drive to connect to Granity and also when re-doing the Drive initializations at the wizard.

Does the fault go a way when you restart the drive in Granity?

I just released v0.5.1, please use that. There was indeed a bug that caused the torque. Strange that I didn’t catch it yesterday :frowning:

The same bug also prevented saving or applying any new settings to SimuCUBE - that was actually a failsafe.

restart drive with 5.0, same result. i put 5.1 and tell you


was this with the 0.4.1 or the current 0.5.x series?

I demand more testing of this :wink:

Thanx Mika, will run 051 :wink: