Simucube firmware 0.50.x feedback thread


#101

Thanks for sharing.

I’m running clean install of Win 10 1903 (latest Build) and the only title on my C drive is iRacing.
I store all other games on other drives to ensure I don’t have any clutter.
It’s essentially a clean Windows install with iRacing.

I re-ran the set motor center point, so will see if it happens again.
Hopefully it’s just a one off ‘quirk’.


#102

Yeah I had about a year of no issues, I run a ton of USBs so thats always a concern, out of the blue in the middle of a race, FFB went out, no steering at all… then steering came back no ffb, wheel offset by 90 deg. It happened a few times randomly and then BSOD bad header.

Wiped everything and started again, remve and lugged every USB, cleaned contacts etc etc… so far no issues. Yes upgraded all drivers to current versions too.

Annoying when it just happens… I mean if I added something it would be understandable, but its like lightning… randomly struck…

Did check with granity software and no issues came up …


#103

@GlobeSpy

I had the same feeling regarding a difference in FFB going from 11.2 to 50.4.

After updating, I immediately lost some pace on a car/track combo in iRacing I had been running all week (911+Watkins), and felt as if I wasn’t getting the same responsiveness from the wheel as before. Specifically, it felt like there was more latency, and I also felt like I wanted to turn the filter setting down. It almost reminded me of the latency that using irFFB in 360Hz mode introduces. I noticed that the car was wriggling more under braking, with me allowing the rears to lock more before I either reduced brake pressure or made a steering correction. I also noticed the car getting to higher angles of oversteer on corner exit before I was able to adjust there as well. This culminated in me driving a little slower, not getting as close to the edge.

Came to this thread specifically to see if anyone else noticed a difference in FFB with 50.4, so I’m glad I’m not the only one.

I reverted to 11.2, and placebo or not, it feels “normal” again after a few laps.

The only issue I now have is that my SimuCUBE doesn’t make the beeping sound it normally does after phasing.


#104

Thanks for your input.
I haven’t had the loss of FFB again since going through the entire setup.

I’ll stick with the new version for a bit, especially as Mika is adamant that there is no difference and it’s all placebo.
Hard to argue with the developer on that, just wish there was a way to measure latency and amount of FFB and compare graphs side by side to see if there’s anything in our placebo thoughts.
That’s quite a few people saying the same things, but that’s also a known phenomena with a group of people when a few say something and the ‘pack’ agrees.
The brain is complex and power of suggestion very strong.

Interesting you lost your ‘be-be-beep’ noise going back to 11.2 - that’s not placebo!


#105

I upgraded an old customers SC1 tonight from MMOS to 0.50.4c without any issues.

One problem I ran into is I could not connect to Granite via the enable button. Is there a new granite version that must accompany 0.50.4c?

It will post the error message later when I can get online with the pc. Verizon FiOS just went offline for some reason.


#106

You can easy measure latency and compare both firmwares using RFR-WheelTest soft :
http://www.racingfr.com/forum/lofiversion/index.php/t48669.html


#107

I haven’t personally felt a difference, but mika did say the torque update rate got lowered from a possible 1700 down to a stable 1250. If you were actually refreshing faster than 1250, it could give a difference even if in theory it should be very minimal.


#108

Thanks.
What value would relate to torque update/refresh?
Is that the TorqueBandwidthLimit value that most set to unlimited with SinCos/Biss encoders?


#109

Thanks for this, I will look into it


#110

I’m pretty sure it’s how fast ffb updates gets send out to the wheel, it’s not user settable. But as said it’s very small difference in actuality, the human can definitely feel a lot of things but we’re talking about an update every 0,83 ms compared to the old possible 0,58 ms. If the game hasn’t delivered new ffb I’m not even sure there would be a difference, except if the simucube filters would behave differently. (Though I believe they said they made sure they perform the same with variable things like fps etc.)


#111

Here are Wheel Test results with 50.4. Unfortunately I have not been able to get the bumpstops to work with 11.2, so I have been unable to get results with that firmware.

I also wonder if switching from the Vive to the Index VR headset could be causing some weirdness. I’m getting occasional SteamVR issues where switching on the wheel after SteamVR causes SteamVR to say Room Setup needs to be rerun. Or starting the wheel first results in the base stations not being detected. I don’t think it’s something as simple as the sim running at a lower FPS, as I’ve actually been able to maintain 120fps without motion smoothing/reprojection on the tracks I’ve tried so far.


#112

Is this diagram with or without filters?

For example these are the best latency I found for each wheel:

  1. OSW(Mmos) 2.368 ms
  2. AccuForce 4,881 ms
  3. SImuCube1 (50.4, recon 5, filters on) 5.008ms
  4. G27 5,918 ms
  5. SimuCube2 Pro (filters off) 5.969ms
  6. Arduino Leonardo 6.969 ms
  7. G25 10,014 ms
  8. DFGT 11,936 ms
  9. TX 11,963 ms
  10. CSW V2 12,632 ms (drift 0)
  11. SSW 12,792 ms
  12. T500RS 14,600 ms
  13. CSR 17,851 ms
  14. CSW V2 21,959 ms
  15. GT3RS 24.005 ms
  16. T300RS 43,964 ms

#113

This was with filters, just using my default iR profile which is recon 5, 0.33% damping, and 3.75% inertia.


#114

You should run these artificial tests without any filters. Otherwise they are not comparable!


#115

Also the delay is not really anything meaningful in these tests, as the windows and usb things have an effect.


#116

One more test without filters and recon 1 pls.


#117

I didn’t expect mmos to have the lowest latency


#118

If the user had very old IONI firmware before, then the latest versions will require a Granity update as well.


#119

Yeah, usually OSW with Mmos has higher latency but there is one diagram with very low one.


#120

unless the tests are made on the same PC, sub-10ms differences are really invalid comparisons.