Simucube firmware 0.50.x feedback thread


#81

Only 0.50.x is supported now, so it makes sense to upgrade from 0.11.0 to 0.50.4c (via 0.11.2). Then you are ready for any future fixes or new features that may be added Simucube1.


#82

Does anyone have the wheel centring 180 deg clockwise from normal, when the PC is started up.
It does not seem to happen every time though.


#83

Last thing I after shutdown is place my wheel in the same position, about 10 degrees right. I have the ERN sincos encoder so it does a centering when startup. When I do this and its starts in the same position I have 0 issues, if the wheel is 10 deg left it will center differently. Find the position that works and keep it.


#84

There might be something funny going on with wheel centering, also the same bug has existed in 0.11. We will get back to it eventually, but we don’t have all the possible encoders here at the office in a working order for Simucube 1 development, so this will take some time to get to.


#85

(see Above) NO PROBLEMS HERE …lol


#86

That’s funny because I have the EXACT same situation with my SinCOS encoder.
I have to leave the wheel at about 10-15 degree to the right before powering up or it will not center correctly.
Never been able to understand why, but it’s an easy workaround so hasn’t caused problems.

I’ve tried starting everything from scratch, re-loading the DRC file for my encoder (from SimRacingBay) and nothing changed.


#87

Sincos encoder is not absolute. The zero point is at the end of phasing, and offset to that is defined by the motor configuration wizard and the reset center button.

Motor will phase between the pole quadrants, and in a 10 magnetic pole motor, there are several places where the phasing can be performed. The servo drive does not know anything about which poles the phasing is happening in, so if it does not happen in the same quadrant that you set the offset to, then the position will be off.


#88

Mika, appreciate the explanation but a little complex to pull a solution from.
I’ve ran the config tool from scratch and nothing changes this issue.

Are you saying that in theory setting the center point using the config tool should resolve this need to always have the wheel a little offset to the right?

Appreciate a simplified explanation that I can try out.


#89

He just agreed with you…:slight_smile: Put the wheel in the same position when turning on the cube… same center each time…


#90

You will always have to have the wheel doing the phasing routine between the same pole quadrants on a sincos encoder.


#91

Well, I guess my ‘placebo’ feel is more acute than most.
I’ve driven several hours with [iracing] car and track combos that I know like the back of my hand.

And, there’s absolutely [in my placebo mind] a noticeable ‘softening/vagueness’ of the FFB effects.
I’ve been using recon 8 for a while and tried going down to recon 5, only to find that I could now feel cogging, which isn’t something I have felt for quite a long time with my small MiGe/SinCOS setup.

I’ll go back to 0.11.2 and compare.


#92

What encoders do you need?
I may be able to help.


#93

My mistake, I meant to say it rotates 360 deg clockwise, looking at the wheel.
I will try centring the wheel at shut down to see if that stops it from happening.


#94

I have one wheel with a SinCos encoder, if I leave it slightly off-Center to the right, maybe 1 or 2 degrees, absolutely zero issues. If I l eave it to the left of Center, it always is out by almost one rotation.

So, just leave it somewhere close to the right of Center, zero problems. Has always worked on Bogeyman.


#95

Thanks, I’ll try that.


#96

Update on Centering:

Seems 0.54c has resolved my need to leave the wheel 10-15 degrees to the right.
Just centered the wheel and tested powering up and it’s centering properly with correct index point.
Turned off and centered wheel and repeated 5 times - all good.
Perhaps I’m still centering with a couple of degrees to the right out of years of habit (as imperceptibly small as when going through the process of centering the wheel using the software and ‘eye-balling’ center), but it would always be off by a quarter turn in the past if I didn’t have the wheel very obviously offset to the right.

Maybe some kind of fluke?
Small MiGe - SimRacingBay 2048-line SinCos

On the FFB - played with settings for a few hours and seems that I don’t need anywhere as much friction or dampening (iRacing) as before, and that has seemed to ‘liven’ up the wheel a little.
I drive the Classic Lotus quite a bit and it’s still a very bumpy ride.
GTE/GT3 cars still seem a little ‘soft’ and I can’t go down with recon as it absolutely introduces cogging/slightly gritty feel that I didn’t have before (I regularly ran a profile using recon 5).
Interestingly, ACC and AC don’t have this cogging/gritty feel at recon as low as 3?


#97

Still rotates 360 deg when turning the power on. It does happen every time.
Never used to do it with the 11.2 firmware.
Is there a way to revert back.


#98

Pretty sure you just need to launch the config tool from that FW version and go through setup.
Back up your profiles if you haven’t done so.


#99

@Mika
Been running the 0.50.4c for a day or so and had a couple of strange events happen that I’ve never had happen in any other FW.

I lost all FFB in iRacing after simply going to the pits and heading back out on track.
Checked the config tool for faults, then enabled USB Ioni mode and went into Granity to see if anything had been recorded - no faults/errors in Granity
I don’t run very high FFB (76nm in iRacing for GT3 cars) anyway so over-voltage is not something that really could happen.

Today, I was practicing (again iRacing) and spun he car.
On leaving the pits I found that the wheel didn’t know where it was and what I thought was center was -360 degrees.
The only fix for this was to go into the config tool and reset the center.
This has never happened in any FW version since owning my system for close to 3 years.

Any ideas on why these issues might happen?


#100

Funny I had the or very similar issues the other day, then I started to get BSOD Bad Header messages.
Reinstalled Windows and everything else as a clean install, removed and replugged every USB, Plug and power point, all cables. New drivers… problem gone.

Would laso advise running the motor configuration in simucube after reinstall.

I suspect windows for my issue as it came out of nowhere, no new drivers etc etc. Took the opportunity to upgrade the simucube too.