Simucube 2 vibrate when turned on

Hi everyone,

I just received my Simucube 2 Sport and when turned on it makes a strong vibration/sound and I have to hold the wheel very hard to stop it. No problem after the High torque mode is enabled.

Any help welcome.


1 Like

I also have this issue!! Sometimes returns when in full lock in high torque as well. Aslo if I end up crashing hard in to a wall I’ll get the same strong vibration from the wheel

We have taken note of this issue, and are investigating possible causes.

1 Like

Hmm, the safe mode applies very high damping in addition to reducing max torque to ~4 Nm. Perhaps high damping is unstable in your cases by some reason.

Anything untypical attached to your SC2 or rig? I.e. flexing shaft or rig/table might explain this.

Please post photo of your setup if possible. Thanks!

Also can you test if the vibration happens also if you manually turn damping up (to 100%)?

Yes if I turn damping up to 100% it does vibrate really loud! ! No nothing that shouldn’t be on there! Iv taken the QR off to double check that everything was tight. 15600290336144350076578859169388|375x500

Yes it does vibrate with damping at 100%

All fixed tight here.

ok so first I dissconnected the wheel from the QR and left the QR attached (took the 6 screws out of the wheel) no Vibration at 100% or in low torque mode. Only at full Lock will I get the Vibration… (left and right)

I then disconnected the motor from the rig and at full lock I get the vibration but not at any other point.

would rubber washer on the 6 screws attaching my wheel to the quick release help with the other vibrations (soon as I started to attaching the wheel to the quick release vibration start) do you think? an is is normal for the motor to vibrate at full lock ?

after putting it all back together I notice the 6 screws from QR to wheel were slight off once lined up this has reduced the times it vibrates. if turned up to 100% slowly its doesn’t vibrate (can hear a slight sing from the wheel) if I turn it straight up to 100% I get the Vibration again I think im gonna get some rubber Washers and see if that will help the problem.

Chris, I just did the same and got the same result with the vibration.

I have noticed that we have the same wheel.

1 Like

:-/ I did email Augury but never got a reply. I may look to return the wheel as it looks to be the issue.


I also have the same problem, and as you guys I have a F1S on it…

It’s only harmonics, I have the same on my F1S…you can tune it out, but anyway, it disappears when you start to drive or switch mode to high-torque. It just shows the frequencies the new SC2 can replicate, amazing.

Anyway, no issue with other wheels, my diy wheels are all quiet. But not a problem with F1S, tbh, just a slight annoyance for a few seconds…



Could you share you settings with us to try please? Also does your vibrate at full lock? Is this just a setting change or normal for it to vibrate this way?

I would agree it does seem to go once driving and in high torque mode but does return if you crash hard.



Have you tested the pro at home yet, or just the Ultimate?

Talk soon,

3 rubber washes seems to have solved it!! If I have all 6 it still comes back which is weird. 20190610_161815|375x500

Iv also got a reply from Augury. They are not awear of any issues an didnt have any problems when testing. Theh are going to take a look anyway as it seems strange to them. Would you guys be able to message them as well

damn i have the same issue with F1S , but even with no wheel on if *i put my hand on the motor i feel little vibrations when turning it slowly.
When i put the F1S , it’s simply unplayable really big noise, tuning high torque on reduce the noise , but in game i still feel vibrations and it’s annoying.

Is this still happening with the latest firmware version?

Just installed it it’s even worse, now same thing with no wheel on …:frowning:
I recorded it, but I can’t send the file as the format is not supported : MP4

Torque bandwidth and slew rate limit seems to have absolutely no effet.
On standard mode even with 0 % friction 0 % inertia the sound is crazy. That was not the case with my previous firmware. 1.08 …
Playing with truedrive , i’ve found fixes , but i don’t know what that really do …
Center frequency any value greater than 48hz
+Attenuation DB -24,5 ( anything more and it’s the sound again…)
+Q factor 1.1 or 2.1 ( any other value doesn’t work)
These 3 seems to work together …but I have no clue of what it really means ( settings these i can go up to 50 % inertia no problem , but no more)

It is then most likely a resonance issue with that wheel,and you are not the first one to report it.

Inertia over 30% sounds like a lot, and might be just outside of stable operation.

What happens if you reduce torque bandwidth or decrease the slew rate?