Sc2 not connecting to wheel after firmware

I just updated to truedrive 2021.12 and I was then prompted to update the sc2 to the latest firmware. After doing so I lost ffb in Iracing and I also couldn’t connect my cube controls gt pro zero wireless. After uninstalling truedrive and reinstalling ffb has returned but I still can’t connect the wheel. Both SC2 and the wheel are new. I’ve tried all starting procedures and the battery is fine on the wheel, sc2 just won’t recognise it. Any ideas?

We did improve the detection of the wireless wheel receiver module in 2021.12 as there was a timing error in the previous release 2021.11.

If you power off and back on, the receiver should be detected.

Yeah I’ve tried powering the sc2 on/off numerous times and nothing, also tried powering cube controls on/off but again nothing.

Is there any course of action to resolve this that anyone knows of?

If it works for you on 2021.11, then I suggest you use it instead.

We already did a code review on the change that we did for 2021.12. We increased the delay at system power up before communicating to the wireless wheel receiver. The receiver module started too slowly on some units, that caused “wireless wheel receiver not detected”. Then we also increased UART supersampling for increased communication reliability with the module. So both changes can only have improved the communications.

Hello Mika, rolling back to 2021.11 and the associated firmware has resolved the issue, thankyou.

We may have found a cause for the non-working behavior. Fix will be out as soon as we can.


+1 I have the same issue. My whole “Simucube Wireless Wheels” tab seems unresponsive. All the buttons are grayed out.

Downgrading to 2021.11 did not fix the issue. The menu is still entirely grayed out for me.

Try 2021.9, it should have the least problems.

Thanks! Downgrading to 2021.9 resolved the issue. I don’t think this is a timing issue like the devs seem to think in Simucube wiereless wheel receiver not detected.

I’ve been thinking about possible causes / differentiating options and haven’t come up with any cause for it that would not be fixed in the beta release on the forum.

I will have access to the code tomorrow and perhaps there is something that comes up then.

I have a SRB BB Ultra and I have connection problems as well. When trying to downgrade True Drive I fail to open it since it says firmware version of my SC 2 Pro is to new. What can I do?

1 Like

I had the same issue where my Ascher B16L-SC didn’t connect to the SC2.

I’ve been running 2021.11 Hotfix since late November.
During december I’ve had a rare problem with the wheel not shifting when I click the shifters. It seems random, and I couldn’t find any pattern for it.
On December 31st I updated to 2021.12 and the wheel connected as usual. I used it on december 31st for a few races. I had LOTS of issues with the wheel not shifting when clicking the shifters, to the point where it almost happened every lap.
Then on the 1st of Jan, the Ascher wheel wouldn’t connect at all. I thought it was the battery, but then I came across this thread. Downgrading to 2021.9 fixed it, it can now find the wheel again. I updated to 2021.11 Hotfix and wheel is still found.

I’m hoping that 2021.11 will stay stable, although if the misshifting continues I might downgrade to 2021.9 again to see if that helps. I’m not even sure if the misshifting has to do with the TD version or not - but since it got very bad on 2021.12 I assume so, for now.

Hope you can find the issue with wheel not connecting in 2021.12. Let me know if you need any more help with logs (if that exist) etc. :slight_smile:

It would have been nice to see if there was any signal quality difference between the versions. There shouldn’t be, the code that reads the wireless modules is exactly the same.

Sounds like a typical battery empty symptom.

1 Like

@Nrde Maybe, will get a new one anyway. But TD reads 3.6v, sometimes 3.59V, so should be fine.

I didn’t monitor signal quality too much, but everytime I checked it was at 100%, in both versions.

Might be some other problem then, hope it’s fixed with a new battery though.

I have the same problem, but I can’t fix it. Tried to change the battery. Tried earlier version of true drive 2021.11 + hotfix and 2021.12 (2021.9 I couldn’t use because it said my current firmware was to new).

My ascher wheel does not show up at all in true drive (it blinks when I turn it on and also when I hold the shifter paddles in for 1 second) and I’ve followed the steps described here, but no success. As 2021.9 is not usable I don’t really know where to start troubleshooting.