SC 2 Pro - Losing FFB mid corner for 1-2 sec

If it was certified properly why you went to extent of printing Simucube on the PSU but not updating spec label? Makes no sense to create all that controversy if proper certification actually took place (which based on earlier posts from you didn’t happen “to save money”)

You are the only one going after controversies for anything we do :smiley: lol

The Simucube 2 wheel base product was certified as a complete unit with the PSU.

Again, go back to the linked threads to see how I am the only one. Do you need a calculator?

Here’s the latest update from today’s troubleshooting…

  1. Ran a Bios Flash/Update to ensure BIOS was latest stable version and BIOS settings were correct for chip set, etc.
  2. Did a clean reset/reinstall of Win11 immediately after the BIOS flash – and completed all updates prior to installing anything – used Revo Uninstaller Pro to remove all Win11 bloat software and apps.
  3. Installed iRacing from scratch – configured system from scratch to ensure app.ini, rendererDXmonitor.ini, core.ini, etc. files were all new and correspond to latest iRacing update.
  4. In app.ini file, I turned OFF the [Force Feedback] settings that will cut FFB if wheel spinning too fast, etc. FFB settings cut and paste below for reference.
  5. I installed ONLY the software needed to calibrate/run my wheel, base and pedals – SimHub for wheel dash, Heusinkveld Smart Control and TrueDrive Paddock software. ALL installed using ‘Run as Administrator’ mode.

Ran a few test laps of the 992 GT3R around Red Bull Ring and Suzuka.

The FFB is STILL CUTTING OUT – but now the frequency is much less and the location of lost feedback is not as regular/predictable as before – so not always the same corners or situations.

I did notice now that the wheelbase is making a Beep – NOT when the FFB first cuts out – usually there are 1-3 short beeps in succession as the FFB is being restored. After the final beep (usually the 3rd), the FFB feels normal again.

I also turned the Sim sound off completely so I could listen to the SC 2 Pro base sounds – aside from the beeping above, I do hear some ‘grainy’ sounds in the base while the FFB is running ‘normally’ – a very slight clicking or knocking sound that corresponds to each bump in the road or texture of the curbs. That may be normal, but since I normally race with headphones on, I’m not used to hearing any sound come from the base. Just reporting what I heard/saw…

SO IN SUMMARY – THE FFB CUTTING OUT PROBLEM STILL PERSISTS – but the circumstances and symptoms have changed since the rebuild/refresh…

I’m at a loss for what to do next…still waiting patiently for a reply from SC Customer Support – haven’t had a reply from them since LAST THURSDAY…and nothing yet today…

I think i read it before on this thread but could you change the strength to appear in Nm. Those beeps could be clipping maybe. Is it possible to try with another usb cable ?

@Loukas_Bourdas Hi Loukas,
I checked that earlier as well, 6.3 = 54Nm if changed, OP posted a screenshot after my request. So even it behaves like hands-off or clipping, it is something else. I am sure we are all going to chuckle when problem is solved, will be something simple.

When I am home, and if no one else has checked, I will compare basics to my iRacing ini as well. But quite a weird one, and those 3 short beeps sure sounds like clipping or hands-off, doesn’t it. But UI settings says otherwise.


Hello!!! Yes but now he is using 5.3 so my guess is it is clipping.

I’m not sure what 5.3 equates to, it would be best if OP just click on maxForce and leave it to be displayed in NM, so then we’re more able to at least diagnose and rule that one point out.

Good catch, I have missed he has increased the ffb strength in iRacing UI.

It’s 54.1 NM. I have also unchecked “Auto” and manually set Base NM to 22 NM vs 25 max. Didn’t help.

Don’t have a 2nd USB cord that fits SC specs…:man_shrugging:

I was testing strength from 4.3-6.3-10.3 and wheelbase from 25NM down to 22 NM.

It’s cutting FFB in ALL settings. Lower strength and NM results in less frequent, but when the wheel “loads” with force on corner entry to mid corner, that’s when it cuts/clips…


If the cable is known working i would try it. It can’t hurt.

Don’t have a 2nd USB cable for Simucube…so can’t try/test that…

Here are screenshots of my iRacing FFB and Paddock FFB settings I tested – (reduced FFB) to try to get the clipping/cutting to stop:

Is it normal for you to use the Q factor?

No, not really, Notch Filter is old remnant from Argon days, which had a use back then, but I suspect very few people will be using it. IMHO, there are better filters to achieve the same outcome.

Mika can confirm if it will remain in the list, but I have not seen a need for it for many years now.

Please change Intensity on iR screen to 0% so
AUTO will calibrate to higher Nm values=less FFb
Then you will feel low forces coming from game so no clipping in this scenario.
Next step is to adjust True Drive strenght and other filter to achieve your dessired feeling

And, as Beano said, dont use Notch filter at all and try to leave Static Force Reduction as low as possible.

Good find :wink: @Alfye20

I don’t know if it is related to your settings as i am no iracing guru but i would start with a simple profile of my own with 0 filters just to see what happens and go from there. Although it should theoretically work since it is from someone using the profile. The cable is not expensive and you can find one basically everywhere. I am not saying that this is the problem but it won’t hurt to try.

When Clipping beeps are in play, the base beeps in a syncronous rithm but no loss of forces at the wheel… You can try Clipping Notifications on desktop ( no game running) and turn the wheel beyond bumpstops, you will hear and feel what SC2 does when clipping.

Loss of forces, 3 beeps and force ramp up, looks like Hands Off Detection. Change that option to Off and save profile or changes.

If everything continues the same… could be a faulty PSU

1 Like

This, this is incorrect as the wheelbase does not load the power supply in any circumstance more that it is designed to supply when used with SC2 Pro.

Also, whatever speculations there may be about certifications, please realize that a PSU safety certification and engineering design are 2 different things and certain changes to engineered design do not always trigger re-certification work for the entire product.

Hands off Detection is off/disabled.

As for the other settings, I didn’t create the profile. I got it from an iRacing pro/streamer who uses SC2Pro. Have been using that SAME profile without issue for months.

Problem with base started when I updated TD software 10 days ago and it requires a FW update. The profile did not change.

I’ve tried other profiles. The base clips/cuts with all of them.

All seems to point to faulty base or conflict between TD and FW…:man_shrugging::man_shrugging::man_shrugging: