rFactor 2 and SimuCUBE

rfactor

#426

i tried it with several profiles, the problem remains


#427

May i ask how do you change settings in your json or profiles because at some point i was altering values in the controller json and i had the launcher open and the changes didn’t apply and i thought that i had the same feel with different settings. Game and launcher must be closed.


#428

game and launcher were closed. In json I have previously set to 25 Nm


#429

i also think that problem is with RF2. as i said, with Project cars2 it works perfectly


#430

still no solutions for the grainy feeling in RF2 with SC2?


#431

as I said, the next time I will be able to test, is today…

It is coming directly from the simulator, though, so its just to add filtering to tune it out.


#432

The SC1 I drive RF2 without filters and it makes no noise. SC2 does not sound good. I’m looking forward to the solution


#433

With rf2, I generally use between 6 and 8 on the reconstruction filter with small Mige / Biss C combo. Any less and yes it feels far too grainy which imho detracts from the nice stuff that you want to feel through the wheel. AC by comparison needs hardly any filtering.

Having said that, once dialled in properly, rf2 for me gives by far the best and most communicative ffb feeling of any of the sims I currently use. The simucube profile helped with this also iirc.


#434

Testing proved inconclusive so far today. I managed to dial the horrible grainyness out but only after reflashing firmware. Need to get debug data tomorrow or Thursday.


#435

OK; the files I supplied over the weekend were just wrong, but there was pressure to get them to you before start of Le Mans 24h.

Another issue is that even if I have a correct Simucube 2 profile in the game folder, which is autodetected properly and feels kind of OK to drive, then when I plug Heusinkveld pedals in, it gets detected instead, and just wrong FFB profile is applied in game.


#436

Simucube 2 Drivers, try these. Delete existing controller.json, assign your controls, and copy the FFB section from these files.

Or delete controller.json, press Detect in game, and verify that the correct device was detected.

For completeness, my settings for the test session:


#437

is the horrible grainy gone?
why 900 * steering range? In the json file is 1440 *


#438

Although i don’t have simucube2 i would like to give some recomendations to you @Mika in order to test them and make the experience even better for simucube2 owners.

“Steering Wheel Maximum Rotation Default”:1440,

since you set the steering range in simucube at 900 and the game can’t autodetect the change i would say it should be like this

“Steering Wheel Maximum Rotation Default”:900,

since you have set the Nm in json to match the servo capability i would say that using full 100% overall strength in simucube should be optimal. But then you should lower the
“Steering torque per-vehicle mult”:1,
since you have 3 servos available this line should defer i guess so i don’t have a number for you.

“Steering Wheel Bump Stop Harshness”:50,

i don’t know if those work atm but when they do it should better be lowered

“Steering Wheel Bump Stop Harshness”:20,

“Stop Sequential if Neutral Configured”:1,

if you use paddle shifters and you get to neutral can you go in to reverse ? check that a bit since i think it should be set to something else but i don’t remember

“Off-road multiplier”:0.3,

check the forces when you go offroad, if they are a bit aggresive lower it to
“Off-road multiplier”:0.1,

“Steering torque filter”:4,

since you propose reconstruction filter , give it a go with lower values for the filter ingame.

  1. “Steering resistance coefficient”:0.1,
    “Steering resistance coefficient#”:“Coefficient to use for steering resistance. Range: -1.0 to 1.0”,
    “Steering resistance saturation”:0.1,
    “Steering resistance saturation#”:“Saturation value to use for steering resistance. Range: 0 - 1.0”,
    “Steering resistance type”:0,
    “Steering resistance type#”:“0=use damping, 1=use friction”,
    “Steering spring coefficient”:0,
    “Steering spring coefficient#”:“Static spring effect rate (-1.0 to 1.0)”,
    “Steering spring saturation”:0,
    “Steering spring saturation#”:“Static spring effect peak force (0.0 to 1.0)”,

these lines are really crucial . I don’t have a recomendation for you but if you want to improve the feel for your gamers you should try other values and see what happens for simucube2. “Steering resistance type”:1, for me was better in simucube1 to mention one.


#439

Yeah, I’m not an expert in any rFactor 2 stuff, I must admit that. My interest here is to fix the grainyness issue, and I suspect the erroneous small nonzero minimum force value caused it. And it is default for any undetected controllers - I got it when game decided that I have Heusinkveld pedals as #1 controller -> no Simucube json file settings were used.


#440

Noone is an expert , just trying to help , since i think that if granite makes these profiles for most of the games it could be an added value for your product.

In any case even if you don’t test everything , my first recomendation as oliver posted before me , with your settings i think that the steering wheel will not have the correct dor.

maybe windows has a list for this hardware as to what is first , second etc that you can rearrange in order to feed the simucube2 as first device for rf2 ?


#441

Windows does have this kind of list and preference order, but as far as I know, there are no tools to rearrange it.


#442

i never had a problem with that in terms of the json , and there were more devices than just 2 or 3 . Anyway although you don’t have to fix something like that check this


if it works for you , you could put it as a recomendation if the same problem arises for other users aswell.


#443

The issue has not been solved at all, same grainy feeling with your settings on as well.
Sorry for this but I wonder how a company can sell a complete steering wheel system without test it on the main simulators. With simucube 1 the issues could come from the Mige motors (I have never had an issue) but now the entire system come from the same company


#444

We have indeed tested before, but using a low torque motor. As the FFB interface to PC and to sims is exactly the same, it is very surprising that there would be any issue. Did you double check that the configuration didn’t get overwritten by the default one from the simulator?


#445

Something worth clarifying for rFactor2 is:

Controller presets and custom controller-profiles reside in (folder): rFactor2 (root folder) \ UserData \ Controller

The file named “controller.json” (player folder) is an active working file that the game edits based on your controller settings and should not be manually edited as it will only confuse things. This file automatically gets updated when you exit the game.

What is needed here is a custom rF2 “preset” for SimuCube2. Once you add the preset to the supported controller list, start with that and edit (assign controls) as needed, then save it using a unique name. That should be the file that you edit manually (if needed), not the preset and not the file named “controller.json”.

When editing a custom controller profile, always be sure that the game and the rF2 launcher are closed.