rFactor 2 and SimuCUBE

rfactor

#244
  1. Did you have rF2 closed when you changed steering wheel maximum rotation default to 1440?

  2. Did you change this setting in the Controller.JSON file in the UserData\player folder, as per the instructions, or in the OSW_Simucube profile file in the UserData\Controllers folder?


#245

Yeah rF2 was closed anytime I made a change to the json file. The settings I changed are in the controller.json file, I never looked at the other one.


#246

Somehow you’ve got to get “steering wheel maximum rotation default” to stick at 1440.

  1. Are you using the new OSW_Simucube profile which you will see in the UserData\Controllers folder or the profile you had been using before this update?

  2. Have you saved your profile in game after changing the Controller.JSON? That part of the in game screen on your screenshot above is missing.


#247

I’m about to delete the current in-game profile and start over. Nothing else is fixing it.

Edit: Still doing the same thing. I have no idea WTF is going on.


#248

Shouldn´t be set “Steering Wheel Maximum Rotation from Driver” to false?


#249

Yes, I think so. There is a proprietary API / USB command that a game can use to get the maximum steering angle from the driver. This is what Logitech, TM and others are using, I believe. Having searched a full day for any documentation for this, I didn’t find any, so it really must be secret.


#250

No. Quote from Update, "If your wheel actually does support us reading the maximum rotation, you can alternatively set “Steering Wheel Maximum Rotation from Driver” to “true” so we will read whatever you set from the driver. We do recommend setting it to the maximum value in the driver, as we can only make the rotation less in software, not more. "

I have it set to true and all works fine. Maybe makes no difference whether true or false for SimuCUBE.


#251

Its going to be something small and obvious.

Have you saved your new profile in the SimuCUBE firmware? Is it green or red at the bottom of the profile page?

Have you saved your profile ingame? Does it say “(modified)” after the name of your profile in rF2 Controls? If so, you need to save it.

Below are screenshots of both my profile JSON in UserData\Controllers (I called it OSW_Simucube1 so I could keep the default file vanilla) and my Controller.JSON in UserData\player. They are both identical as far as I can see.

“Steering Wheel Range” is 720 because that was the last car I tested. “Steering Wheel Maximum Rotation Default” stays 1440 and does not revert back to an earlier setting.


#252

I was under the impression that “Steering Wheel Range” is tied to the visual-wheel in-game. I need to take a closer look at that and see if the visual wheel matches as it should.


#253

Are you certain that you are altering the correct file? (Admin rights make a difference?)

You need to edit the custom (saved / named) json-file, not the template file (named “controller.json”)

The wording can be a bit confusing in the Roadmap the way it is written.


#254

Both of my files look identical to yours minus one thing; “Steering Wheel Range” in my OSW_Simucube1.json is 540 but in the controller.json it is 400 from the last car I drove. Shouldn’t those be the same? This is driving me crazy.

The default setting is staying at 1440 in both files.


#255

Maybe that’s what I’m screwing up.


#256

Okay, I have confirmed that my “controller.json” does not get altered (at least not out of game).

I changed the parameters as shown below and have 100% confirmed that the Soft-lock feature works and the visual wheel and actual steering wheel match perfectly to the per-car soft-lock rotation.


#257

I changed both the actual controller.json (as it’s named in the player folder) and the one I created that’s named OSW_Simucube1. Is that where I’ve screwed up? Mine still doesn’t work correctly.


#258

I didn’t manually change anything in the “controller.json” file at all but, here’s how it reads now:

“Steering Wheel Maximum Rotation Default”:1440,
“Steering Wheel Maximum Rotation Default#”:“Default maximum wheel range to use when not read from driver, from 40 to 1440 degrees”,
“Steering Wheel Maximum Rotation from Driver”:false,
“Steering Wheel Maximum Rotation from Driver#”:“Whether to read the steering wheel rotation from the wheel driver, if possible”,
“Steering Wheel Range”:540,
“Steering Wheel Range#”:“Degrees of steering wheel rotation, both visual and physical (if available)”,
“Steering Wheel Software Rotation”:true,

It appears this may be the active file, not a generic reference or template file. It doesn’t match my modified json exactly but, as I said, it’s all working here.


#259

Well there’s my problem so now it works! I changed the “Steering Wheel Max Rotation from Driver” to true in that json and that was the wrong one to change. I took what they posted literally and didn’t realize I wasn’t supposed to change that exact one. Thanks everyone for the help!

Another question. Noticed all the FFB for each car is now reset back to 1.00 as a default but even when turning it down almost 50% on a couple cars the forces are still much higher than before this update. Are there some more changes I need to make in any files for a DD wheel that may have defaulted back?


#260

On simucube profile i set the overall strength to 45%, DirectInput damping 45% and DirectInput spring 45%.

They did the OSWpreset.json ready to use those DI effects as they are activated on their .json.

I have 20Nm motor , y guess the 30Nm one needs 30%,30%,30% values.


rFactor 2 update New OSW settings
#261

i have to say since the changes using the OSW profile ive been running the mclarens mp4-8 and 13 and even the 23 and i have to say its transformed the feel of the OSW for me now it feels fantastic.
All i did was what was said above i set 1440 in simucube and made sure same was showing in those 2 files and made sure wheel rotation set to true. For me and i could be nuts but it feels great now. Maybe its just these cars i dont know but im really digging it.


#262

Having the proper steer-lock can help the FFB sit in it’s pocket for each car. Although, having an extra dose of placebo may help a bit too. :wink:

Either way, it’s nice to have things working as intended now.


#263

If you are now using the OSW_Simucube profile that Studio-397 created for this update, you will probably find that there are quite a few FFB settings which are different from those in the profile you were using previously.