rFactor 2 and SimuCUBE

rfactor

#224

I’m super happy they finally implemented it. I followed their write up though and I’m having to turn the wheel too much compared to what it should be. I set the rotation in Simucube to 1440 degrees (as they said that was recommended) and did the same in the controller.json file. I don’t know, need to mess with it more.


#225

Agree, something not right!


#226

I will test it soon.


#227

It seems rF2 may reset the profile to the default settings as the changes I made did not stick. Others have reported it working in S397 forums so there must be a way to make it work.


#228

if you have the game open or even the launcher , the changes you make in the json do not stick. I know that the hard way.


#229

Just to clarify, we need to start the game, setup the OSW using the OSW-SimuCube preset; I set the axis and buttons assignments, save the custom controller profile, then exit the game and launcher. Then locate that controller-json you saved and edit the lines as described in the Road-map.

Read Max Rotation from Wheel Driver to True; I did that and set mine to 1080 and now it changes in-game according to the per-car steering-lock. You can set the maximum lower if you want (or don’t know the hardware’s maximum). I also made sure to set the visual rotation to match (if using VR / visual wheel).

Save the json before closing and test in-game.

Note; you must have “Vehicle Set” checked in the rF2 controller settings. Also, be aware that the default preset uses quite a bit of FFB-smoothing so you may want to reduce that or the Recon-filter to increase detail.

I confirmed that it now works in-game, depending on the car you choose.


#230

Think my problem is I didn’t switch to the new in-game OSW SimuCube preset, I’m still using the same one I’ve been using. I’ll try that and see how it does.


#231

Got my running as well, thanks


#232

Works very nicely, with the OSW wheel 1:1 with the animated wheel and the ingame bumpstop (which I have set at 50) working well.

The new OSW_Simucube profile feels good also, although the settings are in places different from the revised Accuforce profile I was using previously.

Note that in the new OSW_Simucube profile, Steering torque capability is set to 18. You might want to set this to match your servo motor;
e,g, for Small Mige “Steering torque capability”:20,
and for Large Mige “Steering torque capability”:30.


#233

Good tip @Ceolmor . BTW, do you know if it’s possible to tune in some “Under-steer” cues in rF2? Ideally, I’d like some vibration as in AC or RR.


#234

Can someone share the profile you are talking about? I don’t see it in the controller folder with all the profiles. Setting the nm at 20 or 30 for small and lare mige isn’t always the best as i have tested. I can help with settings if someone wants.


#235

Not sure what I’m doing wrong but it just doesn’t work for me. The in-game car is turning a lot less than what I’m turning on my physical wheel.


#236

Depending on the car, it should generally be lower - for example: a PT-1 class car may have only 400 degrees of rotation while the Honda Touring car will have 800 degrees. You should see that change represented in the controller settings after you select the car.


#237

I keep testing the BMW M8 GTE which has 540 degrees. It doesn’t match my wheel at all though; not just visually but I’m having to turn the wheel nearly twice as much as I should have to get the car out of the garage.


#238

Put 1440° in your SimuCUBE profile.

And check “vehicle set” inside rF2


#239

I have 1440 set in SimuCUBE and vehicle set is checked as I have always left it that way.


#240

just to be sure . Steer Ratio Speed and Speed Sensitive Steering are set to 0 ? And Steering Help , disabled.


#241

Here’s my current settings. I was testing it out with the McLaren MP4-13 which uses 420 degrees.



#242

If you have 1440 on simucube rf2 profile you have to put 1440° on " steering wheel máximum rotation default" on the .json file.

Right now you have It on 540°.

Just start over, put 1440° on simucube profile and select the premade OSW file from studio 397 , edit your axis and key bindings and save your own profile .


#243

I had changed that to 1440 in the .json file but it didn’t change anything unless the game changed it back.