rFactor 2 and Simucube 2

rfactor2

#101

we are working on a “add profile” wizard for Simucube 2 True Drive with a simulator selector which would also tell if any specific files need to be changed.


#102

Hi all,

Here is the latest version of rFactor 2 JSON files.
Changes:

  • bugfix: SC2 pro and sport were the same names in the json
  • correct steering torque capability values
  • off-track multiplier reduced to suggested levels

Comments:

  • torque filter remains at 4, as it can be adjusted in game
  • stop sequental if neutral configured -setting is strange, and I’ve asked rFactor 2 developers to adjust this to correct when they include the files in a release

Not seeing the Simucube 2 in rfactor2
#103

Will rF2 get support for automatically applying the correct bumpstop settings?


#104

I have provided them with all the details to do so.


#105

what steering angle do you have to set in TD? 1440 is no longer possible. The car steers like a truck


#106

The same thing happened to me.

You need to make some changes to your controller.json file to get 1440 degrees of rotation back. I noticed my JSON file got changed to 900 after using Mika’s latest update.

If you follow the instructions here:

Software wheel rotation explained

You’ll be able to use 1440 once more in True Drive.


#107

Hi Mika jason files are good …auto rotation is working ok for me …Was driving my SC1 Small midge. biss C. this morning, RF2 tatus 318 around Donnington for about 40 minutes …Then set up my new SC2PRO on the 4 4th lap 4 tenths faster . same setup WOW This WHEEL IS FANTASTIC


#108

I drove rF2 with the SC1 a few days ago. What do I have to set for SC2 now? Can I do this automatically or do I still have to download something?


#109

if you create a new profile or default controller profile in rfactor2, it loads up totally unsuitable profile for DD wheels. You can either try to load the OSW_Simucube profile in-game and reassign controls, or download the suitable in-game profiles from this thread, a couple of posts up. Reassigning controls may still be needed after loading the profile.


#110

okay, thank you. I downloaded the 3 files and put them in the folder. Then I could select the profile in the game.
Do I still have to change something with the steering wheel?


#111

hi Stefan have a look at the post 5 up by EsxPaul follow the software wheel rotation link and do as they say exactly …then in the game settings/ options/ controls select the rotation you want.and your bump stops work correctly …or tick vehicle set and the game will set the rotation auto for you.Also you have to put 1440 in steering range in TD for this to work…Also do not forget to save the settings in the controller simcube2 profile you will have to give it a name … then when you start rf2 it should load that profile automatic for you…also the files MIKA SUPPLIED for SC2 is wrong on Steering Wheel Maximum Rotation Default shows 900 change that to 1440 , as that is how rf2 set it up for auto rotation to work correctly… hope this helps regards denis…PS if you have any probs send me a PM


#112

Ok, rFactor2 must have implemented the auto rotation for sc2 devices then? Great. They never game back to me regarding that.


#113

I tried changing the data. That didn’t work for me. Then I went back to Mika’s version and set the SC2 driver to 900. That seems to be okay. It felt good. But I have rF2 new and don’t know anything about it.


#114

hi mika all of sudden i have a problem with rf2 when at bathurst track and run over the curbs .ie last chicane first corner in gt3 cars the wheel turns hard left and will not return and in TD it goes to Read-only safe profile and high torque mode is disabled and in the Info tab shows created ffb effects shows PeriodicSine and have to reset the device state …i have to get out of the game and reset TD to get the game to work again …when in the game i tried resetting the E-stop but that did not help wheel always over to the hard left…Mika i was driving yesterday and this was not a problem on the same track same car for 3 hours…now when i drive today this happens all the time on high curbs … i am at a loss why this is happening now…regards denis…i have sc2pro


#115

Do you have both PSU’s still connected? can you verify that?


#116

hi mika one psu was not showing a blue light …so i unplug from power at the wall and plugged in again and the blue light came on …that is strange why would the blue light go out …will do some more driving and let you know if that fixed the problem…could it be a faulty psu? Mika just had a 10 minute drive and all good … Why would the blue light go out, as it was firmly plugged in at the wall power point


#117


#118

@Mika first thanks for all the efforts and all those involved, packed in those .json files.
I got my SC2Pro a few days ago and would like to give those settings a try. As concerning files i am a total noob, so if you or anybody in here could help me out with my following questions:

1.) can i place that json file without renaming it into the rfactor/user folder ? (but how does the soft know that this is now the actual file to use ?)
2.) do i have to open an existing json file (and if yes, which one ?) and then copy/paste the code inside that one from the file you zipped ?

Sorry seem way noob, but want to try that out, as my rfactor centering is totally off … means its not focused on centering the wheel its just the opposite. Its quiet heavy to keep it centered. On Assetto Corsa its fine and fun.

Anyhow i‘d really appreciate the input of all of you‘z.

Cheers
Mike


#119

@EMS
In controller.json, which you can find in your C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\UserData\player folder, adjust the “Steering Wheel Software Rotation” to 1440 and “Steering Wheel Maximum Rotation from Driver” to true.
Save the file.

In rF2, go to Options - Controls, and there you can load the Simucube2Pro.json rev3, which you’ve copied into C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\UserData\Controller, the rev3 file you can download on here.

Assign additional buttons. Make sure there are no steering aids selected, within the options. Save.

In TrueDrive, add the rF2 settings, and adjust to your liking.

Off you go.


Not seeing the Simucube 2 in rfactor2
#120

Thank you for your time and your precise description. Worked perfect !