rFactor 2 and Simucube 2

rfactor2

#41

the feeling as far as i know will be better. If you simucube2 pro with 25nm and you use 18nm in json that isn’t right. My opinion and if you check the profiles for dd1 and dd2 you will see that they use the max the servo gives.


#42

sorry Loukas i have misunderstood, I thought you were referring to the % of strength. I already use 25nm in the json file


#43

ok , i thought you were using Mika’s profile.


#44

yes but i changed the nm option…


#45

The line “Steering torque capability” seem to be working as the slider in iRacing.
If I put it at 40Nm, I get half the torque on a Small Mige.

Not sure if it’s a better solution than running 0.5 in-game.


#46

hello, I have the pro too. For me it also makes noise on RF2. Pcars2 is perfect!


#47

Just an idea. It would be very cool and useful to public screenshots/profile files from the devs for every popular title on the market. Of course nobody should use that profile becouse everyone of us have different taste when ffb comes in mind. Speaking for my self personally I would like to see how my osw perform as intended by developers :slight_smile:


#48

i tried it with several profiles, the problem remains


#49

May i ask how do you change settings in your json or profiles because at some point i was altering values in the controller json and i had the launcher open and the changes didn’t apply and i thought that i had the same feel with different settings. Game and launcher must be closed.


#50

game and launcher were closed. In json I have previously set to 25 Nm


#51

i also think that problem is with RF2. as i said, with Project cars2 it works perfectly


#52

still no solutions for the grainy feeling in RF2 with SC2?


#53

as I said, the next time I will be able to test, is today…

It is coming directly from the simulator, though, so its just to add filtering to tune it out.


#54

The SC1 I drive RF2 without filters and it makes no noise. SC2 does not sound good. I’m looking forward to the solution


#55

With rf2, I generally use between 6 and 8 on the reconstruction filter with small Mige / Biss C combo. Any less and yes it feels far too grainy which imho detracts from the nice stuff that you want to feel through the wheel. AC by comparison needs hardly any filtering.

Having said that, once dialled in properly, rf2 for me gives by far the best and most communicative ffb feeling of any of the sims I currently use. The simucube profile helped with this also iirc.


#56

Testing proved inconclusive so far today. I managed to dial the horrible grainyness out but only after reflashing firmware. Need to get debug data tomorrow or Thursday.


#57

OK; the files I supplied over the weekend were just wrong, but there was pressure to get them to you before start of Le Mans 24h.

Another issue is that even if I have a correct Simucube 2 profile in the game folder, which is autodetected properly and feels kind of OK to drive, then when I plug Heusinkveld pedals in, it gets detected instead, and just wrong FFB profile is applied in game.


#58

Simucube 2 Drivers, try these. Delete existing controller.json, assign your controls, and copy the FFB section from these files.

Or delete controller.json, press Detect in game, and verify that the correct device was detected.

For completeness, my settings for the test session:


#59

is the horrible grainy gone?
why 900 * steering range? In the json file is 1440 *


#60

Although i don’t have simucube2 i would like to give some recomendations to you @Mika in order to test them and make the experience even better for simucube2 owners.

“Steering Wheel Maximum Rotation Default”:1440,

since you set the steering range in simucube at 900 and the game can’t autodetect the change i would say it should be like this

“Steering Wheel Maximum Rotation Default”:900,

since you have set the Nm in json to match the servo capability i would say that using full 100% overall strength in simucube should be optimal. But then you should lower the
“Steering torque per-vehicle mult”:1,
since you have 3 servos available this line should defer i guess so i don’t have a number for you.

“Steering Wheel Bump Stop Harshness”:50,

i don’t know if those work atm but when they do it should better be lowered

“Steering Wheel Bump Stop Harshness”:20,

“Stop Sequential if Neutral Configured”:1,

if you use paddle shifters and you get to neutral can you go in to reverse ? check that a bit since i think it should be set to something else but i don’t remember

“Off-road multiplier”:0.3,

check the forces when you go offroad, if they are a bit aggresive lower it to
“Off-road multiplier”:0.1,

“Steering torque filter”:4,

since you propose reconstruction filter , give it a go with lower values for the filter ingame.

  1. “Steering resistance coefficient”:0.1,
    “Steering resistance coefficient#”:“Coefficient to use for steering resistance. Range: -1.0 to 1.0”,
    “Steering resistance saturation”:0.1,
    “Steering resistance saturation#”:“Saturation value to use for steering resistance. Range: 0 - 1.0”,
    “Steering resistance type”:0,
    “Steering resistance type#”:“0=use damping, 1=use friction”,
    “Steering spring coefficient”:0,
    “Steering spring coefficient#”:“Static spring effect rate (-1.0 to 1.0)”,
    “Steering spring saturation”:0,
    “Steering spring saturation#”:“Static spring effect peak force (0.0 to 1.0)”,

these lines are really crucial . I don’t have a recomendation for you but if you want to improve the feel for your gamers you should try other values and see what happens for simucube2. “Steering resistance type”:1, for me was better in simucube1 to mention one.