Not seeing the Simucube 2 in rfactor2

My first time opening rfactor 2 since I got the Simucube 2. I can’t find my new wheel base and pedals at the same time. What am I missing ? Hit the detect button but nothing showed up.
Please advice

Read this, not just my post.

1 Like

To begin with,
in player folder which file we are editing and save?
in rf2 where can we find that Simucube2Pro .json rev3 file?

You have to download and put the .json rev 3 file into the folder manually. Then you can go into the game, select that file and then assign your controls and adjust to your taste.

You can find the files here:
https://community.granitedevices.com/t/rfactor-2-and-simucube-2/2975/102?u=esxpaul

Thanks EsxPaul
I have downloaded it and paste into the Control folder.

Loaded and accepted in rfactor2 but unfortunately nothing really seems work.

Just like it is not connected at all. Nothing… no sign of live …

That’s strange.

So the game cannot recognise your pedals or SC2 when you try to assign them in game.

Are they connected directly to the pc or are you using a usb hub?

directly …

yes it is exactly like how you describe, used to work with my t300 and now not sure why…

nothing works basically…

I can see they been founded but no a sign that there are actually connected in the interface right after you detect/load them

How about doing a Steam file integrity check? Could be worth a try.

Edit: Another crazy long shot but @Bazz had a somewhat similar issue with assigning controls in F1 2019 and managed to fix it by switching his hardware back and fourth between usb ports. You can read what he did here:

https://community.granitedevices.com/t/f1-2019-help-needed/2952/15?u=esxpaul

1 Like

Do you use irffb? If it’s running in the background it will stop other games from working.

i assume you are saying iracing ffb?
if so how to stop it?

do you mean i haven’t loaded the profile correctly from True drive?

Hi Paul, how to do the steam tested you mentioned ?

Hi Maxx

My explanation would be rubbish so I’ll link you to the official instructions. Only takes a few minutes to do :slightly_smiling_face:

https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335

Thank you Paul…

I need help, there is no any response in Rfactor2 but it used to be fine with other wheel base…
I did downloaded the simucube2 pro json file
Pasted into the C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\UserData\Controller
loaded in Rfactor2
deteted the simucube 2 pro file

BUT there is no ANY response in Rfactor2, feels like not connected at all. I know the wheel base is on , the torque is constantly there, but the wheel just has no connection to the rfactor2.

WHAT SHOULD I DO???

I just tried rfactor2 for the first time ever, I copied the JSON file and I can select it rfactor2 but steering doesn’t register.
By the my pedals which work in iracing and AC, ACC also did not reguster in rfactor2.

@Cyberbug after you have selected the simucube profile IE sport pro or ultimate , Recalibrate rotation left and right you may have to rotate the wheel more than 540 in either direction , then do the buttons and any thing else you want to map .then everything should work ok

2 Likes

hi there,

complete noob to rfactor, I have just received my Simucube 2 pro and wanted to give it a go with the demo, I’m still waiting for the pedals to come but I want to try to map the brake and accelerator to the paddles just to try.

unfortunately the button work but not the steering, I have tried modifying the controller.json etc but nothing happens :frowning:

download the simucube2 profiles from here https://www.dropbox.com/s/vv68vz8g7gq7lyk/Simucube2_rfactor2_json_files_rev3.zip?dl=0 and copy paste the pro profile inside the UserData\Controllers folder of your rfactor2 installation (to be sure you put it in the correct folder , this should contain profiles from almost all known wheels of the market) . Then load the profile inside the game and map your steering and everything else you need.