Motor goes crazy after updating Windows

During the game (iRacing, Automobilista 2) the motor of the SC2 Sport goes crazy. Suddenly it starts shaking (AMS) or it does nothing (iRacing). I can only press the E-Stop (AMS) or quit the game (iRacing). Even rebooting the PC doesn’t help. I updated Windows to version 2004 and I am using the HP Reverb. Is my SC stuck or is it just a software problem?

Don’t you have another laptop/desktop to check to be sure?

Only an old one. No game will be running there.

Post your settings for the filters you are using on the SC2, please. Sounds to me you are running the raw unfiltered profile where oscillation will of course be a standard feature :wink:

I did not have any problems before updating Windows.
I always use raw profiles. The problems start suddenly after playing a couple of minutes.

Edit: Three days ago I played AMS2 for more than 4 hours without having any problems. Yesterday I played it also for about one or two hours, also no problems. Using a raw profile.
After playing AMS yesterday I did the Windows update 1903 to 2004.
Today in the morning I played about 30 minutes. No Problems. Then I started a race against the AI. 5 min practice, 10 min qualifying and 10 laps. Everything was fine until lap 4. Then suddenly the wheel stated to get crazy. No changes in the true drive profile.

The infamous 2004 update… Dont know if my PC is running it right now but its scary

1 Like

so apparently that last win update is really doing something?

I have been using Build 2004 since i could force the install of it (upgrade, not fresh install). With all lastest drivers and did maybe 7-8 races (VRS Iracing, 40min each) with SC 2 Pro and Rift S. Even used the lastest Nvidia 446.14 that everybody warned about with VR/Iracing… , no issues at all with anything.
(Intel 9700K @5.1 / 1080Ti (OC MSI afterburner), MotherBoard Asus Z390, latest BIOS)

(go through ALL USB devices in Device Manager(see pic below) and check for Power Management, uncheck all). After updates/hotfixes from Win10 those values sometimes enables themself)

I also run True Drive 2020.4 in “Easy Mode” not Advanced if it can matter… doubt it.


Strart -> Run -> winver to see build



1 Like

2004 here. No issues on AC, ACC, R3E.
Try to uninstall USB controllers, reboot and let Windows install the right ones, there could be conflicts.

1 Like

I did a Windows downgrade. Wheel was still going crazy. Then I deleted and re-installed the USB-controller and it worked fine for more than two hours. Tomorrow I will have another test.

1 Like

What motherboard you have?

MSI B450 Gaming Plus

Yesterday iRacing was working fine. Today I tested AMS2 and the problem was there again. Suddenly the motor starts to go crazy (a lot of vibrating and turning to the left). I tried to make a small video. (in real I didn’t turn the wheel that much and hard - just a tiny turn right)
I had to push the e-stop. After releasing the e-stop my wheel was turning and my wheelposition is at 435° I have to reset the center.

@Mika do you have any idea why the wheel starts turning, after that I just touched it? Can I do a factory reset? Something is wrong. Or is it just a problem between Automobilista 2 and the SimuCube? I already deleted all AMS files in my documents. In iRacing yesterday everything was fine.

hi, do you have those issues while calibrating or mapping wheel inputs into ams2 or while playing? i’m telling this because it is a known thing, I did like this : when I map or calibrate the left/right inputs, first I set sc2 torque at the minimum value, then set all ams2 ffb values at zero - most important is the “menu spring” value. I then map and calibrate the wheel with barely no force in the wheel itself, and just after that I set td and ffb values as normal. this is currently the only way to do all that without the wheel spinning crazy into the ams2 menus. hope it solves things for you. let me know :slight_smile:

Thanks @SuperMonaco_GP I will give it a try. I had the problems, while driving and today while I was in the menu (virtual reality) and for the first time in TD while just touching the wheel.
I just deleted AMS and all files of it. I reinstalled it and now I am gonna test it.

1 Like

Why not just have the e-stop pressed when assigning controls. Much safer that way.


It seems there is a problem with AMS2 and the SC.

After reinstalling, assingning controls worked well. I did it with the pressed e-Stop before and now with the method @SuperMonaco_GP told.
I started a Test drive and the FFB felt horrrible, so I tried the customFFB (Automobilista 2 - Simucube 2).
While changing the settings in TD the wheel started to go crazy (turning until e-stop was pressed) as I changed “Inertia”. So I closed TD, turned of my SC and changed the FFB profile in AMS to custom. After turning on the SC I could change the settings in the TD profile.
FFB feels good. I could only test it for some minutes and will give it a try later this evening.

Thank you all for your advices and your help.

Maybe the ffb is inverted in ams ?