Messed up my IONI..Granity gives error

What should the FOV and FUV setting be? I’ve managed to access granity, firmware updated to 1.7.20 and Simucube 1.0.30

Typically for example 30.0 V for FUV and 50.0 V for FOV.

Getting an error"Couldn’t connect to Ioni, reconnecting" can you assist on anydesk?

Can you tell me what encoder I have?

I do not have information on that encoder model number. The “couldn’t not connect to IONI, reconnecting” -thing is not related to any encoder stuff, but some fault with communicating with the servo drive. Does that come up right when you start? can you paste the debug event log from the Simucube Configuration Tool?

It will double check my files in the morning to be sure, but I am pretty sure that is an incremental 10k encoder.

Shouldn’t Nic revert to the Mmos2014 mode that was working and then start from a specific point and maybe ask Joe to take him through the steps in the correct order

It’s a standard 10k PPR/40k CPR incremental encoder Mige used to sell on the earlier servos. It is simply a case of configuring his IONI via Granity for the correct settings.


Rob if he already has Simucube software installed he has to use the dip switch method to revert to MMOS.

He told me he spent all day trying to get it to work. So I have no idea what he has done.
I would imagine I will have to start from scratch.

I should be able to help him tomorrow.
We had a big thunderstorm here yesterday that took down trees and we had wide spread power outages. Our Internet is still down. Hopefully it will be fixed by tomorrow.

With the time difference between USA and SA that makes things a little tricky. :slight_smile:
At least it looks like we can communicate thru Whatsapp.

Mika and Beano This one is an odd one. Please help if you have any ideas.

After doing all of the proper setup via reset all in dfu etc I get this error message

I have everything setup proper in the newest Ioni firmware.

I did have difficulty accessing dfu at first. It took many times moving the dip switches before anything was in the device list.
This could have been one of the boards that had the slightly oxidized contacts.

I tried 11.2 and the newer 1.03

All drivers seem to install correctly.
I then tried reverting back to MMOS. With MMOS setup the wheel is very heavy no matter what I set max force or Ioni amp settings.

Bear in mind I am doing all of this remote.
Nicolas is in Capetown SA

At first I was getting errors in Granity before manually updating the Ioni firmware.
As you see there are no error messages in the test tab.

It seems the Simucube is just not communicating with the Ioni

I also should mention that this control was functioning normally on MMOS before Nic tried upgrading to Simucube software.

Not sure what could have gone wrong in the process.

We have had exactly one Simucube previously, where the chip that muxes either the Simucube processor or the X4 USB port to IONI, had a fault. This looks like it may be the same type of fault.

The thing is I used that exact base with Mmos2014 for at least 12 months and it worked perfectly. It also worked 100% until my friend Nic tried to upgrade to SC1

Mmos uses PWM&DIR signals to control the IONI, instead of the digital bus that Simucube firmware uses.

Thanks for your input Mika.

I tried all of the tricks I know several times and nothing worked.

Once I did not have errors displayed at the top of the Simucube screen, but as soon as I tried to run motor config the driver error came back.

I guess Nic has to buy a new Simucube board.

It looks like the Ioni is ok.