Messed up my IONI..Granity gives error

the disco board is inserted onto another board (with the 2 big capacitors…power board?) and then you can see in background the IONIcube board/servo drive.

Thank you.
yes…this worked! i did not realise i had to use the mini USB end, not the micro USB.
I’ve just flashed the mmos Hex again… and yes Mmos is back, and it’s green.

But i still have the issue with Granity - it still comes up with Communication error flags.

EDIT…panic over. IT was just my crap network. Copied granity files over to local drive and its fine.
Thank you all.

1 Like

i have fixed all this now, thank you.
I now need to figure out what hardware i need to replace in my current setup, so i can install Simucube! I shall leave that for another thread (If i cannot figure it out myself that is!)

1 Like

That’s why i was telling you to connect the disco board directly. Update the ioni firmware because it has a lot of improvements but be careful not to wipe your granity settings.

You need to buy a Simucube board. :slight_smile:

If you are in the USA send me your contact info and I might be able to help you with your upgrade to Simucube.

Hey guys I’m very interested in converting my DD to Simucube software as Gifford has done but my son races 5 days a week and I am honestly terrified of making a blunder …I have a genuine Simucube 1 board but since I posted a few images in another post I think joe said my board is one of the older versions …is there possibly any of you well informed gents could actually at some stage physically go on voice in discord or somewhere and help me … The other prolly more expensive safer way would be to buy a new Simucube1 board and ioni controller and do it without the risk of making a blunder.
This is my previous post

Hi Robert,

Will voice on whatsapp work in your country?
I have never tried voice on there, but might work ok?

I am willing to try to help you, but I hate discord!
I have tried to use it twice and I get an echo of everything I say.
We switched to cell phone really quick.

Teamspeak or even I see telegram now has voice options

Hi Joe

I bought this Simucube 1 from Robert and have converted to the Simucube software but I’m getting an error.

I think Joe saw pictures of that previously, and it is not a Simucube board. Can you take pictures so we can all confirm that?

Hi Nicholas,

Ahh I heard Robert Bought 2ea SC2! :slight_smile:

That is a Simucube board. It is one of the early versions, but you should still be able to put the Simucube software on it.

I would have updated the Ioni firmware version before upgrading to Simucube software. You need to be careful not to kill the ceramic resistor.
I don’t remember which Ioni firmware added the protection to not send too much current to the resistor in the configuration stages.
Maybe Mika can answer that.

What error message are you getting?

“Couldn’t connect to Ioni” it was first saying update error, start and restart.

How will I know if the Ioni is messed up?

And do I need both Usb cables connected for it to work.

Yes you need both USB cables hooked up.

I don’t think you will damage the Ioni.

What I am saying is you need to be careful and make sure you have the correct . drc file loaded on the Ioni for the motor you have.

So when you upgrade to the Simucube software when you run the motor configuration choose the use drc as is.

Do you possibly have a link for the file, I tried all day yesterday and could not get it to work. It’s also not connecting in granity and I have both Usb cables connected now

Once you completely have the Simucube software installed and configured you can use only one USB cable as long as you don’t need to make any adjustments to the Granity/ Ioni software.
I personally always kept both USB cables plugged in.

What motor do you have and what encoder does it have?