Help with a fault please

Hi guys so im using a simucube 2 pro (R2), and my main wheel is a momo wheel on an ascher b24L-SC button box.

80 percent of the time i have no issues however 20 percent of the time i have lots of mis shifts, sometimes ill shift up and nothing happens, sometimes down the same thing. the connection between the wheel and base is 100 percent and i am using the antenna. I cant work out if there is an issue with the wheel or the wheelbase or if there is some kind of interference, i do use bluetooth headphones but often this happens when they are switched off.

i have the wheelbase connected through a USB hub rather than directly to the pc, maybe this is the issue?

any advice is appreciated, happy racing guys.

Which software release are you running?

it is the latest, 2022.7

I am having the exact same problem. Started just recently. Using Simucube 2 Pro and Ascher F28-SC V2 wheel. Been using it for a few months with no problem at all. But like I said, suddenly it started doing this. For me it skips downshifts way more often then upshifts. Its the same in both iRacing and ACC. Have been talking with because its from there I bought my gear, but they dont know what could be the issue. They asked me to do several tests, so I did. But the “skipped input signals” (misshifts) is there no matter what I do. I am not using an USB hub so thats not the issue for me.

I even did check the “clicking” sound in a silent room. To check if I could physically hear if there was any difference in the sound from the right and left paddle. But there was not.

I should add that I checked the battery and connection. Connection is 100%. Battery first showed 3.56V, wich I have come to understand is good? But then the day after it showed something else. Sometimes it showed 3.53V and then 3.54V, and 3.56V. In other words it jumped back and fourth a bit when I opened True Drive every now and then to check. Is this normal?

I have absolutely no idea what is causing this, but this is not just a little “issue”. Its a very big problem. My rig is basically undrivable now as it stands.

So if anyone know the answer, or comes across it, please do let us know.

We are of course investigating if there is something that could cause this suddenly, but we haven’t found a way or reason why this should happen.

thanks for your input, i can confirm it happens to me a LOT in ACC, have not played iracing for some time so cant confirm it there. its exactly like you said where i have been using the base and wheel combination for a long time and its only recently been an issue… i suspected i was having an antenna issue so i even rotated the base 45 degrees to expose as much of the antenna as possible even though its saying 100 percent. i can only say ive noticed it only on the latest driver, never before.

i just know for sure either the ascher button plate on the wheel is skipping shifts or the wheelbase is not picking them up. I cant be 100 percent certain but i am also pretty sure it happens mostly on downshifts when shifting rapidly to get maximum engine braking, its not engine protection either its definitely hardware related. Maybe i notice it more on the downshifts because they are more critical for entering a corner and often it will not shift down when i ask it to and i then mess up my corner entry.

thanks, we can only ask for you to investigate what you can within reason as im sure you have other things to do ofcourse. It does seem to be a recent issue and by recent i mean almost certainly with the latest driver for me, i dont know if this has altered anything to do with the wireless connection to wheels or not but if it has altered anything in that regard it stands to reason there could possibly be a bug there.

I would suggest to try to figure out if this is an issue of the wireless connection or the wheel …

We all recognize missing shifts as imho this as the paddles are the joystick buttons that we use in 99.99% of the clicks - we may not recognize if there are missing clicks on any of the other button (on my CubeControls F1 Pro I would not be able to judge if a rotary encoder for Bias etc. is missing one click).

So my tipp is to download vkb joytester as this will report each click/release, deattach the wheel from the base, walk away from the base and see if it starts to miss clicks are or if you get a complete disconnect - that’s what I would expect and every disconnect needs a reconnect that needs some time.

@GR, what time is needed for a reconnect? I only have BT wheels and my custom one is BT4 which takes a significant amount of time to connect - if this is longer than the time of missing shift clicks (e.g. 2sec vs. 1sec.) it is more related to the buttonplate/wheel.

An additional check would be to see if other buttons have the same issue, but you never recognized … again use VKB joytester and press one button several times 10,20 or 40 and check the log if you see exact the same number of click in joytester - this only makes sense when it usually happens every <40 clicks.

1 Like

cheers ill dig into that tomorrow at some point and see how it goes. thanks.

I confirm that I also have this problem with the wireless steering wheel :frowning:

yup… i still have it, no idea what is causing it i just think its been a thing since the latest update for me, ofcourse we cant roll back.

ahh thanks for that, ill have to give it a go i think because im literally on the verge of selling it off because i dont feel like using it as it is. ill report back if i see noticeable change from firmwares.

I tried changing the battery today and it seems to have fixed the problem. At least I have not had any misshifts yet in about 30 minutes of testing. Before I changed the battery it misshifted just about every time I came into a corner, so… It seems to have worked. The wierd thing is that when I am driving in iRacing it does not misshift, but when I look at the True Drive software then it does not show an input signal everytime i press the paddle. Like it is suppose to still misshift. Yet it does not misshift while in game. Now that being said, the battery life on this wheel is NO WHERE NEAR as long as it is said that its supposed to be. Because it seems like when the voltage of the battery drops just a tiny bit of its original fully charged state, then the wheel becomes unusable. In other words, always have a spare battery lying around. And when you need to change, buy a new one right away. So that you always have it available.

The battery was suppose to last about 2 years with heavy use every day. Well… I have had the wheel for just a couple of months, and it has not been used much. Not much at all I would say.


for me it seems to be very very inconsistent, i have not touched my rig in over a week because im slowly losing motivation to race knowing that the issue is there but last night i jumped in and did a race and it was perfect… That seems to be how it goes for me with this so far, sometimes ill jump in and its perfection and sometimes ill jump in and there are clearly mis shifts and i end up spending time wiggling around the antenna on the back to see if i can get it to behave any better and stuff like that instead of actually racing.

i will however change the battery on your advice, its not too expensive so why not, i also have not had this wheel more than a few months at most and race just a couple times a week so the battery really should be in good condition but im going to replace it anyway, maybe it was shelved for a long time before sale i dont know.


Have you had the opportunity to change the battery? If so, did it fix the problem?

I can report that I still havent had a misshift since I changed the battery on my product. So far it seems to be ok. I just hope that it’s not just a coincidens. I also have a second brand new battery available here at home just in case it happens again. If it does happen, then I will change the battery straight away to find out if the problem goes away again. And if that happens, well then I will know for sure that its the battery in the product that dont last nearly as long as promised.

hi, i ordered a pack of 4 batteries and every single one of them arrived dead, reading 2v in true drive, unbelievable, i will order more soon and get back, my original battery is reading 3.59v so it should be basically like new but i will change it either way.

Oh :flushed: Sorry to hear that. I would have been furious let me tell you.

I just wanted to report that now I have not had any misshifts at all since I changed the battery. Many hours of testing now. I also have one more brand new spare battery lying around. Because well… The battery does not last as long as advertised. Obviously… But its ok now that I know that the problem wasn’t worse then just a battery change.

thats good to hear, i finally have another pack of batteries on the way, apparently their customer service was in america so they would email me in the night and id email them in the day so it took a few days for them to actually decide to send me another pack, i wasn’t going to just buy another pack and take the risk so i waited to see what they said and yeh they are sending me more so in the coming days ill be able to tell you how it goes.

ive been having better luck with the original battery recently quite ironically, not noticed anything consistently wrong, what i find when playing ACC for extended time is the shifts are crisp and immediate at first but after 20 mins or so of driving suddenly shifts are not happening when i want and often ill have to click again… so im really starting to doubt myself about what is going on, is it some kind of damage to the car in game i really dont know but as far as i know there is no gearbox damage in game, engine damage yes but not gearbox or is there? but i shift when i should anyway im not a rookie racer at all lol

ill let you know how new batteries go, ill change it anyway to be sure.

I really hope it works out for you with a new battery. If it does not, then I will be paranoid about my own wheel again.

Just a little side note. I bought my battery here at the lokal mall. They have a store chain called Clas Ohlson. The name (number) of the battery there was LS 14250. Now I know people have said that it should be ER 14250. But apparently LS and ER goes for the same. At least thats what I could find out on the internet. And my LS “version” of the battery works just great. For now at least.