Drive firmware update error turn system off and on again


#22

OK I will take a look. Give me a moment


#23

OK, It’s showing 48.0 VDC


#24

OK, so this might then be caused by having 10.5 A both as Maximum Motor Current and Maximum Continuous Current values. Please put Maximum Continuous Current as 10.0 A.


#25


#26

The Motor type should be 3 phase AC or BLDC.

I wonder where/why your settings are so wrong.


#27

No Idea, I will change it now
Is there a way to reset things?


#28

There is no way to reset settings as such, but your are not far off from the settings that should work.


#29

ok great so that fixed it !! thanks!!


#30

So this now leads back to the original query about SIMUCUBE. After trying many times I can’t get it to work. At this stage I maybe should go back to MMoS. Can someone let me know the steps?


#31

i ll try to help you down bellow


#32

It turns out that @Charles_Kellyman has a STM32F4 Discovery + IONICUBE build, thus it is not compatible with Simucube’s firmware.

If there are good experienced people that know how to flash the STM32F4 on his Discovery with the MMOS hex file, please help! I’ve never had such system and do not exactly know what tools are needed. Also helping in blind with no physical access to the hardware is difficult thing.


#33

Before you continue , run MMOS , if the light is green stop reading. If the light is red continue.

open granity , connect , load settings from file (attached below) and save them

10010_MAX_unlimited-48v_5Kppr.drc (9.2 KB)

i don’t know what psu you are using to adjust mpp setting.

then go download STSW-LINK004 https://www.st.com/en/development-tools/stsw-link004.html#getsoftware-scroll . install it and open it.

connect your disco board with your pc

a.connect
b.erase chip
c.program & verify
d.select hex file located in MMos_FW_0.99.2.zip (if you don’t have it tell me, just in case https://files.fm/u/ytvqkxpg)
e. flash
f. disconnect
unplug it from your pc.

then plug disco again to your pc and open mmos forcefeedback 2014 located in MMos_Tool_0.91.zip (if you don’t have it tell me, https://files.fm/u/ytvqkxpg)

now the light should be green. press setup and make the changes like this
index

and see if it is operational like before.


After MMos to Simcube getting an error
#34

Thank you I will try this tomorrow

Fingers crossed


#35

Also make sure to check use encoder index. :wink:


#36

He already has working settings in IONI, no need to reload the drc file. And use encoder index is something that can be setup after initial install when thing is otherwise working.


#37

i know thats why i didn’t tick encoder index from the beginning. I saw too many errors in granity thats why i told him to load the drc , atleast he should set DIV=MUL=100 , lower MCC , and increase FOC to maximum but i prefered to give him the file to be sure.


#38

I just mentioned it because I saw it was incorrect.


#39

Hi guys…
I very replieved to say I have MMos working again thank you so much for your help!!
I did load that *.drc file. I have found that everything seems exaggerated in regards to FFB now also the wheel is quite notchy. Not as smooth as before. I saved the *.drc file @Mika helped me with last night. Should I reload that one?
I don’t to do anything wrong


#40

just lower mmc , i had it at 12.86 , go 10.50 . If this doesn’t cut it for you , change Div=Mul=50


#41

OK will try that when I’m back on the other PC tomorrow