Dfu mode ioni 1x


#1

Hi, I’m a tomomeglic owner of the first ones.

The motor is a small 20nm.
The encoder I think 10000ppr (I’m not entirely sure)

It worked well with Mmos, I tried to upgrade to simucube but it has been impossible for me, when configuring the engine, I get the message in red ioni couldnt connect, reconecting. and there’s no way it works.

I have given up, but now I am unable to put the card in Dfu mode to reinstall Mmos.
I have looked at a thousand post and tutorials but I am unable.
In the device manager, I get simucube, I have tried on another pc and I get Hid game device.

Nothing of stm32, nor anything of dfu mode, do what you do.

Any ideas? I’m a little desperate and I do not know what else to try.


#2

Is it a Simucube control or IONIx1 control?
Post a pick and we can help.

Also have you tried contacting Tomo?
He will get you sorted! :slight_smile:

You will likely have to flip the dip switches on the Simucube and install the bootloader dfu.


#3

I do not have the tome contact, I did not buy new.

I leave some pictures to see if I’m confusing myself in something.


#4

That is a STM32F4 Discovery & IoniCUBE system.

It is not at all compatible with the Simucube firmware.


#5

you don’t need to do everything from there . you basically have to flash the mmos hex file again. Ignore the part with the drc file since it shouldn’t be wiped but if it is we can make you one. since the links of the files are dead there i reuploaded them here https://files.fm/u/g2wnn53f . If you restore mmos , and you have the 10000ppr you have to put 40000cpr in mmos settings and not 20000cpr like the picture.


#6

Also I do not see any wires hooked up to the discovery board input.

Here is Tomo contact. Used does not matter still contact him.
simracingbay@gmail.com