Win10/ Game wheel controller not detecting the Simucube hardware

Greetings fellow Sim-Heads.

My name is Jack. I started racing back in 1974 on an Atari running the Gran Trak 10 racing game
and did the Amiga deal in the 80’s, then in the 90’s I moved to the PC when they became a thing.

Problem: Windows 10 Game controller/in game wheel controller not detecting the Simcube hardware.

I figure the best way to solve my multiple problems is the same way you eat an elephant, a small piece at a time.
This post will start with basics setup questions, as I have spent days on the forums and websites looking for answers, but there are so many combinations and permutations of what OSW people own, and may give good advice on MiGe 130ST-M10010 setup, but they have a ARGON , and not a IONI driver, or it is a decade old post and the info given on setting up the software is out of date.

Here is my current SW and HW.
Hardware: I currently have just Frankensteined a used Sim-Lab frame together.

Have installed and plumbed a pre-owned OSW Simcube MiGe 130ST-M10010/Biss-C system with IONI SERVO & STEPPER DRIVE. It is powered by a Mean Well 480-48/120v. Have no idea if it has ever worked.
Software: I have installed Granity 1.15.1 followed by simucube_fw_open_beta_0.11.0, then updated to Simucube_fw_1.0.40. as well as flashed the IONI board with IONIFW-1.7.20. driver.
Software installed on my desktop: Dfu file manager, DfuSeDemo, STM32 ST-LINK Utility, Granity, Simucube Configuration Tool, and USBDeview.

The wheel did phase at initial startup, and both led lights on the motor controller are green. Wheel has force but does not show up in the Windows game controller.

Here are my Configs:

Here are the Simcube settings.

A few basic questions to start:

  1. What settings in the software settings above should I correct?
  2. What should be the correct [FOV] Over voltage fault threshold and [FUV] Under voltage fault threshold numbers to use with my hardware?
  3. Please explain what positions the DIP switches should be in for programing and game play. My board has 2 DIP switches.
  4. Do I have to install MMos firmware and drivers before Simcube firmware and IONI, or just Simcube? (I do not know if MMos FW/Simcube FW and drivers were previously installed). I did install Simcube FW, and drvrs.
  5. Is Device Firmware Mode (DFU) only needed for MMos data transfer?
  6. Do I need a SimpleMotion V2 USB? 

I hope this will be enough questions for now, for me to know that I have a safe base line to start from.
Will then return with more questions when problems arise.

I would like to thank everyone that took the time to read this loquacious post, and you are the backbone that keeps our passion alive.
Thank you all. J

Hello, when looking at the Ioni in Granity, it seems that you are missing the e-stop. It needs a closed circuit on the e-stop to function. Open circuit there will cause it to fail initialisation. See STO active alarm in your last photo.

Other than this, you’re also missing the STM32 bootloader device driver….but anyway, I leave this for Granite Devices guys to resolve for you, as you might have to do a fresh staged FW upgrade for the Simucube, meaning start from fresh. There is some conflicting information between TrueDrive and Granity where device /STO is concerned, as well as initialisation inside Granity on the first tab.

Anyway, enjoy getting it sorted, Joe is a good guy to have help from.


As Beano said it looks like your e-stop is not connected or it is popped out.

NO DO NOT try to install MMOS. You already have Simucube software installed.

I would suggest unplugging the control and removing the cover and take pics of the components inside. That way we now what we are dealing with.
If you have the Acrylic control box maybe you can look real close with a flashlight and see what power supply you have.

Where are you located in the world?

Answers according to your questions.

#1 settings we will deal with later

#2 set FOV to 51
FUV to 30

#3 your dip switches are in the correct position for game play when you took the screenshots of the Simucube software.

#4 No do not install MMOS. You already have Simucube software installed.

#5 DFU mode is used only to upgrade firmware.

#6 you do not need Simple motion V2.

The other dip switch does not do anything, and the other controls whether the Simucube is in the DFU mode for firmware / bootloader installation (it will show as STM32 Bootloader) or whether it runs the firmware installed on the microcontroller (= Simucube is visible as the game controller in Windows).

Simucube firmware does not need any drivers.

Joe is correct. You are missing the Safe Torque Off button (STO) signal as seen in Granity. Can you check that it is installed?

Thank you Beano and Joe for your quick assistance.

I was following your recommendations, and was making some headway, but by that point my brain was about to pour out of all the orifices in my head, and I was getting lost on what I had done up to then, and did I do it correctly.

E-Stop problem was just me not knowing the correct position the E-stop should be in for any particular software.

With your answers in hand, I felt it was best to re-format my hard drive and start from scratch.
To that end, could the forum please suggest where I can find how-to instructions on doing a clean SC and Granity SW/FW install for a SimuCUBE based OSW kit Biss-C with IONI Servo & Stepper Drive.

After days of endless searching, I never could find one that was current enough not to contain info that muddied the waters with things like IONICUBE and MMOS software.

Joe: Here are the photos you requested. I tried to include them in the original post, but hit the pic limit.

Thanx again Beano, Joe, and the others that had a look at my post. J

You seemed to have already done it with your previous install. Just get the latest Simucube firmware package and go from there. No need and no benefit of cleaning out anything on the devices.

Thank you Mika for your quick response.

I started out knowing nothing, but over the past couple of weeks, my knowledge bank is getting built up, so it should be more clearer, and make more sense to me for this install.

Cheers. Jack

1 Like

I am still running into the hang-ups I was having last night.
After fresh windows install, I reinstalled Granity and SC configuration tool (SCct).
I then installed STM32 ST-LINK Utility.
Moved #1 DIP switch to the on (E) position.
Disconnected the mechanical e-stop from board (Yellow and Blue wires)
Turned on SC-HW.
Things looked like this.

I did as mush as i could do from this list.

I then opened SCct but all was grayed out.
Opened Granity and clicked on Connect.
This is what I received back.

When I selected Address 250 in firmware update mode, this popped up.

I then tried to get SCct working so I could select activate the Enable IONI USB Configuration button and i received another flag.


  1. Is there a way to set the board back to factory default?
  2. Do I leave both USB cables in while uploading FW, or only USB port X4?
  3. For FM data transfer do I put both DIPs to (E) DFU, and then for game mode I move switch 1 to the (O) normal position?

This shovel I have is really good at digging deep holes for me to fall in.
Thanks again folks. J

completely unneeded step. ST-link does not work with Simucube at all.

so there is a Simucube firmware communicating with the servo drive, and thus you will not be able to connect via Granity.

You need to use the latest version. This dialog will pop up if you have later version on the device already.

No. Factory default firmware runs some production test features and then puts the device into DFU mode.

It is equivalent to just putting the device into the DFU mode via dip switches.

When using Simucube firmware, you don’t need to worry about Granity at all, you just need to use the X3 port and delete Granity,as you seemed to already have the servo drive working.

Simucube firmware can be updated without touching the dip switches, as the very first step in the firmware installation is to install the custom bootloader, where after you do not need to ever touch the dip switch again.

Have the SW working with no Faults.

Went back to an earlier version of FW. had upgraded to simucube_fw_1.0.40, then to simucube_fw_1.0.40 when things went working and I thought, what the H-E double hockey sticks.

Enable IONI USB Configuration button

Gr 1

SC fault 2

I posted this right away in hopes I save some one from answering my latest post, so I have not proceeded past this point of just having the HW, SW and servo drvrs all happily communicating with each other.
For me and others that find themselves at this step, what do we do next i.e. move Dip #1 to the normal (E) position?
When working with SC connection tool to set up wheel parameters, should the e-stop be in or pulled out, and the D-1 should it be in the normal or DFU mode?

I see some light at the top of my hole. Yeah.
Please keep the sage advice coming.

Power off the system. If it boots up to the Simucube firmware instead of Stm32 Bootloader, then the dip switch is already correct.

Does not matter.

Normal mode. Simucube Configuration Tool only communicates with the Simucube firmware and if you have the dip switch in dfu mode (stm32 Bootloader) then it obviously does not work…

Thank you for that Mika.
But I cant seem to stop digging.
I used Granity to flash the IONI FW just to make sure it was the latest ver {IONIFW-1.7.20}.
After doing that, I am back having the same old ID-1 192002 fault flags.
[FOC] = High [FOV] = 51.00 [FUV] 30.00.
Should I leave [FOC] on Maximum?
Screenshot 2022-01-05 143049

Screenshot 2022-01-05 142952

Till the next group of questions. Thank you so much. Speed Monkey.12396

You need to manually enable the drive from the first tab in Granity. Simucube requires that and does it automatically.

Not required. Simucube firmware updates the IONI firmware automatically to the latest tested version.

See also

Where the 192002 fault is precisily explained.