When i streaming, simucube2 dead


Hi. when i streaming the iracing
the simucube2 ultimate has died.

Please check the attached link video. I was turning the steering wheel to the right, but it was momentarily fixed to the left and then suddenly returned to the right. The car was going left and suddenly the steering came back and my car spun.

I connect simucube directly to the computer.
Use the latest driver and firmware.
Connect electricity to a wall terminal that is not a multi-tap.
It’s a new house that hasn’t been built for a year.

I have no idea what’s causing this, but if you only have this problem when streaming it would help if you give more details about what software and hardware you use for streaming.

Is USB power saving disabled for SC2 in windows device manager?

Or just disable USB selective suspend in Windows advanced power options.

things already done already

my pc
gskill CL14 royal 16*2
asus apex board

use the OBS

I don’t think it has anything to do with the streaming environment.

Hi kos

Could you try swapping to another USB cable that has ferrite cores attached.

You could also try connecting directly to a different USB port on your PC, preferably a USB2 port.

So, does it happen when you’re not streaming as well? If not, I would still suspect it has to do with your streaming environment.

How often did it already happen btw, just once or multiple times?

I’m using a genuine simucube cable. Other cables with ferrite core are also in use (on pedals). Only usb3.0 exists on my main board.

To be honest, what’s the problem in the streaming environment? Then other streamers who use simucube should have this symptom.
It’s been like that about three times so far.

You could try using USB tree viewer software to see what might be happening when you lose the connection.

I’m wondering if the USB 3 controller on your motherboard might not have enough bandwidth/is getting overloaded, especially if you have multiple devices loading that controller.

Again, if the problem only happens when you’re streaming, and it doesn’t happen when you’re not streaming, imo it’s a logical approach to first check your streaming setup. That’s just my analytical approach.
Good luck solving your problem, I hope you get it fixed soon and can enjoy your racing again.

1 Like

I couldn’t test it like that because I didn’t do psych racing when I wasn’t streaming. It didn’t happen often.

I think it’s an expensive main board. I have a lot of connected devices, but I don’t think I’m running out of bandwidth.Can I get the software by Google?

I’m not sure which viewer would be the most recommended by GD but you could try this

first 09/25

second 09/26

third 09/27

After the first problem, check the USB cable, check the power cable, check the power saving, and check the direct connection to the main board.

We’ve checked all the problems, but the same problem has been happening for three days.

Please give me a solution. I’m really angry.

Have you tried swapping to another USB cable completely? I would definitely try that because apart from making sure it didn’t become unplugged, there isn’t really a way to “check”.

I had a similar problem with a piece of audio equipment that randomly disconnected from my PC and fixed it by changing the cable.

I would also try what @Raimond has suggested and try racing without any kind of streaming going on. I know you want to stream while racing but by stopping temporarily you can at least rule that out for sure.

Another thing I would ask, is your cpu/ram overclocked? I have read of cases where this can interfere with USB port reliability.

Just trying to think of things you can try out :slightly_smiling_face:

@kos137 Does your PC case have any USB2 ports plugged into the Apex board?

Hello. Thank you for your help.
Once the cable was replaced, all streaming-related programs were terminated. When I entered the test, the symptoms were more frequent than when I used the genuine cable. I was driving with the truedrive program on, and I saw it coming up when the feedback was gone.Like turning off the simcube. So we’re testing it with a third cable. I don’t think the conclusion is about streaming.

all ports are usb3.0/ usb3.1