True Dive download issues

keep getting this after a prompt was telling me my old shortcut couldn’t be used. So I tried downloading a different firmware but kept getting the message above. Tried the downgrade option which also didn’t work as it kept saying I had not got a certain file. Can not remember which one, forgot to write it down. A few nights ago I did go on a deleting session as my PC didn’t have enough memory space for the recent iRacing update, so maybe I have deleted something I should not have. I’m Really stumped as what to do

You are trying to use an older True Drive version than the one that came with the FW that’s currently on your Simucube.

Go download a few of the later ones and see which one will be the correct one. There will only be one. To old and you will get the message above, but newer ones will anyway ask you to proceed with a FW update, you can do that too…


Thanks Beano, will give that a try

Cheers Mike, that will get you going. You’re simply trying to use an older True Drive version than the FW on the SC, no biggie…

I seem to need more help with this. I have gone through and downloaded every true drive released and still getting the above message?

It is a strange message because I usually drive with older software versions when trying newer firmwares without problems up to 10.2020

You likely got the online profiles beta. You need to downgrade by following the firmware downgrade instructions. Can you show a screenshot about what kind of shortcut you made?

All working now. I just loaded the version 10 beta and all is working fine now