Sudden loss of FFB!

Hello !
I’ve had a problem for a few days now, after a few minutes the FFB disappears and the steering wheel locks on the left. I drive wireless with two Ascher hubs and the problem occurs with both hubs.
I opened the back of the Simucube Sport 2 and tightened the antenna without seeing any other problems and the problem persists!
I bought it from SRB in November 2019. I play rFactor2 and Assetto Corsa Competizione.

Are there any fault codes in True Drive when this happens? Is the device visible in Windows all the time, or is there a tone for USB disconnect/reconnect? What firmware version are you running?

The firmware is the latest, 2021.1
When this happens, the indicator behind the case is green.
Tonight, I just removed the NVIDIA program to save set as default, and since then, no more problems!
Thank you Mika for taking care of me.

Hi mixer, I get usb disconnects on my SC2 Pro very often when racing, usually after some heavy FFB from crash or spins.

I have tried all my ports and not sure what is going on.

What did you mean by saying “I just removed the NVIDIA program to save set as default” … I do not understand what you did, I have Nvidia drivers running my RTX3090 but there is always some Nvidia program running in background. Can you please tell me exactly what you did ?

What SC2 Pro you have, rev1 (2 psu) or Rev2?
Try to attatch firmly all power cables.

By the way, It can be some kind of Safety feature like HandsOff detection

R2 one pwr supply. Cables all fine, not loose. My guess is usb banswidth overload but it keeps happening no matter what port.

My system is Asus X570 mobo Ryzen 9 5900X cpu and new bios is supposed to fix usb issues but it doesnt as my Reverb G2 still has to be on a separate usb card.

Hoping new Granite firmware may fix the problem.

The solution with the Nvidia software was not a solution! I ended up replacing the USB cable between the PC and the Simucube2, and everything is fine now.

Even with the newest Firmware and changing my USB ports around I still get very short disconnects where the FFB stops and steering stops for micro seconds before instantly returning. Like the data is frozen for a split second, it is random and always catches me off guard causing me to lose concentration.

I wonder is it the cable ? I do not have another to test.

Can you give us more information about your PC and hardware connected to it? Which BIOS version are you running on that motherboard?

Thanks - PC specs - Latest Bios

  • Update AMD AM4 AGESA V2 PI
  • Fix USB connectivity issue

Ryzen 9 5900X + Crucial Ballistix 16gb DDR4 3600mhz

I race using HP Reverb G2 and PT Actuator Motion System. So I keep the VR, motion and Simucube on separate USB channels to maximise bandwidth.

The FFB loss is like micro seconds and their now is no actual disconnect / Reconnect of the SC2 Pro wheelbase like there was before. It is just feeling the FFB and Steering goes limp for a second then is instantly working again. But it is enough that is very noticeable and breaks concentration - felt more when during cornering.

Hi Mate, as a suggestion, switch off your motion and retest, let’s go from there. Also, test on a few different USB ports, I am always connecting mine to onboard chipset-based usb2 port.

100% success-rate that way. In years gone by, I have found heaps of issues with Asmedia, and lately, with my Asus /5900x setup. Only thing that worked for me was to use my quad-controller Startech card.

Thanks Beano, yeah I have been methodically testing each usb port. I have one external usb 2 port at the front of my pc which I had not tried yet. I did try with motion off and it still occurred but I will try again.

It must be some sort of usb issue and although the AMD mobo usb issues are supposedly rectified it is possible they have not covered all possible scenarios including this.

I do have a 4 port usb card plugged into a pci slot that is similar to that Startech one but maybe not as good !

I will keep trying … it happened to me once today already while playing pCars2. It happens very quickly and this time was at Road America exiting a corner.

Yeah, I have the bloody expensive Dark Hero Asus board with a 5900x, and I can’t use onboard USB.

Thus using my Startech card for my SC2, Reverb G2 headset, pedals and wheel button-box. No issues that way :wink:

Definitely AMD issue from my extensive testing. I test in parallel on my Intel 7900x system, zero issues with onboard USB on the X299 chipset. AMD X570 though, pretty ordinary…

This is the card I am using, note the quad controllers, hence the price…

There are many cheaper single-controller versions, this however has a controller-per-port, adequate for high bandwidth throughput. But as a first step, start with a good quality new USB cable. Work your way up from there.

1 Like

Thanks for the tips Beano Ol’ Boy :wink: … yeah I just realise my USB 3.0 pice-e Card does not have separate channel of 5gps but the 4 x ports share.

However I am now certain it is the USB connections and lack of bandwidth. So I first took your suggestion and connected my SC2 Pro to the usb 2.0 port on the front of my case.

Next I relocated my Reverb G2 usb connection together with my PT Actuators / Thanos Controller onto the 3.0 pci-e card. They are now the only usb devices on the pci-e usb card.

I did 5 laps of the Nordschleiffe in VR with my FFB and Motion turned up a little higher than normal and had absolutely no loss of FFB whatsoever - that is the longest I have raced since getting my Sc2pro without some sort of FFB disconnect. I did then a few laps of Mugello in a Ferrari and seemed to have a very slight loss of FFB but I am hopeful that was just a glitch.

My supplied usb cable is a good one with ferrites chokes at either end and not like the lower quality cables some mention in another thread. But if problems begin again or persist then I guess next step is to either get a Starcard USB hub like yours or a Trip-Lite usb cable. But for now it seems good.

I do hope AMD sort out the shennanigans with their X570 chipset because otherwise I really love the X570/5900X combo … after having only intel cpu/mobo’s for last 20 something years - Amiga before that … Ha ! LoL :smile:

Oh in case anyone interested in a cheaper solution to your Startech card - below is the 4 port hub I bought. Works perfectly for Reverb G2 and now my motion attached, so I think the 5gps bandwidth probably is enough for just 2 high power devices.

Bugger ! My workaround failed, FFB worked fine for a period today and then with no warning has begun totally diconnecting then reconnecting during races again.

Pretty damn frustrating and must be down to the crappy usb connections on this AMD Asus X570 mobo.

AMD need to sort their shit out :anguished:

Have you tried switching BIOS to PCIe 3.0. Plenty of reports of v4 causing issues on this chipset.

No haven’t tried that … does it affect the gpu at all ? I am running a 3090.

Very little in gaming scenarios.

Thanks Andrew and the gap appears to be extremely slight and probably not even noticeable sim racing in VR.

I am currently testing with just the pci-e slot my usb 3 hub is slotted into set to Gen 3 and have left the pci-e with my Gpu at Gen 4 … or is it advised to have all at Gen 3 ?

Not having much success … I think all the pci-e slots must have to be set to Gen 3 but I am still getting FFB disconnects and also weird video freezes and glitches few times. I never had such issues with my Accuforce so I am wondering now is something else going on?

I am picking up a new usb cable tomorrow. Ferrites and shielded cable that is bit thicker.

Being the sc2 pro is new I would like to know from Mika or someone at Granite, is there any other fault finding process I can follow as I am surely not the first or only customer having such problems.

It is really frustrating at this stage as I would love to just race and enjoy the wheel. Plus I do not know, is it a possible fault in the wheelbase ? Unlikely I guess but it needs to be ruled out somehow.