Sporadically loss of FFB in iRacing

Hey there,
inthe last days I had several moments in which the FFB was gone for a moment and after a short while (up to 1 second) it came back.

One of my friends gave me the hint, that this might be an issue with the power supplies.
Can anyone confirm this and how can I solve it.

It is a SC2 Pro.

Best regards

Is it the single or dual power block version?

Are you sure it’s not just the hands-off detection kicking in?

The SC 2 Pro has 2 PSUs

From my understanding the hands-off detection should kick in if I have the hands off the wheel.
So during a race it should not kick in…or where is my fault in thinking ?


Does you profile reset? Is your steering still registering when you have that no FFB situation?

Your understanding is correct. How3ver the hands-off detection can sometimes falsely think you took your hands off the wheel when it’s not the case, especially in situations with quick change of force direction, and when the hands-off detection setting is at a higher level in true drive. Try setting it to either low or off in true drive.

Yes I have been having exactly the same. No ffb or steering for a second or two. Sometimes wrecking the car. (Brand new r1 pro) Any suggestions?

Not just In Iracing though. Also happened in AC

Does disabling hands off detection help?

Hand off detection doesn’t change it for me.

I have also had a full permanent freezes in game that you can only get back when you turn the base off and back on. Reading on here I found that can be caused by another usb device disconnecting. im now going through trying every usb device i have (which is allot) to see if I can find the cause. Still at the early stages though - any suggestions welcome if others have found a solution for them.

The hands-off detection was set to LOW

What do you mean reset?
As mentioned the FFB was gone and came back and after that everything was fine again.

In that situation it felt like driving on ice and as if the steering input was not recognized any more.

What I can try is to reproduce the problem and then look on the replay whether the steering angle changes. But it is quite sporadically (but nevertheless a problem as I crashed several times due to this).

Any hints?
Any settings that I can change in the TD ?


ok I still cant fix this issue.

I drive in iracing for 10 mins and 1 will get a 1 second freeze in steering often sending me into the wall. no usb disconnect sound or anything.
fresh install on windows did not solve anything… Most of my rig is on a powered usb hub. Tried a different hub, no change, ran the simucube base from multiple usb ports on hub and directly from pc, no change.

Hand off detection disabled. Using Truedrive 2020.10

Ok further investigation where I have every single usb device in my pc unplugged apart from the simucube 2 and heusinkveld pedals. Still having freezes.

I change out the nice usb cable that came with the simucube to a generic usb cable with no ferrit magnets and its happens WAY more… usually before I can even leave the pits. I get full usb disconnect cycles, regardless of if I run from powered usb hub or direct from pc usb.

So its obviously a usb issue of some sorts, but only affecting the Simucube 2

What would cause this? I have my rig fully grounded, so that shouldnt be an issue.

sorry… more information troubleshooting this…

so, I keep the bad cable in play for troubleshooting as it faults out much quicker than the higher quality cable which can take a couple of laps before a minor glitch. The cheap cable will minor glitch constantly and full disconnect eventually.

Im thinking power/earth issues so I test the socket powering my entire pc and rig and all is fine. I try running everything from an alternative socket in the house but no difference. I move everything onto one power strip with shared earth, still freezes.

Then I connect a cheapo in line usb isolator I have to the cheap usb cable and manage to complete several laps without any issue whatsoever, totally impossible before. So 100% its a usb power/noise issue of some kind. the isolator works, but is probably just masking the real issue. what would you suggest to fix this properly?

pc specs - Asus Crosshair VIII X570, AMD 3900X, 2080ti, Corsair HX1000i PSU

The isolator that suddenly fixes the problem: https://www.amazon.com/HiLetgo-ADUM3160-Voltage-Isolator-Support/dp/B07235PR4V/ref=sr_1_2_sspa?dchild=1&keywords=usb+isolator&qid=1605041207&sr=8-2-spons&psc=1&spLa=ZW5jcnlwdGVkUXVhbGlmaWVyPUExNFRVREYxNE8yUzZIJmVuY3J5cHRlZElkPUEwMjI4OTM0MUVBNkI0UTlQMEk4TSZlbmNyeXB0ZWRBZElkPUEwMjY5NzY5MzM5RTRXUURMNE1NTiZ3aWRnZXROYW1lPXNwX2F0ZiZhY3Rpb249Y2xpY2tSZWRpcmVjdCZkb05vdExvZ0NsaWNrPXRydWU=

Thanks gor hijacking my thread :wink:
Well after it is an USB issue it is not exactly the same issue as I have.
So we should try to separate these two things.

So back to my topic:
Any hints what can cause the sporadically loss of FFB that recovers after a short time without a powercycle (like at Gifteds SC)…


Apologies Sven,

to confirm though it sounds very much the same issue… mine does not require a power cycle either… its nearly always a split second loss of ffb and steering that comes back almost immediately, but if your cornering or something at the time it can be enough to crash the car. With the stock quality cable this might only happen once in a couple of hours play - other times more often.
I have artificially made the issue worse for troubleshooting by using a cheaper unshielded usb cable, that can even cause a full usb disconnect/reconnect - perhaps you can try the same.

Now with a usb isolator fitted to the cable it appears to have fixed the issue completely. This would indicate a ground loop issue over usb. I have hunted for the route cause on my rig but not yet found it. The usb isolator might end up being the permanent fix

I thought you had to do a power cycle.
Now i am confused.


No I was incorrect.

99% of the time I get a split 1 second disconnect in ffb and steering. a couple of times and very occasionally I might get a longer disconnect, that will also eventually just reconnect on its own, true drive will show the wheel disconnected and reconnect as if you have just turned it on. (you don’t actually need to power cycle) - I can induce this more frequently with a ship basic usb 2.0 cable without ferrite cores on it like the stock cable.

going through the forums I have found half a dozen people over time that have reported similar issues, but no cut and dry resolution. So far the usb isolator seems to quickest fix and works even with the cheapo usb cable. Im going to run that for a week to confirm (ordered a couple more to test also)

So the question from me:
I understood yout posts so, that you always have USB disconnects right ?
Or is this also a misunderstanding?

I can see no USB disconnects…there is no USB disconnect/connect sounds in my case.
So still there might be 2 different problems?


Yes I also dont hear any usb disconnect sounds when its a momentary freeze. but 100% I have narrowed it down as a usb issue at this point from all my testing.

I have a huge amount of stuff in my sim racing room, it could be anything causing a ground loop on the usb ports but im pretty confident its a ground loop issue

Any hints for my issue from official side ?