SimuCube V1 Issues

I need help trying to fix my Simucube V1, The Ioni is blinking and its SSSL and the error code Is “Other/unknown, possibly configuration error such as motor mode Motor typeMT not selected”. I don’t know what to do to try fixing this error. SimuCube is being shown when I go to “Control Panel\Hardware and Sound\Devices and Printers” but when trying to connect it using the Granite Devices “connection tap” it wouldn’t connect. and whenever I try using the Simucube Configuration tool it wants to update and then gives me this error message " Error: Simucube did not boot in Firmware Upgrade Mode in 30 seconds…Power cycling the Simucube and trying the update again can also be successful as Windows will already know the device on the 2nd try."

I have tried unplugging both ends of the cable (from the cube and the motor itself) and whenever I disconnect the Motor & E-stop connector the wheel becomes able to be turned freely with any issues, But once plugging that in it goes back to a “clungy” / FFB is kinda stuck. I did turn off the Simucube and removed the IONI chip and turned the wheel back on and then the wheel becomes free but once installing that chip back into the cube that wheel goes back to being that “clungy” kind of feeling. i have many times tried resetting the power and switching it from on and off as well as changing the USB ports to a different port on the computer.

Also, Whenever I unplug that Motor & E-stop connector cable from the Simcube the blinking orange continues even though the motor and e stop cable is not connected. also even with all the cables being disconnected (the 2 USBs, Motor & E-stop connector, & the Motor position sensor connector) the blinking light continues blinking even after a reset

I have the latest Granity software which I have is 1.15.3 and I have Simcube_fw_1.0.40. Granity opens but when I try to “connect” it keeps giving me “Unknown devices type:#### at bus ## in unknown mode” or its Unknown devices type:#### at bus ## in firmware upgrade mode"

The wheel also phasing when it would do that beep/tone, but since this issue, it does not phase and or do that beep/tone at the end.

The wheel was working fine and I noticed in the FFB that it became kinda “clunky” when I looked into the cube I noticed that the IONI was blinking and what I stated up above is what I’m getting.

If anyone can help that would be awesome.

Did this happen when you tried upgrading firmware?

It sounds like the flash memory containing the servo drive settings has somehow corrupted itself on IONI, and reinstalling the settings will fix the issue. This is very, very uncommon but not the first time we have heard of this happening.

Connect to the servo drive via Granity and put a working DRC settings there. Remember that you will need to click “Enable IONI USB Configuration mode” in Simucube Configuration Tool before you can connect via Granity. Otherwise you will certainly get the “Unknown devices type in unknown mode” errors in Granity.

Alternatively you can upload the settings again via the Motor Configuration Wizard in Simucube Configuration Tool.

Unfortunately simucube is saying that it has to do an update and whenever an update is attempting to be made it closes itself out giving me an error code that reads “Error: Simucube did not boot in Firmware Upgrade Mode in 30 seconds…Power cycling the Simucube and trying the update again can also be successful as Windows will already know the device on the 2nd try.” The whole Simucube configuration tool is not working either cause of the update cycle.

Try with each Simucube firmware release older than the one you have now until you find one that does not ask to update.

It seems the servo drive initialization has a bug (in the release you have) that does not abort the initialization attempt and thus will not go to update mode either.

I have the latest one which is 1.0.40 and it says in the lines of “Simucube needs to updates cause your version is TOO OLD”. I’m not at my pc right now to word it correctly but it says the software is to old

If it’s okay with you, I’m fine with doing a team viewer session or something an let you look an see an try anything.

Yes, and that old version in the device is hung up on trying to initialize the servo drive, which it can’t due to it having some corrupt settings.

You should really do as I said here:

I would need to know which firmware version you were running previously as the latest one asks you to update.

Ive just downloaded an ran all the versions of Simucube from the latest version of 1.0.40 / 1.0.39 down to 0.11.1 / 0.11.1. they all are giving me the same error that its needs to update to a newer version

Also wanna to note that has no updates for windows either

Inside my device manager, this is what it’s showing, also in “device and printer” it’s also being seen. I have uninstalled all the drivers and restarted the simucube and the IONI is still blinking the same pattern (SSSL) and all the Simucube Configuration Tools are still saying that same thing as above.


No this didn’t happen when trying to update. It just happened randomly. I was using the wheel earlier in the day without a issue an than I went to work. When I came back home it started having this issue.

I want to provide an update,

I have been able to get the INOI to be found when I switch the switches on the motherboard. I downloaded that latest IONIFW 1.7.21 and thankfully now Granity sees the IONI and I can now I have the ability to go into the “testing” tab and see what the results are. When on the Testing page I keep getting this error

When it comes to the Simucube issue I still haven’t been able to load it into the app with the motherboard switches turned on the position that I have to use to get into Granity to try to get the software to work.

Also want to add that the LED on the IONI is still doing that blinking orange and SSSL

Show all settings from all tabs in Granity. The blink sequence is likely meaning that you do not have any valid settings there now…

This is also the advanced setting page also

Some funny settings there.

Put MMC to e.g. 10 A and MCC to 7 A.

Put OverCurrent Tolerance to Maximum.

Then, can you check if the STO signal is stable? Fault location 140407 indicates that the e-stop cable might have unsteady signal.

this is this chart that i keep getting when the button is released

When the button is pressed in

this is when I’m turning the wheel itself

i also checked the cable itself (i don’t own a voltage meter through) but the cables and connections on both ends going into the box of the button and the end that goes into the green housing into the Simucube both look fine.

I am going to redo all the ends, sadly I don’t have those size wire clamps but I can soldering

redid the ends going into the Simucube, Still getting the same results as post above