Simucube setup help needed

hi i am really stuck i have just bought a new pc with windows 7 and i cannot seem to install my osw(big midge simucube).it worked fine on my old machine although ollie talked me through the install proceedure.when connecting through usb it installed the drivers but doesnt show up in device i need both usb cables plugged in.i have been following the guide but dfuse demo wont show any stm devices in dfu mode.i am really confused and not that good with this sort of thing sorry.

Both cables do not need to be connected. Are you building a new system or attempting to just install a previously working system to a new computer?

Just the X3 is needed, if you already have a firmware on the SimuCUBE.

hi thanks Mika i am trying to install a previously working system to new doesnt seem to recognise the usb in devise manager.will it still have the firmware installed as i upgraded to 0.8 which worked great on my old pc.

Yes, the firmware is stored on the device.

Do you have the correct USB connected? Which motherboard do you have?

i have tried both usb’s but no luck.i have up updated all usb divers on my mother board which is a asus v extreme x99.
do you think upgrading to windows 10 might help?.

1 Like

Update motherboard drivers. Asus X99 is famous of its USB issues, which are not limited to SimuCUBE.

I know users have fixed the issue by purchasing a PCI-Express USB addon card.

What does install an existing system to a new pc mean - you put your old harddrive with a running Win7 into a new PC with different hardware? If yes, that is usually not working, as you have incorrect hardware drivers in your Windows System - sometimes you can switch back to legacy drivers before (!) removing the drive from the old PC, but usually you need to do an install from scratch.

thanks Mika im getting somwhere now.just installed my Inateck Superspeed 4 Ports PCI-E to USB 3.0 Expansion Card and now simucube is showing up in devices and printers.however i still cant install the new firmware as it doesnt show up as STM devive in DFU mode in device manager under either universal serial bus controllers or other devices.
i hope you can help i’m really missing the osw.

Is there a device with yellow exclamation mark? Update its driver, like I did in this video:

i wish there was.i already watched your video earlier.very informative.
there is nothing in the device manager.really stuck for ideas now.

also dont understand how all my other peripherals connect and work through usb.
they also download new drivers when needed…i’m downloading windows 10 now to see if thats any better.

Does it show in Devices as MMOS Force Feedback or as SimuCUBE?

shows as simucube.
i must be doing somthing wrong because just plugged it into my laptop and it still doesnt show in device manager

If it shows up as SImuCUBE, it should also show up in Game Controllers and be usable there?
Does the SimuCUBE Configuration Tool show Disconnected or what?

yes it is in game controllers as would i install the simucbe configuration tool though.i downloaded mmos but that is in red DFU mode.

sorry im getting confused here.i cant install the simucube config tool because when i open DFUse Demo it is blank like yours was in the video.however i dont have/see any STM Device’s in devise manager so cant update the drivers.i only get simucube in game controllers.

You don’t need to install anything with Dfusedemo, you have already done that step previously.

Do you found solution? i have same problem… and now i cant see STM anymore, i have simucube but i cant instal softwear, *Error: motor did not initialize in 30 seconds. Propably cause for this: Wrong settings for the motor.)