SimuCUBE Open Source Firmware Public Beta release thread


#21

Is there any user guide which describe each function of new configure tool ?


#22

It is linked right on top of the page that is linked on the first post:

https://granitedevices.com/wiki/SimuCUBE_Firmware_User_Guide


#24

Guys, here are AKM53K files for both BiSS and SinCos encoders, which you can adapt for your AKM servos - you will need to change at leasr RPM, MMC and MCC, as well as bits for BiSS and interpolation for SinCOS: https://www.dropbox.com/s/f9jcan2z1ia54zc/SimuCUBE_AKM_BiSS_SinCOS14JULY2017.zip?dl=0


#25

I seem to notice a trend iracing crashes during launch. sometimes i need to launch in 3 or 4 times before the game works. it only happens when i got the SimuCUBE running. it never happened with mmos. but since i run the simucube firmware. when i finally get ingame its stable.

the error is a The instruction at XXXXXXXXXXXXXXX referenced memory at XXXXXXXXXX the memory could not be read


#26

There have now been two reports of the SimuCUBE seeminly causing that. Thanks for reporting.


#27

i also have been running Asetto Corsa for hours on multiple days, didn’t have any problems there.


#28

I do have the same error BUT only in iRacing IF I used another sim like Assetto Corsa or pCars2 before! A restart of the PC fixes it and it never happens if I just start playing iRacing from the get go.


#29

Hello SKeijmel, something similar happens to me, also with AMS, iracing, ac, and rf2, but when I’m back to Mmos it has stopped happening …


#30

OK, thanks for reporting.

I’ll put this thing on my list to investigate, but as it seems to not always happen, the reason for it could be hard to find. I will focus on some other things first.


#31

I have the same kind of crash. In the closed beta and now also in the public beta. I’m back to MMOS until there are attempts to fix the issue.


#32

So you consider the issue to be a showstopper at this point?


#33

iRacing creates a log file of a crash in the root of your Documents/iracing folder. I am not an expert but maybe it gives a hint


#34

I’ve seen some iracing crash logs, mainly graphics crash related, and there is just a short software trace log. It cannot be really used unless you have access to iRacing’s source code…


#35

So you consider the issue to be a showstopper at this point?

Yea for me it is unfortunately, it keeps crashing right away. Not only iRacing but also Assetto Corsa crashes straight back to the menu.

(Simucube, IONI Pro HC, NDR-480, Small Mige)


#36

So, we have identified that

  1. iRacing will crash sometimes.
  2. It is more likely to crash if another sim has been started and closed before it.
  3. No crash will happen after a reboot.

Can we also deduce this:
4) Another game will crash, if iRacing has been started before it

We might be onto something here…


#37

Is it really only me here who dont get any force feedback in PC2 ? Would be kinda nice to see if its just me or anyone else.


#38

I am sure you can, because one of my friend is testing Pcar2 with this FW already.


#40

Am posting this on behalf of @Berniyh post copied from ac forums.

"I suspected that it might be the FW, because I have ETS2 crashing when you try to modify the FFB settings as well.
(Apart from the fact that FFB in that one doesn’t work at all.)

At least if others confirm that they see this too in AC, then we do know that the FW is the origin.

I’ve only seen crashes when I try to modify the FFB stuff or if I select the Simucube as a used device, but if that is already assigned, then it works as far as I can tell."


#41

Also from @Berniyh
" Have any of you seen AC crashing with the new firmware? (vanilla content)
Since I’ve flashed the FW on Sunday, I have random crashes when starting a session (2-3 s after loading, engine sound doesn’t even come up).
The only other thing that I changed is that I wiped and remapped all of ACs controls.

Previously with 1.15.1 and MMos, I didn’t see crashes."


#42

@pavano reply to the above so it’s not a isolated case me myself I’ve had no crashes apart from RF2 and PC2 but rF2 has always been unstable for me and PC2 don’t count because it’s not out of BETA yet :slight_smile:

“hm, now that you say it…
I had random crashes quite often, at session start, as you describe it (no sound, sometimes only the picture starts to fade in). I always thought it to be my flakey system. However, I haven’t used the latest fw, only .70, because last time I could use my rig was about 10 days ago.”