SimuCUBE Open Source Firmware: Beta version 0.6.x bug reports

Report bugs here.

There shouldn’t be any new bugs, but some things might have been fixed along the way. If you feel that a previous bug has not been fixed in this release, please re-report it.

hm, don’t know if I did something wrong, but Ioni fw won’t update…

after the the fw update of the simucube the application did freeze.

Try turning SimuCUBE off and then on again. If it still doesn’t connect, chances are that Ioni firmware update has gotten interrupted. Try to connect with Granity (remember to use the Enable Ioni USB configuration -button). If Granity suggests to update firmware there, you can upload 10060 version manually.

It shouldn’t freeze, it should just quit. I will investigate this, as it properly just quits on my machine.

first I had a screen shot of the freeze but I accidentally deleted it.
Had already done the on/off several times
once, under simucube firmware was something like 132.23

Tried it with granity, and now it works!
Thanks so much!

Please elaborate - did you have to manually flash Ioni firmware, or did granity connection just fix it some other way?

sorry for being so short
I connected to granity, and then the wheel did the phasing, which it hadn’t done before.
I quit granity, went to the config tool, and the config wizard came up.

EDIT: when driving everything feels exactly the same IMO

Everything updated well for me. Will test a couple laps and report back later. :slight_smile:


1 Like

This is very much expected, as no changes were made there :slight_smile:

Next, buttons, profile management, more games, and more filtering stuff.

1 Like

when going through the wizard, there is a tab where it says “updating the firmware”. when you are on this tab there are dot-dot-dot periods are going across the screen, but the NEXT button is enabled and looks like it’s waiting to be pressed.
it should probably be disabled until the update is finished, so users don’t click it by accident

the configuration tool crashed after going through the firmware update wizard and pressing the FINISH button

---------- from event log ----------
Faulting application name: SimuCUBE Configuration Tool.exe, version:, time stamp: 0x598f26ba
Faulting module name: SimuCUBE Configuration Tool.exe, version:, time stamp: 0x598f26ba
Exception code: 0xc0000005
Fault offset: 0x0000aaaf
Faulting process id: 0x2494
Faulting application start time: 0x01d3139ef7d3195e
Faulting application path: C:\Users\velez\Downloads\simucube_fw_beta_060b\SimuCUBE Configuration Tool.exe
Faulting module path: C:\Users\velez\Downloads\simucube_fw_beta_060b\SimuCUBE Configuration Tool.exe
Report Id: 0c2ea882-b113-4c3e-889a-bb0b3bd55ae1
Faulting package full name:
Faulting package-relative application ID:

I tried to make it so that the next button disappears, but it its quite difficult to accomplish in Qt. I wanted to release the thing sooner than later, and fix that Next button later. In fact, I already know how to do it…

The crash is something that doesn’t happen on my computer, so I will have to investigate further.

Aaaaand… this Next -button thing is now fixed, it will be in for the next release.

1 Like

the “upgrade firmware” button is always enabled and i can install the firmware upgrade over and over.
is this by design?

Yes. I might improve the wizard in the future, to note that user has the current version already installed.

I also wanted users to test the upgrade process in this beta. On different computers, etc.

I installed the firmware with out issue tho i did have to cycle the power of the simucube to allow initialisation after it uploaded the firmware. Maybe a simple note on the page to let people know to cycle power to the simucube on that last page.

Yep, had the same like @Troyau. Update went up to 100% and than nothing happend.
I closed the “Configuration Tool” and re-opend it, still showed update 100%.
Powered the Simucube “off” and “on” and than it showed “Operational”

This must be the Ioni firmware update. I must try to catch it hanging like that some day. I didn’t want to put “power cycle” instruction in the SimuCUBE firmware update wizard, because power cycling when the (quite fast) Ioni firmware update is in progress will corrupt the Ioni firmware, and then it must be recovered with Granity & manual Ioni firmware update.

when going through the firmware update wizard, there is the tab where it does the transfer and the live byte counts are counting up.

is it expected that there will be a ‘pause’ of 5-10 seconds occasionally, where the byte count just stops, then starts again after many seconds?

This is not expected. It would indicate something maybe freezing up in the windows usb stack, causing access to it to hang.

However, even if the hanging happens, the bootloader will not write correct checksum for the code unless the written data matches the checksum that the configuration tool gives after upload. And if the correct checksum is not written to Flash, the bootloader will not try to boot up the corrupt firmware, as it also checks against the saved checksum before booting. So, good report, but we are safe and robust…

Please tell me your operating system, motherboard and the drivers you have installed?