Simucube not recognized by Windows 10


I purchased a Simucube 1 from SimRacing Bay recently. When setting it up I cant get it to connect to the PC (Running Windows 10). When I turn on the box I get a Windows warning saying that the USB is not recognized and that the device has malfunctioned. Any ideas?

Also, the device itself is showing 1 green LED and one red flashing LED.

Help would be appreciated

try to change usb port

That, or a new/better USB cable…

Simucibe 1 has two USB connnectors. Have you connected both or just one?
If only one, then maybe the wrong one.

I had some USB low voltage problem when I installed my old SC1 when both USB was plugged in.

Both cables are new. We have tested and the cables don’t seem to be the issue.

At this time we have only tried to make it work having both cables connected. We assumed that both needed to be connected to work.

Here’s what we’ve tried so far:

Installed unit as directed (FAIL)
rebooted computer and Simucube (FAIL)
Switched USB ports to use other ports (Currently porting directly to motherboard) FAIL
Swapped USB cables for others (FAIL)
scanned for hardware changes in Device Manager (Simucube doesn’t show up) FAIL

We haven’t tried to only use one USB. That said, why is their two of them if you only need one to operate?

Again, this is a brand new pre-assembled unit from SimRacing Bay and it’s very frustrating to not be able to use it. I’m looking to the community for urgent help here.

Thanks in advance,


Hi Keith,

If you have option, try some other computer or laptop to connect Simucube system on.

1 Like

The other USB port is for configuration of the servo controller.

Thank you Dennis. Do you know which USB is for configuration or are you suggesting trial and error?

X3 inboard mini-USB = USB HID (gaming port)
X4 our board mini-USB = USB IONI (drive-controller )configuration port

Refer to the wiki =

Hi Tomo. We tried a 2nd computer and that didn’t work either.

So far I’ve tried swapping USB’s for new ones and that didn’t work. Tried one connection at a time and that didn’t work. Tried on another computer and that didn’t work. I think I’ve got a dead box here. Any thoughts?

Ok, lets try to determine more precisely. I just checked orders database, last order for Simucube 1 was 6 months ago (mid May). Did you use it during this period or this is actually first time?

Yes that was when I purchased it. This was my first time hooking it up as I didn’t have the simulator finished until now.

So this is what I’ve tried:

  1. Opened the SimCUBE box, flipped the dipswitch to DFU mode. Plugged the box in the computer with both USBs and powered it on. I got the Device in DFU Mode in Device Manager, but I had to unplug the closest USB to the fan or my computer with BSOD (STTub30.sys) (faulty USB).
  2. Downloaded the .hex file from the German website.
  3. ran Dfu File Manager and created the .dfu file.
  4. Opened DfuSe Demo (v3.0.6) and it found the device in DFU mode. Clicked on “Choose…”, selected the .dfu file we created in step 3, click on “Verify after download” and clicked on “Upgrade”
  5. Had the pop up box, click on Yes or Continue.
  6. Firmware upgrade completed successfully.
  7. Turned off the SimCUBE.
  8. Flipped the DipSwitch back to regular mode (ON)
  9. Started the SimCUBE. (Windows gave Error 43, USB Device not recognized (Device Descriptor Request Failed)).
  10. Tears
    I was expecting to see that Windows detects an MMOS device as the wiki says.

Thoughts? We are willing to get on a phone call if anyone wants to help.

All good. I will send you email in few minutes, i think i have the right details (Order #6205)

yes that is me. Thanks for your help

Tomo will help you on this. If this is a recent order, then it is likely that it has an encoder which is not supported by MMOS. But good news is that if you got the DfuSeDemo working and managed to flash something with it, then at least the hardware should be fine.

1 Like