Simucube Ioni Pro first power on


I have connected both usb Simucube my Windows 10 PC
Dip switches are both ON
The DC supply is 48.3V
LED3 on Simucube MB is on
The Green LED on Ioni flashes twice quickly then pauses
The Orange LED flashes one long and three short flashes
Windows 10 recognizes the MB as Simplemotion serial on Com 7
When I click Connect it is successful for a few seconds then disconnects with the error shown

Any advice appreciated

I don’t have a wire between the GND on the power supply and the ground on the Simucube. I have only connected 48V from COM/+V

Is a wire required? Could this Gnd reference be the cause of the error?


GND is required. Please follow the instructions provided here carefully:

Kind regards,

Thank you. I have now connected the GND wire but it hasn’t made any difference.

Is it a boot loader issue? I haven’t uploaded that yet.

The bootloader appears for while in Devices then disappears (it disappears after I click connect)

This morning I disconnected everything and visually checked the boards. No problems found. I connected the 48V and this time I removed the USB extension cable and used the very short mini USB cable on its own. It is now working. At this stage I suspect it is the extension cable. At the moment the motor and emergency stop are disconnected.

Granity under the Connect tab shows the Ioni drive properties. However, there is a caution at the bottom of the window “Drive needs to be restarted…” I clicked on the restart button, the drive disconnects and reconnects OK but the caution returns. The LEDs on the Ioni drive are still flashing that it has a communication error LSSS.

I have tried the Simucube Configuration Tool inside the latest firmware release but everything is greyed out - it’s not seeing the drive.

Can someone point me in the right direction of what to do next please?

Thank you

Install latest IONI firmware using Granity, then install Simucube bootloader dfu file using DfuSeDemo. Use Simucube firmware package 0.11.2 to set up the system.

Thank you Mika, I will give it shot.

I’m stuck again. I successfully updated the Ioni firmware from Granity but now I am getting “Unknown USB device…” for Simucube.The known good USB cable is plugged into the Granity USB port. I have tried to update the driver but Windows says the current version is the best one. This is really tough going.


The SimpleMotion serial port is still working when I run Granity but the device list is empty because Windows has stopped the driver

Plug the good USB cable into the inboard/HID port, see if windows recognise the Simucube. Outboard port is for Ioni/Granity, inboard port is for Simucube/HID.

It’s difficult to support you if you have known USB cable issues. You should also go through the Simucube Wiki, following the basic steps there with good USB cables, will get you there by 99%


Thank you. Yes I agree. I have disconnected all other USB devices except my mouse/keyboard.I removed the Ioni drive. I rebooted. Three cables now do the same thing when plugged into the Granity USB port as shown in this screen shot. Now granted all three cables may well be defective but they are consistent. At least the driver isn’t being stopped by Windows but is the situation any better?

Progress. After removing the ioni drive and rebooting I can now see the STM driver and Windows is not showing any error with it. I started the Defuse demo and it automatically selected the STM driver however it is flashing on/off every second. Two steps forward…

The flashing continues in Defuse but at least the device is not grey and flashing in Devices and Printers now since I moved the USB cable to an onboard motherboard USB port. I have removed my mouse/keyboard and an internal 4 port USB hub but the flashing persists. Its like Simucube is rebooting every second. The power supply voltage is stable and has no noise on the line and the green LED on Simucube is steady. If I switch the cable to the HID USB port I can connect with Granity and establish a connection with the Ioni drive.

Can you post the name and model number of your motherboard, please? Just would like to see what USB chipsets are in use, and where you have your Simucube connected.

Some 3rd-party chipsets, as I have discovered 3 or 4 years ago, doesn’t play very nice with DD wheels in general…

Your case certainly seems to be one of those, devices shouldn’t drop in and out, it should be stable :wink:

If you can, have a look at your motherboard manual and connect the Simucube to the chipset-native USB 2 ports, not 3rd-party VIA or Asmedia…

Apologies for the delay - it was Australia Day yesterday. I have tried every port on my MSI x99A Gaming 7 motherboard. Only the MB chipset USB 3.1 ports show a stable connection in Device Manager with the correct name in Devices and Printers. However, Defuse still flashes between a successful read of Simucube info and no connection – every second. I tried different cables and all the USB port combinations. No other USB devices are attached. I have removed the Ioni drive card. I haven’t had any problems with other USB devices in the past. Thank you for trying to help

I put the 4 port PCI USB card back in and plugged Simucube into one of the USB 3.0 ports. Devices and Printers is showing a stable FT230X Basic UART. Granity can see the port but because it isn’t being reported as an STM bootloader, Defuse can’t see it.

Both cables plugged in again, or, which one? X3 or X4?

Yeah sorry, in my excitement I plugged it into the Granity port. Back in the HID port now. No change. The only port giving anything close to working is a USB 3.1 port shows a stable connection in Device Manager with the correct name in Devices and Printers. However, Defuse still flashes between a successful read of Simucube info and no connection – every second.

Really stumped

You have the servo disconnected, yes?

It should be ok to leave Ioni in, but servo cables unplugged, just to rule out EMI.