Simucube Firmware update wizard missing "Cancel" and "Next" buttons! First time setup


To verify If I have done everything right:

I followed IONI drive configuration guide. I have a big Mige so I downloaded Mige 130ST-M15015 5000ppr configuration file. I loaded this file and saved it to the memory, restarted device. Then I changed the CRI to PWM, FBR to 4.2 mil because I have the Biss-C and MPP to 1000. Upload,save,restart.


  • initialization is succesful

  • I increment setpoint by 500 as instructed. The first setpoint already makes the motor move, then at 1000 and 1500 again. But after this, there is no more movement.

  • Changed MCC and MMC to 5.5, 6, 7 to test, all of them have similar results, but with bigger numbers than 5 I get smaller/fewer rotations. I also tried with inverted FBI, which also gives me some rotation at specific values.

I was not sure if this is a successful test or not, but there were no errors, so I finalized with leaving MCC and MMC at 5.5 for now.

I installed the software, then followed the steps. Everything was successful.


After I open Simucube configuration tool, the Firmware update wizard comes up, but there is no buttons and I can not do anything.


The 0.54 version seems to have this issue for new installations. Please install 0.11.2 instead. The bootloader, which you already have installed, is compatible and will not have to be installed again.

We are trying to find the time to fix this issue for 0.54x versions for SC1.

1 Like

Thanks !

What values are the correct one for MCC and MMC for the large mige? I dont have the spec sheet and I havent been able to find it online.

Do you perhaps have a configuration for the large mige with Biss C ?

Is this a full-up DIY build? I will get you the file, but the PSU is rather important to know.

Here is the file:

Please note, that you will have to change the MPP parameter (maximum power) if you have only 480W PSU.

So I encountered 2 new issues. Wheel movement is not picking up in SimuCube Configuration tool. First I tried 0.11, then I tried 0.54. No luck. In both cases I initialized successfully.
Then I tried to connect in Granity software to apply the settings you sent me and check the encoder readings. However, I can not connect anymore. The software is stuck in “opening bus” state. I tried restarting everything, but no luck.

Yes, its a fully DIY build. I have a 1000W PSU . spec tag attached.

you must click the “Enable IONI USB Connection” in Simucube software in order to get the Granity connection working.

In Granity, you can observe the Position Feedback value on testing tab to verify encoder operation.

I completely forgot about that step !

Thank You, after submitting your settings and re-initializing in simucube things seem to be working properly !

I will now try the wheel with some games.

1 Like

Hi Mika,

I too have this issue, however I have lost it from device manager and it wont show up in DfuSE demo software list anymore to load a new file. When I check the device in Bluetooth and other devices it says SimuCube in firmware upgrade mode.

I cant get it to show up anywhere in order to reload the file you suggested.


Can you help please?

This is a known issue. Continue installation by using 0.11.2 zip package.


Thanks I downloaded previous version and it seemed to update firmware but now I have a red error ‘Driver firmware update error. Turn system off and on again’.

I have done this several times and also turned PC and wheel off and restarted, same result.


Thanks in advance

Update IONI firmware via Granity.


Im sorry but im just going in circles. I cant use granity as my communication interface does not show up in drop down list to update.

Also now in simucube config tool it shows ‘disconnected’ again and I cant get a responce. I have tried to reload the Bootloader file throudh Dfusdemo but I get the same result.

edit - i manually switched the DFU swith back to run and it detected the wheel but now says ‘couldnt connect to IONI , reconnecting’. edit - When I press Disable Ioni USB congi it says ‘Ioni Granity Congiuration Mode. Games will not work’ but I still cany do anything in Granity.

Also windows now shows an error in device manager and now states ‘unknown USB device’ - Itried to update the driver but it wont update and wondows says its the best for it.

The device shows up in game controllers although it has no responce as SimuCube

do you have both usb connected to your pc ?

1 Like

Hi yes it’s connected to the inside port of the available 2. I did just see the diagram that says the other one is for USB configuration though. None of the user guides say anything about which one to use.

Any suggestions?

Well, you need the outside one for connecting via Granity. See here ->

Check the Wiki for all relevant info, everything is there;)

1 Like

Just plug in 2 USB Cables (x3 and x4) for the complete setup routine. Afterwards when everything is running fine only the cable to x3 is needed.

1 Like