SimuCUBE Firmware issues and debugging

Lets start debugging the various issues that have cropped up here.

Currently known issues, without a good resolution, are

  1. Incompatibility with some Asus X99-chipset motherboards due to 3rd-party USB chipset used on the motherboard instead of the USB hub inside the processor, or poor electrical design of the motherboard. SimuCUBE is by far not the only device to have problem with these motherboards.

  2. Non-booting computers when SimuCUBE is on. This must have something to do with motherboard BIOS trying to parse human interface device descriptor correctly. We know, that there is one little issue in the report descriptor, but it shouldn’t affect a sensible device descriptor parser.

  3. SimuCUBE seems to be disconnecting totally at various times of usage. Please make sure that in Device manager, you have all USB hub power management turned off. “Allow the computer to turn off this device to save power”

  4. Some people seem to have strange trips / loss of FFB while driving, that also requires a power cycle to resolve.


in 0.8.4 i had loss of FFB using rFactor2
In 0.8.12 first time out i had a loss of FFB when leaving the pit so i restarted the game (which i had to do in 0.8.4 also) to regain FFB.
Now my Asher buttonplate wasn’t recognized anymore in game (check in Windows controllers it was there and working) but i could drive using my thrusmaster shifter which i did and i had no more loss of FFB.
My Asher buttonplate was connected via a powered USB3 hub, so after doing 2 races to be sure my FFB didn’t get lost, i connected my buttonplate in a USB port in the back of the PC, now rFactor2 saw it again did again (but only) 2 laps and had no problem with loss of FFB.
Gonna give it a longer test tomorrow and report if i find something but hope it helps someone

It sounds like you might have some grounding or EMI issues. I don’t think we did anything in the firmware side that would have an effect.

Couldn’t it be the USB hub i used is buggy? Because now with buttonplate in back of pc it worked in my short test. in the last 1.5 year i only had EMI problems when i started using my simucube but did all i could find on the web to get rid of it and never had it again. that’s why i ask about buggy hub.

Wiring can develop faults too, if moved often. But USB hubs are made by some devils. I have yet to find a 7 port usb 3.0 hub that would actually work with 7 usb devices. The first one failed after 5-10 hours, the second after a few days, and then I got an USB 2.0 hub that has worked since.
Devices connected to the hub:
SimuCUBE’s Granity USB connection
FTDI serial adapter cable
Segger J-link debugging device
Logitech G27 shifter with Bodnar adapter
Logitech G27 pedals with Bodnar adapter (*)
Teensy microcontroller for my button plate Base Station, the button plate is connected wireless via bluetooth

(*) has since been superceded with connecting the pedals directly to SimuCUBE via self made adapter

1 Like

Is it a powered USB 2.0 hub you are using? Simucube i always had directly in my pc

O and one more question is EMI somehow measurable?

Each of my hubs were powered, with a separate power supply. First one I exchanged to more expensive one, which died too. Then bought the USB 2.0 hub from another place.

EMC is measurable but only with laboratory instrumens, oscilloscope etc…

1 Like

I dare to confirm that my problems with loss of FFB in rFactor2 where the result of a ‘buggy’ powered USB 3 hub. In this hub i had connected my Asher buttonplate and my Thrustmaster H shifter. I now connected them directly in the back of my pc and i am a happy camper now for the first time realy enjoying the masterpiece simucube firmware.

So anybody with kind of same problems, i hope this info can help you too.

Hello, I’m driving endurance races on rF2, so far I had 100% power in the simucube firmware and in the game 25% strength, yesterday we left the 4h race without problems, today I tried to put 100% power in the game and in the simucube firmware gave 30% strength, and after 2-3 rounds ffb is lost, I tried it several times

Were there any faults visible in the Configuration tool? was the fault permanent, requiring a restart of the game, or did cycling e-stop clear it?

just restart the e-stop button, and it worked for a while

The problem of disconnecting the steering wheel was again raised in Assetto Corsa. I was standing in the box for about 30 minutes and suddenly disconnected. I tried to turn off and turn on the simucube I was in the box but the steering wheel did not work, it is necessary to restart the game to get back to normal. USB ports energy saving is set correctly. I photographed the lights of the simucube at the time of disconnection.

Difficult to see from the screenshot, but does that show as two leds; i.e the normal power led and the led adjacent to it?

I will check the code, but unfortunately I have full-time commitments and deadlines up to beginning of December, so it might be a while until I can get back to this.

I think so, I took the picture without checking too much.:cold_sweat::sweat:

This disconnecting realy is a strange phenomin because after the relaese of the current firmware i had almost non disconnects and rf2 was perfectly playable for me. Yesterday i was running the game for 4hrs without problems and all of a sudden the disconnects started to happen again. Today i started up my rig again and still disconnect issues.
With the post of @Cruz i thought i share my issue too. Fyi nothing changed on my hardware setup nor software.

About the simucube leds. I only have two green leds burning on my simucube and that always have been that way (mmos and all simucube software i used) and they stay green also when disconnect happens

My problems kept getting bigger and bigger i couldn’t do a lap without loosing FFB anymore so i decided to revert back to mmos and ioni firmware build 1108. The proces went okay but still i have got problems because i don’t have FFB at all in rF2.
Now when i go to control panel i see my MMOS, HE pedals, Ascher wheel and thrustmaster shifter, and when i right click mmos and click properties i see the axis moving nicely but doing this i see flickering in the control panel and Ascher wheel leaving and coming up again and when i do this often enough the Ascher wheel is becoming a unrecognized usb device.

So here is my theory and i hope you can help me @Mika: i think there is something wrong/broken on my simucube board. I don’t know if it has got diodes which prevent current to flow via the usb into the computer. but if so i think that diode is done/broken. Any thoughts?

just to inform you i did all wiring to prevent EMI issues again using the manual from @phillip.vanrensburg


I still think its an EMI related issue in your computer or on your rig.

Is it possible to do the same test with a laptop or another computer?

Could try with a laptop i think. Will do tonight.

I just wanted to make sure, that you have everything plugged into a properly grounded socket and that if you use an extension cord, that cord also has grounding. This really does seem like a grounding issue, but one can never be absolutely sure. From my part, I haven’t seen a failure in a SimuCUBE board that could cause this, but it doesn’t mean that there absolutely couldn’t exist such a fault.