Simucube firmware 0.50.x feedback thread


#21

Nothing related to FFB command processing has changed, so its very unlikely that this would be a firmware issue. But you can downgrade; you’ll loose all your profiles and will have to do the Motor Configuration Wizard again.

Steps to do so is to click Update Firmware in the new version, quit when it says “Found Simucube in firmware upgrade mode” and then use the old version from there.


#22

then its better not to mess with this if its nothing sowtware related. I have one question though maybe off topic but anyway… I am new to OSW so I learn things. I had FFB torque in Granity to 100 Hz. I changed to unlimited, is this ok? I haven`t changed any other parameter in Granity but now ffb feels a lot smoother when I use lower number on reconstruction filter in Simucube. Is this ok?


#23

The torque bandwidth limit is a low pass filter for torque output of the servo drive. Setting it to very low value makes the FFB feel smooth, but it reduces the very sharp peaks as well. Using higher bandwidth with the reconstruction filter activated is the more common way to accomplish this, as the driver can feel sharper road details while filtering out the simulator induced torque grainyness.


#24

Also, if you use Simucube firmware, there is no need to change anything in Granity and in fact the filtering settings in Granity are overwritten by those that are in the Simucube Configuration Tool.


#25

thank you Mika for detailed explanation :slight_smile:


#26

darkojovanoski1986—what track are you loading when the crash occurs?

I finally figured out that the shader patch files for Okayama were defective, and the author of them released an update and my problem was solved.

If you load a different track, do you get a similar error?


#27

get same error in every track/combo. installed previous beto of Simucube and now all works as it should. strange really…


#28

Not really strange at all.
If something can be shown to be reliably repeatable then it indicates that you are not crazy and while Mika may believe that nothing has changed in his software, clearly there’s a compatibility issue.

To be completely fair, it’s likely that the other software is the issue, but only with how it interacts with the new Simucube software.

Code is finicky.


#29

We are utilizing both iRacing and Assetto Corsa extensively at our lab for product testing both Simucube 1 and Simucube 2, and we did not see this issue. Only way for us to see this issue is a poor USB connection somehow.


#30

Perhaps he’s using mods, maybe SOL and the likes?

Are you testing AC with everything stock?


#31

We are using mostly everything stock.


#32

I had a post previously about similar behavior with AC that turned out to be a corrupt file in the Custom Shader’s Patch. When my wheel was off, it would load—when it was on, it would not. However, it was isolated to a single track and an updated ini shaders file for that track fixed it. I suspect something is happening that is triggered by Shaders Patch and track or car configs being out of sync. With updated files, my wheel is working fine in AC with the latest Custom Shaders Patch and firmware 50.3.

Maybe reinstall the shaders patch, and importantly, in Content Manager, under Settings, Shaders Patch, update all the track and car configs.

One more thing . . .it just so happened that several significant shaders patch updates were released about the same time as 50.3 firmware. I originally blamed the firmware for conflicts created by the shaders patch updates.

To test whether it’s the shaders patch, you could temporarily disable it and load stock AC and see if it works.


#33

I used sol when this happened, it happened in every combo I use, sdtock tracks and cars. when I reinstalled previous beta all was fine again. I havent tested yet new shaders patch with new firmware becouse all was good with previous beta and no improvements in 50.3.


#34

I can confirm that AC without sol and shaders patch works without issue on 50.3. maybe new shaders patch will fix this


#35

Need Help, I upgrade firmware from v0.10.4 to v0.50.3, the process all fine without problem.
And after that, I lunch “Simucube Configuration Tool.exe” but the application hangs and crashed.
I have power off and on again, but still can’t working.

What should I do now?

Rick


#36

As mentioned in the update notes, you should have updated to 0.11.2 first as updating from 0.10.x is not supported anymore.

You will have to access the DFU dip switches and set them to DFU mode, then use the bootloader_and_reset_all_settings.dfu file from 0.50.3 to reset the system. Then you can use either 0.11.2 or 0.50.3 to reconfigure the system.


#37

Thanks, Mika.

Sorry for not follow up this issue…


#38

I apologize that his has happened, but we expect that users in general have a supported version (0.11.2) and didn’t have time to test every possibility of old versions.

Let us know if you need help on getting going again - we are glad to provide further instructions.


#39

Hi Mika

Don’t worry, I have make it back to normal now. Thanks for quickly replying as always.

Rick


#40

If I update from 0.11.0 will there be any issues? Is it worth upgrading?