SimuCUBE firmware 0.11 series bug reports


#61

Or, can you repeat the issue if you enable the centering spring and bumbstops in SimuCUBE, and just turning against the bumbstops - no game required.


#62

If there is an encoder issue, then you can just press e-stop and start driving without forces, the encoder does not know if there is torque in the motor or not.


#63

I engaged the E stop and rotated the wheel while watching the simucube overview. There are two specific degrees of rotation where the on screen wheel appears to skip a few degrees.


#64

hmm, interesting. You might want to connect to the drive via Granity, to see if you can spot a discontinuity at those locations when carefully observing the Position Feedback indicator on the Testing tab.


#65

OK. Will have to come back to this tomorrow. Been a long day. Mika, thank you so much for all the help. I’ll let you know how I get on. Hopefully get to the bottom of this.


#66

If it is not happening in other games then it is probably something to do with the game… Because it is happening at the end of a rotation I am thinking it is the way the Game is handling Software Bumpstops… It doesn’t look to be happening mid turn but only when it stabilizes… Does it happen with other cars in RF2. It would be weird that the encoder would slip but there could be something going on there as it is at specific degrees, however, if it is the encoder it will also happen with every other game and car at those specific degrees of rotation as well.


#67

The issue was indeed in-game as @bsohn suggested . Turns out that somehow the bloody ‘steering help’ was changed to LOW. This was causing all the wheel movement. Really sorry for the false alarm folks. Many, many thanks for the help @Mika @bsohn . Elated and embarrassed at the same time.


#68

Glad to be of help and glad you figured it out.


#69

SimuCUBE Boot : 0

SimuCUBE Boot : 11

SimuCUBE Boot : 0

Flash settings data loaded : 0

Initial config has been previously performed. Initializing Drive. : 0

State: Initializing Drive : 0

First-time drive initialization : 0

SMBus baudrate initialized successfully : 0

Drive init stage 1, position : -308

Read MMC value from Drive : 12000

Read Motor Resistance value from Drive : 2744

Read CPR from Drive : 40000

Read Drive Version ID from drive : 11001

SM Watchdog disabled successfully : 0

Waiting for faults to clear : 0

Waiting for servo to be ready : 0

Drive init stage 3, position after faults cleared : -227

Drive init stage 4, phasing, current position : -194

Drive init stage 4, phasing, current position : 3246

Drive init stage 4, phasing, current position : 5000

Drive init stage 4, phasing, current position : 3394

Drive init stage 4, phasing, current position : -565

Drive init stage 4, phasing, current position : -4413

Drive init stage 4, phasing, current position : -5826

Drive init stage 4, phasing, current position : -4100

Drive init stage 4, phasing, current position : -158

Drive init stage 4, phasing, current position : 3631

Drive init stage 4, phasing, current position : 5079

Drive init stage 4, phasing, current position : 3410

Drive init stage 4, phasing, current position : -511

Drive init stage 4, phasing, current position : -4331

Drive init stage 4, phasing, current position : -5754

Drive init stage 4, phasing, current position : -3911

Drive init stage 4, phasing, current position : -429

Drive init stage 4, phasing, current position : 2543

Drive init stage 4, phasing, current position : 3441

Drive init stage 4, phasing, current position : 2201

Drive init stage 4, phasing, current position : -226

Drive init stage 4, phasing, current position : -2150

Drive init stage 4, phasing, current position : -2665

Drive init stage 4, phasing, current position : -1883

Drive init stage 4, phasing, current position : -520

Drive init stage 4, phasing, current position : 336

Drive init stage 4, phasing, current position : 401

Drive init stage 4, phasing,


#70

Please post the whole log - that just a beginning of a normal startup of the SimuCUBE. You can use pastebin.com or something if this forum software does not allow it.


#71

Yeah, sorry for the uncomplete logs, I didn’t notice there was a string limit
https://pastebin.com/JLEWR5tn


#72

That log includes normal simucube startup, then you manually reset wheel center point, then you launch granity and come back from there, then you run the motor configuration wizard as far as I can see.

If you are loosing center point while driving, then your shaft coupler is indeed slipping, or the encoder is slipping or is loosely mounted that allows it to shift a few degrees from time to time.


#73

I don’t understand anything.
Sorry…


#74

It was the central screw of the encoder! After tightening everything is fine, yeah!!!
Thanks Mika


#75

Glad you got it fixed!


#76

Howdy,

After a while I turned up my SimuCUBE on and update to latest firmware & software and the wheel feels stiff now to turn after it has phased (Last time I have had the manual centering configured).

I can feel the wheel chattering and even hear some noises from it.

When I put the profile in to safe profile, the wheel does not have the force anymore but when I adjust the overall strength in my current profile, it does not have the same effect.

I have small mige. Any other information I can provide?

Here’s my log after the start up:
https://pastebin.com/Qf6GbEvy

FFB effect creation log:
https://pastebin.com/vJc93L1q

Edited to add that the wheel works in ACC somewhat at least but I am worried about the wheel behavior when not in any driving title.


#77

stiff to turn sounds very, very strange. Have you tried creating a fresh new profile? Is the wheel stiff to turn also in Granity mode?


#78

Tested some things with a new profile and I noticed that it was the Damping, Friction and Inertia setting that made the wheel stiffer.

I had following settings:
Damping 3%
Friction 0.75%
Inertia 6%

Should those values make the wheel a lot heavier than without?


#79

yes, those will make the wheel heavier. There might also be grainyness, if you have low resolution encoder. I guess you have 5000 PPR / 20000 CPR?


#80

Aye, exactly that.

Glad it was only those filters and sorry for making false post. Got a bit worried when wheel suddenly changed. Just have not used those filters before :smiley:

Sent you some Discord PM’s too but you can now ignore them. Thanks!


SimuCUBE Open Source Firmware Development Update Thread 2
SimuCUBE Open Source Firmware Development Update Thread 2