Simucube 2 True Drive Paddock Early Access

I disconnected the power brick completely and removed usb from PC, Reconnected power, connected USB direct to PC (was connected via powered usb hub) tried with wheel on and off but still the same issue unfortunately, as said previously it works completely fine with TD Classic.

Just received the mail, 2 hours and 20 minutes later.

everytime I try to import a “classic” profile or I save some ffb edits true drive paddock crashes, rendering it completely unusable for me at the moment.

2 Likes

I am also unable to import a profile. Tried to enter manually, I filled all the fields but had nothing for the embedded video. Get an error and request to fill all the required fields, so put … and still wont allow me to save.

1 Like

I’ve managed to reproduce the crashing bug.

But I was not able to repeat the bug where I was not able to save a profile.
You need to have the following:

  • Title field
  • Description
  • Game settings

It just crashed when i tried to save something from the “hardware settings” section, using the “save on simucube” button

It would seem like, that the following issues are related to each other, and that solving them will be possible:

  • True Drive Paddock version always crashes on exit
  • True Drive Paddock crashing on startup on some systems
  • True Drive Paddock crashing on importing settings from .ini file

I might rush a test build right now to get data from your systems. However, tomorrow it is a national holiday in Finland, and I’m also having the Friday off, so we’ll get an official fix on Monday at the earliest.

2 Likes

A test build is available that has possible fix for

  • True Drive Paddock version always crashes on exit
  • True Drive Paddock crashing on startup on some systems
  • True Drive Paddock crashing on importing settings from .ini file

and a definite fix for

  • True Drive Paddock crashing when saving hardware settings on the hardware tab
    • workaround for saving hardware settings is to save them via the Classic application instead.

Can you show us a screenshot where you have an error in making a profile?

Hi Mika
Sorry it was me, I forgot the description. Just tried it and its worked.

trayminimized doesnt seem to be working properly anymore. When minimize application it doesnt go to taskbar, and when hit close on the app it fully closes it. But the app does start up minimized into the taskbar.

1 Like

Is this especially for the Paddock version of the application?

Yes thats Correct. Didnt try with the offline version

After the long weekend, we have read a bunch of feedback left from the software, and are starting to work the reports and ideas presented there. Also under investigation will some issues with the software crashing.

some feedback:

  • the wheel indicator does not track in Paddock until the online app has logged in and sent a profile.
    • will use 900 steering angle and track instead of just showing 0.0
  • trying out online profiles takes too many clicks and also requires to add the profile to one’s own profiles
    • “quick try” -feature is being developed now

Then there are some crashes:

  • these have been difficult to debug so far
  • we can’t repeat some of them at the moment, and we have several windows 10 systems to test with.
  • most of the crashes seem to go away with just moving to 64bit release
    • all releases in the future will be 64bit only

Mika,
Can you confirm if you were having the same issues with trayminimized as i described above?

Yes, it is a minor issue and is on the list of things to get right.

got the same issues, it crashes when importing a ini profile

1 Like

Hi @Mika,
can I import my old profiles into the paddock??
I tried creating a new profile but the only .ini file I can find is the profile backup.ini
Thanks,
Giacomo

EDIT: I found a way but i need to export all profiles one by one first. There is no way to actually have them all imported at once like the offline version?

it crashes while importing