SimuCube 2 and V-Rally 4

I see V-Rally 4 is on the Not Working list but I thought I’d check in to see if anyone had any luck with it?

I tried and it recognizes the wheel but you have to assign Left and Right separately so even though they individually work it breaks steering because you can’t assign the wheel to both at the same time.

Pedals (ProtoSimTech PT-2s) are a weird one where the clutch works fine but the throttle and brake are glitchy and appear to register but only as instant “blips”.

This is probably a game best suited to controllers anyway but I was so impressed with the game I wanted to try it out on PC (dead cheap on Steam right now) and record some video.

I even wrote it up I was that deeply impressed. There are some videos linked here if you want to see it in action. It’s simcade, be warned, but has very, very satisfying handling.

One of its big features? Procedurally generated tracks by stiching together segments of road/path networks with road blocks. It works so well and so naturally I had no idea it was doing that and, in months of game play, I don’t think I’ve repeated a single route. And yet it all feels first class like a normal hand-crafted map.

I tried to get in contact with the developers when Simucube 2 was released, but they didn’t really do anything at that point. However, we did provide development hardware for them and they did use it to improve support in later games/sims they made.

1 Like

Thanks, Mika. Actually surprised you guys went to that effort for V-Rally. Good on you for trying.