Simucube 2 and Ascher wheel, lagging and skipping gears in ACC

Since last couple of firmware updates on the Simucube, especially latest 2021.5 strange things are happening on my Ascher in ACC. It feels like the gearchanging has a delay sometimes, and it sometimes dont change gears when i shift and sometimes it double shifts. I started getting these problems after first 2021 update and with .5 it got a lot worse.

Have you tried downgrading to an old version just to be 100% sure it is not happening in the old versions?

Does this happen for up and downshift?
Had a similar issue when down shifting with my custom made bluetooth wheel using Ascher shifters and it was a broken cable connection. Sometimes it worked while driving, sometimes not.
How does it behave when you‘re not driving (inside true drive you should be able to see which buttons are pressed)?
Esp. test what happens when you hold the shifter while shaking the wheel, when you see that it toggles you should be in the same situation.
Another problem could be a defective micro switch.

This also could explain why it is getting worse over time, as the broken cable will get worse due to feedback vibrations.

Of course when it happens for both shifters it should be another issue as the propability for two broken cables/switches is very low.

What about the other buttons? If it is due to bluetooth issues they should behave the same. You also can try to assign another button for shifting in the game and see what happens.

I had this with my ascher BB and f1 wheel, since changing stock batteries i havent had a skip in a year.

I have not, but i think its not possible to downgrade firmware?

As i can recall its only upshifts that has been a problem so far

Interesting, was actually thinking about that, they say it should last 3 years, i havent had mine more than a couple of months. I’ll try that! Thanks

If it is not the battery, I suggest you contact Martin for some advice.
As you can see in the boostedmedia video about the f64 USB V2 wheel the shifters are connected via headers - not sure if this is done the same in the wireless wheels - but it is also possible that it‘s gotten loose.

Changing battery has so far helped with the problem. Thanks a bunch! @Kevin_Michael

2 Likes

Doubleshift problem has come back again already. Ordered a new battery…

Installed the new battery but doubleshifting persists. Have also separated the usb-cable from touching any other cable but no result. In ACC I have now increased the “Gearshift debounce” from 70 to 250ms and from just a couple of laps testing it has worked so far. With 110ms i got a doubleshift straight from the pit

can you check if the double presses are visible in DiView software as well?

From DiView, “Knapp 9” is Upshift and “Knapp 8” is Downshift
I pressed on time on each back and forth and it is doubling the upshift many times

I wonder if the microswitch is broken.

In the ascher or sc2?

in the wheel.

Can you test if it is always a double “press” or can you get it to glitch in another ways as well?

It is not always a double press in DiView but 80% of the time. None of the other buttons does it so far

Simucube 2 Pro_Buffered.txt (2.9 KB)
I even got a 3x shift now (:

Row 18-23 3x shift
Row 34-35 single shift
Row 64-65 single

All buttons doesnt show up in DiView I might point out.
Right funky doesnt show left/right click and lower right buttons blue and yellow doesnt show in DiView.
They work in game and show in TD