SimuCUBE 1 E-Stop is PRESSED Issue


I’m having an issue with the E-Stop is PRESSED on the SimuCUBE 1. The e-stop is DEFINITELY NOT pressed. I’ve video recorded it: Video of Issue . I’ve also checked with Granity for any faults and there is:

Fault location ID1 440205 (info)
Fault location ID2 0 (info)
[ ] Initialized !
[ ] Error recovering
[ ] Tracking error warn
[ ] Target reached
[ ] Enabled !
[ ] Run (drive active)
[ ] Homing active
[X] Braking
[ ] Permanent stop
[X] Voltages good
[X] Fault stopped !
[ ] Ready for use
[X] STO active !
[ ] Safe torque mode
[ ] Standing still
[ ] Quick stop active

[ ] Tracking error
[ ] Over velocity
[ ] Hardware
[ ] Over temperature
[ ] Feedback
[ ] Over current
[ ] Internal comm error
[X] Power stage forced off !
[ ] Under voltage
[ ] Over voltage
[ ] Motion range
[ ] Firmware error
[ ] Init
[ ] Motion
[ ] SimpleMotion
[ ] Configuration

What caused this fault?

Fault location ID1 440205 (info)
Fault location ID2 0 (info)

! = reasons for inactivity[X] GPI 1
[X] GPI 2
[ ] GPI 3
[ ] GPI 4
[X] GPI 5
[ ] GPI 6
[ ] HSIN 1
[ ] HSIN 2
[ ] ANA1 as digital
[ ] ANA2 as digital
[ ] ENC D
[X] Hall U
[X] Hall V
[X] Hall W

[X] Soft enable
[ ] Phys enable !
[ ] Pos feed enable
[ ] Neg feed enable
[X] Home switch
[ ] Clear faults

Analog in 1 -0.01 V
Analog in 2 0.00 V
Analog Enc A 1.31 V
Analog Enc B 1.31 V

HV bus voltage 47.7 VDC
Device temperature 17 °C
Actual current limit ±12.9 A
Last limit reason None
Output current 0.04 A
Velocity feedback 0 r/s
Velocity feedback (raw) 0
Position feedback 2.38419e-06 r
Position feedback (raw) 10
Setpoint value (raw) 0

Debug 1 -1
Debug 2 -1
Debug 3 -1
Debug 4 -1
Debug 5 -1
Debug 6 -1


| GCFWVER=10720 | HWTYPE=11201 | HWSERIAL=112011995 | BUILDREVISION=3047e45
| CEI=2 | UID=3f7de434 | SMO=0 | TRF1=0
| TRF2=0 | TRA1=0 | TRA2=0 | MPP=0
| NOTCHFILT=655616 | TED=0 | TEF=0 | TEI=0
| SERIALENCBITS=22 | COMMUTATIONCFG=234327 | HAO=0 | FBR=1.04858e+06
| FBD=5 | FB2D=0 | TBW=11 | KVP=300
| KVI=30 | KPP=50 | VFF=0 | AFF=0
| PFF=85 | CM=2 | MT=3 | AD=0
| FLAGS=131100 | MMC=12.86 | MCC=11 | FOC=6
| FOV=51 | FUV=30 | FPT=1000 | FVT=100
| FEV=30000 | FMO=0 | LSF=0 | LFO=0
| AXS=1 | AXT=3 | FFT=0.1 | TSR=0
| TCH=2.09715e+06 | TTR=1 | TBT=0 | CRI=3
| DIV=50 | PIF=2500 | MUL=50 | CAL=10
| CSD=10 | CVL=1000 | CRV=100 | MR=2.24
| ML=6.505 | MTC=1500 | MPC=8 | MMS=1000
| CAO=0 | HOMING=0 | HMV=100 | HMA=10
| HMH=500 | HMT=1 | HHL=0 | HLL=0
| HMF=0 | HSA=0 | HSS=0 | overrideAddr1=0
| overrideAddr2=0 | overrideAddr3=0 | overrideVal1=0 | overrideVal2=0
| overrideVal3=0 | BED=1.5 | BER=0 | BDD=1
| CAPS1=6.29143e+07 | CAPS2=81823

If the STO active signal does not track the estop button status, then either the button is broken or there is a wiring issue.


Thanks for Replying.

I’ve checked the switch and swapped it for another one to test, same issue. The E-Stop wires is soldered directly to SimuCube 1 board by Ben Darley(MIA).

Does the RED E-STOP wire go to 1, White to 2 on E-Stop Switch, I can’t remember?

Any other trouble shooting tips?


The green connector block is detacheable. It comes in two pieces.


Ben Darley chopped the Green blocks OFF and Soldered a type of audio connector to the E-Stop on the SimuCUBE board.

I meant the E-Stop switch itself. Red Wire to 1, White to 2?

See the picture on the page for correct pins. It is the two pins closest to the encoder connector.

Cannot really comment on the color of wires. There are no standards that I know of.


Ben Darley chopped the Green blocks OFF and Soldered a type of audio connector to the E-Stop on the SimuCUBE board.

I meant the E-Stop switch itself. Red Wire to 1, White to 2?

I might have to take a picture to show you.

Could it be Firmware related?

No, not firmware related.

We did not manufacture the estop button you are talking about. You need to figure its pinout on your own.


Give me a few minutes to take the lid off the controller box. Please stay online.


I don’t have the right torqx bit to take it off. I’ll have to go buy one. I’ll post pics when I can.

Did you measure the estop button with a multimeter?


No. I’m not very experienced with a multimeter but which voltage setting should I set it at and which part of the E-Stop should I test?

I’ve attached a pic of the soldering of the E-Stop.

@Mika I’m not getting the USB connect sound anymore after updating to the latest firmware.

Should I try this?

Alright, tonight I had the time to re-do this all and I fixed it. @rung168 this may be a key to your problems as well.
I tried quite a few other things before it finally worked. Here I describe what finally worked.

I used a different pc, set-up the simucube in DFU mode (case c). I also installed the simple motion v2 VCP driver from the wiki.
After connecting with the X3 port, the pc recognized the STM device. However in device manager it appeared with the yellow triangle with an exclamation mark.

The first time I didn’t check this, but defusedemo worked and uploaded the dfu that time. But still I think it may have corrupted (a part of) the bootloader.

This time I manually installed the STM devices driver as shown in the troubleshooter of the simucube user manual.
I ran defusedemo in administrator mode and uploaded the file as instructed by the manual.

Afterwards I switched the DFU switch on the board back into run mode and restarted it. Connected to simucube software. Also this time I turned on the enable ioni feature in the advanced tab. Changed the connector to the X4 port. Still the simple motion bus names had not changed, however this time I WAS able to connect to the servo.

I uploaded the motor configuration file, applied it and restarted granity.

I reconnected with the X3 port again, opened simucube software and turned the ioni feature off again. Restarted the simucube firmware again and this time I was able to successfully initialize the motor. I used the default method to initialize (connect to ioni/the one on top).

Everything worked. All errors were gone. I was happy as a kid.

In summary: put your device in manual DFU mode, do the hole stuff again and don’t forget to manually install the STM driver before you run defusedemo.
I think this has caused all the problems in some strange way. Although, with the drivers not installed, I would expect that defusedemo would give an error if one would try to upload the bootloader. However, maybe it does not and the installer just forces the bootloader in the simucube, thereby corrupting it in some way.
Maybe this is something that should be clarified in the manual. I would suggest to describe that people should check the device manager, and if necessary install the driver manually already in the installation steps and not at the end in the troubleshooter. Furthermore run all applications in administrator mode.

None of the things you describe have anything to do with IONI reading e-stop button. But good that you got it working :+1:


I have Not got it working, that was somebody else’s solution to the issue that I should maybe try?

I don’t even have the USB sounds anymore when I first turn on.

you probably somehow mis programmed the STM32F4 processor. If you move the dip switches to get it to DFU mode, you definitively should see STM32 Bootloader on USB connector.


I managed to get the SimuCUBE into DFU mode and flash the firmware. I flashed it with 50.4d I think but when I go to launch 50.4d it says it’s older than the version that is on the simucube.

I was also talking to @bsohn Brion Sohn and suggested to get help from Esa?

I think there’s a fault on the SimuCUBE board itself. Can’t buy another one as they’re no longer manufactured.

I tried using a paper clip on the E-Stop wires and it didn’t work or I was doing it wrong?

@Mika @Esa

Made another video. Still not working. My conclusion: Board or IONI failure.

Did you already measure the resistance of the actual button / check continuity with it disconnected from the system?