Simucube 1 can't connect to software

For efficient support requests, please consider using the template below. Fill-in the (blanks) and provide additional info when necessary. Thank you! Best regards, Granite Devices team.

I have a question regarding (Simucube 1 regarding I can’t connect with software.

My hardware configuration:
[SimuCUBE based OSW kit with CM110 case]

  • Servo Motor: MiGE 130ST-M15015 30Nm 10000ppr (40000cpr)
  • PSU: Mean Well 480W/720W peak (Noiseless) 30Nm
  • Servo drive: Ioni Pro HC (25A)

Problems arise when:
-can’t connect to software.

I have attached following files:
-(consider adding saved Granity configuration file .drc)

I also would like to share that (additional info).
Windows 10 pro reinstalled
I must be missing a driver or something somewhere.

And of course you have selected ‘Enable Ioni USB configuration’ under the advanced tab in the Simucube GUI?

under advanced it will not let me click anything at all

Well, that’s because you forgot to plug the USB cable back in to the X3 hid port…best to use 2 cables if you want to access Granity too…

i have tried both plug in locations

i plugged in both at the same time and still nothing.
using 11.2 as advised

What are you trying to achieve here? Was this working before? What do you want to change?

To get it working. No games work right now. that is all i want to get done.
Yes it was working before the Windows 10 Reinstall.

So there is no need to access Ganity software right now to get it working Nothing in there will impact the connectivity to the Tuner GUI and Simucube, Simucube HID uses a different processor to the IONI drive controller.

So you need to start changimg USB cables and connect to the chipset-based USB 2 ports on your motherboard.

PS: Stay away from the firmware-flashing procedure as well, that shows me you are using an incorrect tuner-gui version/fw to what is installed on your Simucube…

Next step after you change ports and usb cable, please show me a screenshot of your tuner advanced tab

i’m plugged into the chipset 2.0 usb ports
changed cables too



Where i plugged in.

The X3/Game port should be a basic USB gaming HID port, not any serial port or something such. The FTDI driver loads to support the X4 port, which is the connection to the Ioni.

What do you have under a Gaming ports? Under Devices and Sound hardware?

It seems you are not connected to the Simucube at all, based on that info. Do you ave a laptop to plug it into just to test the Simucube?

Any yellow question marks in your Device Manager? Have you installed the proper chipset drivers for your motherboard?

Chipset Drivers & BIOS updated
Simucube works fine on other PC (i7 7700k w/1080ti)
Simucube worked fine on (i9 9900k w/2080ti) until windows 10 reinstall
There on no Yellow question marks in Device manager.
Blue arrow shows what shows up when i plug the simucube in
PS I have been locked from making any new replies due to being a new user.

How do I fix this?

Uninstalled both and changed ports. same thing installed back.

I have concluded that it is in fact the SIMUCUBE doing this. It wasn’t doing this before on the i7 pc but it is now. after the windows reinstall somehow it got corrupted or changed i don’t know. Is there any way i can reflash the simucube?

I know by far i can be wrong. I just don’t know what else to try.

USA central Time Zone
Just give me a time and i can be online

10-4 i’ll be here.

One connects but the other doesn’t.

Just select that driver and uninstall it from the blue arrow (top one) Then remove the USB cable and plug it into another port…

Also, check what is I stalked under Human Interface Devices. The fact that it works elsewhere is a PC OS issue, not a GD issue.

Let’s see if we can get the drivers sorted. Just post new comments by editing your post above for now.

Something got cocked up with driver Detection/installation I guess. You could probably uninstall 3rd party drivers, then motherboard drivers, dud one to Simucube, reinstall motherboard drivers and then have the Simucube as first device to be connected.

Which Timezone are you in? I could potentially help you tomorrow via a remote session to see if we can get it sorted.

Without a USB connection recognised by Windows to the device, you won’t be able to flash it…but I don’t believe it is the issue anyway.

So if you have teamviewer, I can try to resolve this for you tomorrow. But you need to leave Notepad open on your desktop, so I can relay instructions that way, if needed…or, Skype or WhatsApp…

1 Like

Ok, I will check my schedule tomorrow morning AEDT and drop you a message. Please pm me your WhatsApp number :wink:

Perhaps Joe Sullivan sees this and might sort you quicker… it I will do my best approx 14 hours from now…

Just make sure you download teamviewer and install it so long, please.

1 Like