Simcube 2 sport vibration anormal?

Hi. I wanted to tell you that I have a simcube2 sport. When you stop at the amount of degrees that you set, regardless of the value, it makes a strange vibration. I don’t know if it’s a technical or configuration problem. I need someone to help me. Thank you!

For start, please show your bumpstop settings from the profile and the hardware settings tab in True Drive.

Thanks! I need a email adress to send the video and screenshots. I have video .mp4 and this page don’t accept this extension.

1 Like

if it is not too large video (<100 MB), then support at will work.


I am using Simucube Sports.

But when you turn it on, it suddenly vibrates. The vibration is very severe.

And in high torque mode, this vibration stops.

A video clip of this phenomenon is also attached.

How can I solve this problem? please answer my question

The safe torque mode at device start has quite a bit of added damping. If there is any flex in the system, or a loose QR or loose extension shaft, it can cause the torque controller to make the system a rotational spring-mass system and it will cause the oscillation/vibration.

Can you show a picture of your rig?

What is rig talking about?

Vibration occurs in this area.

It is a video file of this phenomenon.

That can also happen if your motor is not mounted rigidly.

Rig: cockpit, chasis, tablemount

Take a look at True Drive Other filters: friction May be too hi, move down the slider

The motor was securely fastened to the cradle.
it was used well for 6 months, but suddenly this happened.

Can you try this?

1 Like

SQR was disassembled.
When Simcube is running, vibration occurs equally.

I am not sure where should I fix it?

This is my true drive. Can you see and let me know?

Disable resonance reduction and lower your inertia to 10% or less. Of course, alternatively, you can bypass safe torque mode an go straight to high torque.

What has inertia got to do with his problem? Why do you say he should reduce that filter?

I just replicated those setting and the inertia slider directly affected the vibration. I got the same vibration as he presented in the video, and lowering the inertia got rid of it. ( In safe torque mode btw, which he stated was where the vibrations are present)

Few things:
No one runs SC2 in safe-mode…
That resonance can occur under certain conditions, whilst it is annoying, it doesn’t do any harm, the moment you have a load on the wheel (hands-on) it should disappear.
He can probably reduce TBW, or, slightly alter his DFI settings

Again, just set the wheel to auto high-torque and auto-startup of the TD application. Problem solved.

I suspect Tero might have to slightly tweak some of the internal low-level drive-filters to remove this harmonic for that specific servo. Again, it doesn’t cause harm, there are ways to circumvent it.

I’m aware of all of that. My suggestion was just that, a suggestion, to confirm that my findings remedied the vibrations as they did on my unit when placed it under the same settings and scenario. The thing is, not everyone lives in an environment where they can just have the wheel startup in high torque mode all the time, for safety concerns, as they might have kids that play around the rig, or what ever the situation may be. Before the auto high torque feature was introduced I faced this problem as well. Usually I would start up the rig and go make a quick snack and sometimes completely forget about the vibration. But since I live in an apartment, with the vibrations being so strong, it really bothers the neighbors and I would run to hit the E-stop :joy:. Just sharing my perspective.