SC2 Pro - Safety Issue

In the few months I’ve had my SC2 I’ve experienced several occassions when it’s been dangerous.

What I experience is that, when the green lights come on in the sim, the wheel takes an immediate, and full power turn. It’s not a reult of being hit, or wheel spinning etc, it’s like the wheel is immediately trying to get back to a previous/cached position with every effort it can - and it’s way more powerful than I generally have my wheel set.

I haven’t managed to identify the source of the problem, however I suspect it could be due to the use of the emergency stop. Perhaps the wheel remembers where the wheel was positioned before the emergency stop was hit and tries, at it’s next power up, to immediately put the wheel back to that position. Does that make sense?

Is there a way to get the wheel to clear any caches and not try to occassionally harm me when it engaged in a sim? Thanks!

What sim? I’ve experienced this in rfactor 2 when for example if you spin and hit pause then move the wheel and unpause, it will jump to it’s last position before you paused if that makes sense. Same will happen if your wheel is off centre when you return to pits and click drive without centring your wheel


Did you find a way to ‘fix’ it? To minimise the jumps?

Interesting I don’t have that in AMS2. I haven’t played rf2 in a while but my only solution was to engage the torque off button when pausing and unpausing the game. What firmware are you on? I’m using 2021.7

no, this is not happening. E-stop button function is not in any way related to encoder signal path.

This is probably due to game bug, similar to the (perhaps now finally solved issue) where the wheel would pull full left/right when entering a car in in online race.

The very latest - I try to stay up to date (on this if nothing else in life ;)).

OK, that may explain it a bit. My recall suggests that every time it pulls to the right approx 90 degrees - that wasn’t terribly consistent with my theory.

What was the game bug you talk about - perhaps that was it?

It was a bug in Raceroom Racing Experience. We never managed to repeat it. It might have finally been solved when they updated their FFB code around 6 months ago.

@Mika, you are not talking about this one, correct?

And OP has issue with AMS2, not R3E, even if for some there is only iRacing and “everything else”. :rofl:

No, not talking about that one. But it might have been the same issue that caused the online issue as well. But we were never able to repeat it.

It is interesting that OP has this issue. Haven’t seen such happening in other titles. And we do test other titles as well, even though I do spend most of my personal driving with iRacing.

Is there some logging I could do so, if it happens again, I can share it with you?

Any logging I can collect that would help?

So it happened again, just now - seemed to be associated with an Oculus Link disconnect tonight. The wheel moved very rapidly 90 degrees to the right, even though I just brought the car to a halt on track - the wheel onscreen in AMS2 did not move.
Are there logs I can provide that would help troubleshoot this issue?

It would appear that the game stops communications with the device when usb bus has such momentary issue and strange things happen.

It is unlikely that the device side logs would be able to detect this in any way.

You can start executable with log parameter.
E.g .
“Simucube 2 True Drive Classic.exe” log
That should create debug log.txt in the executable directory.

I wonder if a dedicated USB PCI card for the Oculus or SC2 would solve this problem?
USB drops have always been so hard to diagnose.