SC2 Pro & iRacing FFB sometimes doesn't work but after reboot it works again

Hi there,

Since a couple of months i’m a owner of a Simucube 2 Pro. Since about a month I regularly have the problem that I don’t get FFB within iRacing. I can solve this by restarting Truedrive, SC2 Pro and my Ascher F28-SC-V2.

But the problem is, it also comes at unexpected times. Like, for example in the middle of the race after a pitstop my FFB was completely gone.

I already updated to the last latest firmware and software, but unfortunately that didn’t offer a solution.

Any idea what is causing the problem and what I can do about it?

Model: Simucube 2 Pro
Software release: 2021.8
Firmware version: 1.1.33
Servo Drive firmware version: 10829
TrueDrive version: 1.1.33

Thank in advance for your reaction.

Best regards

For a start, check all your connections of the cables. Power, USB, both on SC2 side and on PC side *and dont forget the connectors on the power supplies).
Also try changing out the USB cable for another one.

Hi @Doubleoz - this sounds like a frustrating problem, but if we’re lucky, it’ll be similar to a few other cases reported here.

First, are you losing all control and force feedback, or just force feedback?

Second, when you lose force feedback, can you check truedrive and see if it reports the Estop button is pressed?

If I recall the wiring of the estop is that when it’s in the up position, the electrical circuit is ‘closed’ and electricity gets out one pin of the simucube and back in another.
When you push the button, the circuit is ‘opened’ and the SC reports that the button is pressed.
There are lots of other conditions that can cause an ‘open’ circuit - a loose connector, broken wire, etc…
The good news is that these conditions show up on true drive as the button being pressed, which should make it easier to troubleshoot.

@Raimond and @JackSC first of all thank you for your reaction.

@Raimond I did check all the connections of the cables and they seem to be fine. I also tried different USB port (2.0 and 3.0) but that doesn’t make a difference. Haven’t tried a different USB cable though. Have to check if I have another one myself.

@JackSC it is frustrating yes. I’m only loosing feedback, so I can steer the car but it’s very light with no feedback. The E-stop isn’t pressed when it happend. The weird thing is also that after a reboot of the software, SC2 and wheel it works fine again.

But when it happens next time I will figure out if I can find anything in the log in true drive and post it here.

Hmm, this is definitely a tricky one.
Sounds like your unit is new, but your driver has only been out a few weeks, so you would have started with a different driver/firmware.
Can you try going back to the driver version you started with?

Instructions are here:
Simucube 2 firmware downgrade - Simucube 2 - Granite Devices Community

@JackSC sorry my late reaction. I had the same problem with older drivers. I was hoping that updating my driver would solve the problem but unfortunatly that was not the case. The last couple of days I didn’t had any problems the moments I played. I will wait until the next time it happend and then will look if I will find anything in the log.

1 Like

The e-stop is not physically pressed or TD is not showing it as pressed when the problem occurs? The latter is the important thing to verify.